aboutsummaryrefslogtreecommitdiff
path: root/graphics/grads
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2014-05-24 22:55:31 +0000
committerGreg Lewis <glewis@FreeBSD.org>2014-05-24 22:55:31 +0000
commit0e4743824e8ed53d22b8f752c43174a94790408d (patch)
treebec7a97bd9c86ee3303445ff3a60fb80bb734a2d /graphics/grads
parentd1f3c8531516ea2b01cb16fb6854ad9593916ac4 (diff)
downloadports-0e4743824e8ed53d22b8f752c43174a94790408d.tar.gz
ports-0e4743824e8ed53d22b8f752c43174a94790408d.zip
. Fix LIB_DEPENDS format.
. Make STAGE compliant.
Notes
Notes: svn path=/head/; revision=355098
Diffstat (limited to 'graphics/grads')
-rw-r--r--graphics/grads/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/graphics/grads/Makefile b/graphics/grads/Makefile
index 8f16b5e42781..ef23cbf1eb2a 100644
--- a/graphics/grads/Makefile
+++ b/graphics/grads/Makefile
@@ -16,9 +16,9 @@ COMMENT= The Grid Analysis and Display System
BUILD_DEPENDS= ${LOCALBASE}/lib/libudunits2.a:${PORTSDIR}/science/udunits \
${LOCALBASE}/lib/libsx.a:${PORTSDIR}/x11/libsx
-LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd \
- jpeg:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png
GNU_CONFIGURE= yes
CONFIGURE_ENV+= SUPPLIBS="${LOCALBASE}"
@@ -37,7 +37,6 @@ NETCDF_DESC= Build netcdf-support
PORTDATA= *
.endif
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
@@ -49,7 +48,7 @@ PORTEXAMPLES= *
.endif
.if ${PORT_OPTIONS:MHDF}
-LIB_DEPENDS+= mfhdf.3:${PORTSDIR}/science/hdf
+LIB_DEPENDS+= libmfhdf.so:${PORTSDIR}/science/hdf
CONFIGURE_ARGS+= --with-hdf
PLIST_SUB+= NETCDF="@comment " HDF=""
.endif
@@ -70,16 +69,16 @@ post-configure:
post-install:
.if !defined(NOPORTDATA)
- ${MKDIR} "${DATADIR}"
- cd ${WRKSRC}/data && ${COPYTREE_SHARE} . "${DATADIR}"
+ ${MKDIR} "${STAGEDIR}${DATADIR}"
+ cd ${WRKSRC}/data && ${COPYTREE_SHARE} . "${STAGEDIR}${DATADIR}"
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} "${EXAMPLESDIR}"
- cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . "${EXAMPLESDIR}"
+ ${MKDIR} "${STAGEDIR}${EXAMPLESDIR}"
+ cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . "${STAGEDIR}${EXAMPLESDIR}"
.endif
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} "${DOCSDIR}"
- cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . "${DOCSDIR}"
+ ${MKDIR} "${STAGEDIR}${DOCSDIR}"
+ cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . "${STAGEDIR}${DOCSDIR}"
.endif
.include <bsd.port.mk>