aboutsummaryrefslogtreecommitdiff
path: root/graphics/gstreamer1-plugins-gl
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-11-02 10:26:07 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-11-12 20:38:17 +0000
commit67f5dc164af5a5020ead937eb5dace0dfaf7e5ef (patch)
tree5291d77b1f85036173e06b6934fffd72fca603e3 /graphics/gstreamer1-plugins-gl
parentef2d73ff45602712fd586efaa21a65abf2647342 (diff)
downloadports-67f5dc164af5a5020ead937eb5dace0dfaf7e5ef.tar.gz
ports-67f5dc164af5a5020ead937eb5dace0dfaf7e5ef.zip
graphics/gstreamer1-plugins-gl: simplify quoting via :ts modifier
PR: 267517
Diffstat (limited to 'graphics/gstreamer1-plugins-gl')
-rw-r--r--graphics/gstreamer1-plugins-gl/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/graphics/gstreamer1-plugins-gl/Makefile b/graphics/gstreamer1-plugins-gl/Makefile
index de6baf1f4825..dc5326cfae27 100644
--- a/graphics/gstreamer1-plugins-gl/Makefile
+++ b/graphics/gstreamer1-plugins-gl/Makefile
@@ -15,9 +15,9 @@ OPTIONS_DEFINE= WAYLAND
OPTIONS_DEFAULT=WAYLAND
OPTIONS_SUB= yes
-GL_WINSYS= "x11,egl"
+GL_WINSYS= x11 egl
-WAYLAND_VARS= gl_winsys+=",wayland"
+WAYLAND_VARS= GL_WINSYS+=wayland
WAYLAND_BUILD_DEPENDS= wayland-protocols>=0:graphics/wayland-protocols
WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/wayland
@@ -31,7 +31,7 @@ LIB_DEPENDS= libgraphene-1.0.so:graphics/graphene \
libpng16.so:graphics/png
MESON_ARGS+= -Dgl=enabled \
- -Dgl_winsys="${GL_WINSYS}" \
+ -Dgl_winsys=${GL_WINSYS:ts,} \
-Dgl_api=opengl,gles2 \
-Dgl_platform=glx,egl