aboutsummaryrefslogtreecommitdiff
path: root/graphics/gstreamer1-plugins-gl
diff options
context:
space:
mode:
authorMichal Zielonka <michal.zielonka.8001@gmail.com>2022-09-20 17:47:40 +0000
committerThomas Zander <riggs@FreeBSD.org>2022-10-15 10:46:46 +0000
commite3b732b4791c01bdeeb671ffb557c1914763249f (patch)
treea0a745f340d9d73c9e90a998670e76d457e77a8e /graphics/gstreamer1-plugins-gl
parent90c241c4254b18ecb7db10e3de9748970845e96a (diff)
downloadports-e3b732b4791c01bdeeb671ffb557c1914763249f.tar.gz
ports-e3b732b4791c01bdeeb671ffb557c1914763249f.zip
Update gstreamer1 to upstream release 1.20.3
PR: 261585 Reviewed by: riggs,jbeich,tcberner Differential Revision: https://reviews.freebsd.org/D36850
Diffstat (limited to 'graphics/gstreamer1-plugins-gl')
-rw-r--r--graphics/gstreamer1-plugins-gl/Makefile31
-rw-r--r--graphics/gstreamer1-plugins-gl/pkg-plist21
2 files changed, 40 insertions, 12 deletions
diff --git a/graphics/gstreamer1-plugins-gl/Makefile b/graphics/gstreamer1-plugins-gl/Makefile
index a47b346cb4c4..592c2e5f6202 100644
--- a/graphics/gstreamer1-plugins-gl/Makefile
+++ b/graphics/gstreamer1-plugins-gl/Makefile
@@ -1,4 +1,4 @@
-PORTREVISION= 4
+PORTREVISION= 0
CATEGORIES= graphics
COMMENT= GStreamer GL graphics plugin
@@ -15,17 +15,28 @@ OPTIONS_DEFINE= WAYLAND
OPTIONS_DEFAULT=WAYLAND
OPTIONS_SUB= yes
-WAYLAND_CONFIGURE_ENABLE= wayland
+OPTIONS_UNSET= WAYLAND
+
+GL_WINSYS= "x11,egl"
+
+WAYLAND_VARS= gl_winsys+=",wayland"
WAYLAND_BUILD_DEPENDS= wayland-protocols>=0:graphics/wayland-protocols
WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/wayland
-pre-build:
-.for dir in ${GL_GST_DIRS}
- @(cd ${BUILD_WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} ${ALL_TARGET})
-.endfor
-
-post-install:
- ${INSTALL_DATA} ${WRKSRC}/pkgconfig/gstreamer-gl.pc \
- ${STAGEDIR}${PREFIX}/libdata/pkgconfig/gstreamer-gl-1.0.pc
+USES= gl
+USE_GL= gl glu glesv2 egl
+USE_XORG+=x11 \
+ xext \
+ xcb
+BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto
+LIB_DEPENDS= libgraphene-1.0.so:graphics/graphene \
+ libpng16.so:graphics/png
+
+MESON_ARGS+= -Dgl=enabled \
+ -Dgl_winsys="${GL_WINSYS}" \
+ -Dgl_api=opengl,gles2 \
+ -Dgl_platform=glx,egl
+
+GST_PLUGIN_DIR= gst-libs/gst/gl ext/gl
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-gl/pkg-plist b/graphics/gstreamer1-plugins-gl/pkg-plist
index fd58e0c5b7f6..9f0bc9b5d91f 100644
--- a/graphics/gstreamer1-plugins-gl/pkg-plist
+++ b/graphics/gstreamer1-plugins-gl/pkg-plist
@@ -1,6 +1,8 @@
+include/gstreamer-%%VERSION%%/gst/gl/egl/egl.h
include/gstreamer-%%VERSION%%/gst/gl/egl/gstegl.h
include/gstreamer-%%VERSION%%/gst/gl/egl/gsteglimage.h
include/gstreamer-%%VERSION%%/gst/gl/egl/gstgldisplay_egl.h
+include/gstreamer-%%VERSION%%/gst/gl/egl/gstgldisplay_egl_device.h
include/gstreamer-%%VERSION%%/gst/gl/egl/gstglmemoryegl.h
include/gstreamer-%%VERSION%%/gst/gl/gl-enumtypes.h
include/gstreamer-%%VERSION%%/gst/gl/gl-prelude.h
@@ -8,6 +10,7 @@ include/gstreamer-%%VERSION%%/gst/gl/gl.h
include/gstreamer-%%VERSION%%/gst/gl/glprototypes/all_functions.h
include/gstreamer-%%VERSION%%/gst/gl/glprototypes/base.h
include/gstreamer-%%VERSION%%/gst/gl/glprototypes/blending.h
+include/gstreamer-%%VERSION%%/gst/gl/glprototypes/buffer_storage.h
include/gstreamer-%%VERSION%%/gst/gl/glprototypes/buffers.h
include/gstreamer-%%VERSION%%/gst/gl/glprototypes/debug.h
include/gstreamer-%%VERSION%%/gst/gl/glprototypes/eglimage.h
@@ -26,10 +29,12 @@ include/gstreamer-%%VERSION%%/gst/gl/gstgl_fwd.h
include/gstreamer-%%VERSION%%/gst/gl/gstglapi.h
include/gstreamer-%%VERSION%%/gst/gl/gstglbasefilter.h
include/gstreamer-%%VERSION%%/gst/gl/gstglbasememory.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglbasesrc.h
include/gstreamer-%%VERSION%%/gst/gl/gstglbuffer.h
include/gstreamer-%%VERSION%%/gst/gl/gstglbufferpool.h
include/gstreamer-%%VERSION%%/gst/gl/gstglcolorconvert.h
include/gstreamer-%%VERSION%%/gst/gl/gstglcontext.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglcontextconfig.h
include/gstreamer-%%VERSION%%/gst/gl/gstgldebug.h
include/gstreamer-%%VERSION%%/gst/gl/gstgldisplay.h
include/gstreamer-%%VERSION%%/gst/gl/gstglfeature.h
@@ -52,12 +57,24 @@ include/gstreamer-%%VERSION%%/gst/gl/gstglutils.h
include/gstreamer-%%VERSION%%/gst/gl/gstglviewconvert.h
include/gstreamer-%%VERSION%%/gst/gl/gstglwindow.h
%%WAYLAND%%include/gstreamer-%%VERSION%%/gst/gl/wayland/gstgldisplay_wayland.h
+%%WAYLAND%%include/gstreamer-%%VERSION%%/gst/gl/wayland/wayland.h
include/gstreamer-%%VERSION%%/gst/gl/x11/gstgldisplay_x11.h
-lib/girepository-1.0/GstGL-%%VERSION%%.typelib
+include/gstreamer-%%VERSION%%/gst/gl/x11/x11.h
+lib/girepository-%%VERSION%%/GstGL-%%VERSION%%.typelib
+lib/girepository-%%VERSION%%/GstGLEGL-%%VERSION%%.typelib
+%%WAYLAND%%lib/girepository-%%VERSION%%/GstGLWayland-%%VERSION%%.typelib
+lib/girepository-%%VERSION%%/GstGLX11-%%VERSION%%.typelib
lib/gstreamer-%%VERSION%%/include/gst/gl/gstglconfig.h
lib/gstreamer-%%VERSION%%/libgstopengl.so
lib/libgstgl-%%VERSION%%.so
lib/libgstgl-%%VERSION%%.so.0
lib/libgstgl-%%VERSION%%.so.%%SOVERSION%%
libdata/pkgconfig/gstreamer-gl-%%VERSION%%.pc
-share/gir-1.0/GstGL-%%VERSION%%.gir
+libdata/pkgconfig/gstreamer-gl-egl-%%VERSION%%.pc
+libdata/pkgconfig/gstreamer-gl-prototypes-%%VERSION%%.pc
+%%WAYLAND%%libdata/pkgconfig/gstreamer-gl-wayland-%%VERSION%%.pc
+libdata/pkgconfig/gstreamer-gl-x11-%%VERSION%%.pc
+share/gir-%%VERSION%%/GstGL-%%VERSION%%.gir
+share/gir-%%VERSION%%/GstGLEGL-%%VERSION%%.gir
+%%WAYLAND%%share/gir-%%VERSION%%/GstGLWayland-%%VERSION%%.gir
+share/gir-%%VERSION%%/GstGLX11-%%VERSION%%.gir