aboutsummaryrefslogtreecommitdiff
path: root/graphics/hugin/Makefile
diff options
context:
space:
mode:
authorGreg Lehey <grog@FreeBSD.org>2015-11-19 23:47:28 +0000
committerGreg Lehey <grog@FreeBSD.org>2015-11-19 23:47:28 +0000
commit926f06b1712ee7462c45763944f0b9951bc629ce (patch)
tree6172042819e38f325e3402ffc10db456fe33edea /graphics/hugin/Makefile
parent2444e2e56a094086e0742e9f227c667787da9062 (diff)
downloadports-926f06b1712ee7462c45763944f0b9951bc629ce.tar.gz
ports-926f06b1712ee7462c45763944f0b9951bc629ce.zip
Take MAINTAINER
Approved by: vd@ Upgrade to 2015.0.0 Approved by: edwin@ (mentor) MFC after: 2 weeks
Notes
Notes: svn path=/head/; revision=401978
Diffstat (limited to 'graphics/hugin/Makefile')
-rw-r--r--graphics/hugin/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index cf5104b4b5d6..8672dede158a 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -2,18 +2,19 @@
# $FreeBSD$
PORTNAME= hugin
-PORTVERSION= 2013.0.0
-PORTREVISION= 7
+PORTVERSION= 2015.0.0
+PORTREVISION= 0
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
-MAINTAINER= vd@FreeBSD.org
+MAINTAINER= grog@FreeBSD.org
COMMENT= GUI for Panorama Tools, to stitch panoramic images
LIB_DEPENDS= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
libImath.so:${PORTSDIR}/graphics/ilmbase \
libboost_thread.so:${PORTSDIR}/devel/boost-libs \
libexiv2.so:${PORTSDIR}/graphics/exiv2 \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
liblensfun.so:${PORTSDIR}/graphics/lensfun \
libpano13.so:${PORTSDIR}/graphics/libpano13 \
libpng.so:${PORTSDIR}/graphics/png \
@@ -30,7 +31,7 @@ OPTIONS_DEFAULT= PANOMATIC AUTOPANOSIFTC
PANOMATIC_DESC= Install graphics/panomatic
AUTOPANOSIFTC_DESC= Install graphics/autopano-sift-c
-USES= cmake gettext jpeg pkgconfig tar:bzip2 desktop-file-utils python \
+USES= cmake gettext pkgconfig tar:bzip2 desktop-file-utils python \
shared-mime-info compiler:features
CMAKE_ARGS= -DwxWidgets_CONFIG_EXECUTABLE=${WX_CONFIG}
@@ -61,10 +62,6 @@ post-configure:
${WRKSRC}/src/hugin1/base_wx/CMakeFiles/huginbasewx.dir/flags.make \
${WRKSRC}/src/hugin1/hugin/CMakeFiles/hugin.dir/flags.make \
${WRKSRC}/src/hugin1/hugin/CMakeFiles/hugin.dir/link.txt \
- ${WRKSRC}/src/hugin1/nona_gui/CMakeFiles/nona_gui.dir/flags.make \
- ${WRKSRC}/src/hugin1/nona_gui/CMakeFiles/nona_gui.dir/link.txt \
- ${WRKSRC}/src/hugin1/ptbatcher/CMakeFiles/PTBatcher.dir/flags.make \
- ${WRKSRC}/src/hugin1/ptbatcher/CMakeFiles/PTBatcher.dir/link.txt \
${WRKSRC}/src/hugin1/ptbatcher/CMakeFiles/PTBatcherGUI.dir/flags.make \
${WRKSRC}/src/hugin1/ptbatcher/CMakeFiles/PTBatcherGUI.dir/link.txt \
${WRKSRC}/src/hugin1/stitch_project/CMakeFiles/hugin_stitch_project.dir/flags.make \