aboutsummaryrefslogtreecommitdiff
path: root/graphics/iec16022
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2017-07-06 09:56:13 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2017-07-06 09:56:13 +0000
commitfc11beadbd0df2f94a343a3f46f0ff4b584957dc (patch)
tree8d0c50332cace367fe2e26db9bc5bbda5474c54f /graphics/iec16022
parentb1a51c27b068b7e57a2ed730971a557e1c0717cd (diff)
downloadports-fc11beadbd0df2f94a343a3f46f0ff4b584957dc.tar.gz
ports-fc11beadbd0df2f94a343a3f46f0ff4b584957dc.zip
Update to 0.3.0
Notes
Notes: svn path=/head/; revision=445132
Diffstat (limited to 'graphics/iec16022')
-rw-r--r--graphics/iec16022/Makefile2
-rw-r--r--graphics/iec16022/distinfo6
-rw-r--r--graphics/iec16022/files/patch-image.c12
3 files changed, 10 insertions, 10 deletions
diff --git a/graphics/iec16022/Makefile b/graphics/iec16022/Makefile
index 8f551c999b2c..d97328a25b1b 100644
--- a/graphics/iec16022/Makefile
+++ b/graphics/iec16022/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= iec16022
-PORTVERSION= 0.2.7
+PORTVERSION= 0.3.0
DISTVERSIONPREFIX= v
CATEGORIES= graphics
diff --git a/graphics/iec16022/distinfo b/graphics/iec16022/distinfo
index ad4e5f3aa88a..9a641eb76b54 100644
--- a/graphics/iec16022/distinfo
+++ b/graphics/iec16022/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1475423331
-SHA256 (rdoeffinger-iec16022-v0.2.7_GH0.tar.gz) = 34f00da5f6c83dd14b2803e5ed0f5310310e452023fe989c59fc5489b78cd33a
-SIZE (rdoeffinger-iec16022-v0.2.7_GH0.tar.gz) = 32970
+TIMESTAMP = 1499334495
+SHA256 (rdoeffinger-iec16022-v0.3.0_GH0.tar.gz) = e7fb5c1963587e4abcf5fa041d61d64a8c495e3c8d054f2b2b8dfa1882d14869
+SIZE (rdoeffinger-iec16022-v0.3.0_GH0.tar.gz) = 30847
diff --git a/graphics/iec16022/files/patch-image.c b/graphics/iec16022/files/patch-image.c
index 31359009a2be..02870327a0a7 100644
--- a/graphics/iec16022/files/patch-image.c
+++ b/graphics/iec16022/files/patch-image.c
@@ -1,11 +1,11 @@
---- image.c.orig 2016-10-02 16:05:20 UTC
+--- image.c.orig 2017-07-05 23:29:56 UTC
+++ image.c
-@@ -40,6 +40,8 @@ static inline unsigned htonl(unsigned i)
- #include <zlib.h>
+@@ -32,6 +32,8 @@ static inline unsigned htonl(unsigned i)
#endif
+ #include "image.h"
+#include <unistd.h>
+
- static unsigned char const bbc[] = {
- 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, //
- 0x18, 0x18, 0x18, 0x18, 0x18, 0x00, 0x18, 0x00, // !
+ #define INTERLACE
+ #define CLEAR
+ #define USEZLIB