aboutsummaryrefslogtreecommitdiff
path: root/graphics/inkscape/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2019-10-15 07:25:12 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2019-10-15 07:25:12 +0000
commit34abf939b0f1c6c812bd1ebc36542dc0bd121112 (patch)
treeae3292f50091f4bbcbe7833c583259727484cab9 /graphics/inkscape/Makefile
parent0b464ec3df72f0701298c9f6ffd0213e31a84d55 (diff)
downloadports-34abf939b0f1c6c812bd1ebc36542dc0bd121112.tar.gz
ports-34abf939b0f1c6c812bd1ebc36542dc0bd121112.zip
graphics/inkscape:
- Repair Python based extensions: patch Inkscape to look for suffixed python binary and add missing runtime dependencies. This also fixes export to optimized SVG [1]. PR: 234797 [1] Reported by: georg-bsd Approved by: gnome (maintainer timeout, 2 weeks)
Notes
Notes: svn path=/head/; revision=514492
Diffstat (limited to 'graphics/inkscape/Makefile')
-rw-r--r--graphics/inkscape/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index 111b8f20ad81..9b095231a53d 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -3,7 +3,7 @@
PORTNAME= inkscape
PORTVERSION= 0.92.4
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics gnome
MASTER_SITES= https://media.inkscape.org/dl/resources/file/
@@ -29,9 +29,12 @@ LIB_DEPENDS= libpopt.so:devel/popt \
libpotrace.so:graphics/libpotrace \
libpng.so:graphics/png \
libMagick++-6.so:graphics/ImageMagick6
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scour>0:textproc/py-scour@${PY_FLAVOR}
USES= compiler:c++11-lib cmake cpe desktop-file-utils gnome \
- iconv:wchar_t jpeg pathfix pkgconfig python:2.7,build \
+ iconv:wchar_t jpeg pathfix pkgconfig python:2.7 \
shebangfix tar:bzip2
USE_GNOME= gtkmm24 libxml2 libxslt
USE_XORG= x11
@@ -82,6 +85,9 @@ USES+= gettext
post-patch:
@${REINPLACE_CMD} -e 's|COMMAND python|COMMAND ${PYTHON_VERSION}|g' \
${WRKSRC}/share/*/CMakeLists.txt
+ # Third entry in the table of interpreters is basename of executable
+ @${REINPLACE_CMD} -e 's|python|${PYTHON_VERSION}|3' \
+ ${WRKSRC}/src/extension/implementation/script.cpp
# Obtained from Arch Linux
@${REINPLACE_CMD} -e 's|gTrue|true|g' -e 's|gFalse|false|g' -e 's|GBool|bool|g' \
${WRKSRC}/src/extension/internal/pdfinput/pdf-parser.*