aboutsummaryrefslogtreecommitdiff
path: root/graphics/inkscape/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2020-05-15 12:05:34 +0000
committerKurt Jaeger <pi@FreeBSD.org>2020-05-15 12:05:34 +0000
commitf3865fdd690cfff1396e35f896eba61e58ac3025 (patch)
tree63b34c3013104058e5bf3cd31e62323daaf198a7 /graphics/inkscape/Makefile
parent173dc5aa0948d5aced9361b3a5cd61a70f837177 (diff)
downloadports-f3865fdd690cfff1396e35f896eba61e58ac3025.tar.gz
ports-f3865fdd690cfff1396e35f896eba61e58ac3025.zip
graphics/inkscape: update 0.92.4 -> 1.0
- Smoother performance, HiDPI support, new & improved Live Path Effects - supports python3 - option to use ImageMagick6 PR: 243615 Submitted by: Greg V <greg@unrelenting.technology>, rhurlin@gwdg.de Reviewed by: kwm, vvd@unislabs.com, thierry, waitman@waitman.net, portmaster@bsdforge.com, lumiwa@gmail.com, david@lapinbilly.eu, contact@evilham.com Relnotes: https://inkscape.org/news/2020/05/04/introducing-inkscape-10/ https://wiki.inkscape.org/wiki/index.php?title=Release_notes/1.0#Inkscape_1.0
Notes
Notes: svn path=/head/; revision=535285
Diffstat (limited to 'graphics/inkscape/Makefile')
-rw-r--r--graphics/inkscape/Makefile80
1 files changed, 53 insertions, 27 deletions
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index efcaa3e70e32..c0a042a3306e 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -2,54 +2,70 @@
# $FreeBSD$
PORTNAME= inkscape
-PORTVERSION= 0.92.4
-PORTREVISION= 17
+PORTVERSION= 1.0
CATEGORIES= graphics gnome
MASTER_SITES= https://media.inkscape.org/dl/resources/file/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Full featured open source SVG editor
-LICENSE= GPLv2+ GPLv3+ LGPL21 MPL11
+LICENSE= GPLv2 GPLv2+ GPLv3 GPLv3+ LGPL21 LGPL3 LGPL3+ MPL11
LICENSE_COMB= multi
-LICENSE_FILE_GPLv2+ = ${WRKSRC}/GPL2.txt
-LICENSE_FILE_GPLv3+ = ${WRKSRC}/GPL3.txt
-LICENSE_FILE_LGPL21= ${WRKSRC}/LGPL2.1.txt
+LICENSE_FILE_GPLv2 = ${WRKSRC}/LICENSES/GPL-2.0.txt
+LICENSE_FILE_GPLv2+ = ${WRKSRC}/LICENSES/GPL-2.0-or-later.txt
+LICENSE_FILE_GPLv3 = ${WRKSRC}/LICENSES/GPL-3.0.txt
+LICENSE_FILE_GPLv3+ = ${WRKSRC}/LICENSES/GPL-3.0-or-later.txt
+LICENSE_FILE_LGPL21 = ${WRKSRC}/LICENSES/LGPL-2.1.txt
+LICENSE_FILE_LGPL3 = ${WRKSRC}/LICENSES/LGPL-3.0.txt
+LICENSE_FILE_LGPL3+ = ${WRKSRC}/LICENSES/LGPL-3.0-or-later.txt
+LICENSE_FILE_MPL11 = ${WRKSRC}/LICENSES/MPL-1.1.txt
BUILD_DEPENDS= ${LOCALBASE}/include/boost/concept_check.hpp:devel/boost-libs
LIB_DEPENDS= libpopt.so:devel/popt \
libgc.so:devel/boehm-gc \
+ libgdl-3.so:x11-toolkits/gdl \
libgsl.so:math/gsl \
- libgtkspell.so:textproc/gtkspell \
+ libgtkspell3-3.so:textproc/gtkspell3 \
liblcms2.so:graphics/lcms2 \
libfribidi.so:converters/fribidi \
libaspell.so:textproc/aspell \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
+ libharfbuzz.so:print/harfbuzz \
libpotrace.so:graphics/libpotrace \
libpng.so:graphics/png \
- libMagick++-6.so:graphics/ImageMagick6
+ libsoup-2.4.so:devel/libsoup \
+ libenchant-2.so:textproc/enchant2 \
+ libyaml.so:textproc/libyaml \
+ libdouble-conversion.so:devel/double-conversion
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}scour>0:textproc/py-scour@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}scour>0:textproc/py-scour@${PY_FLAVOR} \
+ ps2pdf:print/ghostscript9-agpl-base \
+ fig2dev:print/transfig
USES= compiler:c++11-lib cmake cpe desktop-file-utils gnome \
- iconv:wchar_t jpeg pathfix pkgconfig python:2.7 \
- shebangfix tar:bzip2 xorg
-USE_GNOME= gtkmm24 libxml2 libxslt
-USE_XORG= x11
+ iconv:wchar_t jpeg pathfix pkgconfig python:3.6+ \
+ shebangfix tar:xz xorg
+USE_GNOME= gtkmm30 gvfs libxml2 libxslt
+USE_XORG= sm ice x11 xext
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}_2020-05-01_4035a4fb49
+
INSTALLS_ICONS= yes
-CMAKE_ARGS+= -DWITH_GNOME_VFS:BOOL=NO
-SHEBANG_FILES= cxxtest/cxxtestgen.pl share/extensions/*.p[lm] \
- share/extensions/*.py share/extensions/genpofiles.sh \
- fix-roff-punct
+SHEBANG_FILES= share/extensions/*.py share/extensions/genpofiles.sh \
+ share/templates/*.py man/fix-roff-punct
-OPTIONS_DEFINE= POPPLER VISIO CDR DBUS WPG
-OPTIONS_DEFAULT=POPPLER VISIO CDR WPG
-OPTIONS_SUB= yes
+OPTIONS_DEFINE= OPENMP POPPLER VISIO CDR DBUS WPG
+OPTIONS_DEFAULT= POPPLER VISIO CDR WPG GM
+OPTIONS_DEFAULT_amd64= OPENMP
+OPTIONS_SINGLE= IMAGICK
+OPTIONS_SINGLE_IMAGICK= IMAGICK6 GM
+OPTIONS_SUB= yes
-CDR_DESC= Support for CorelDRAW diagrams
+CDR_DESC= Support for CorelDRAW graphics
CDR_CMAKE_BOOL= WITH_LIBCDR
CDR_LIB_DEPENDS= librevenge-stream-0.0.so:textproc/librevenge \
libcdr-0.1.so:graphics/libcdr01
@@ -58,10 +74,8 @@ DBUS_CMAKE_BOOL= WITH_DBUS
DBUS_LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libdbus-1.so:devel/dbus
-#OPENMP_USES= compiler:openmp
-#OPENMP_USES_OFF= compiler:c++11-lib
-#OPENMP_CMAKE_BOOL= WITH_OPENMP
-CMAKE_ARGS+= -DWITH_OPENMP:BOOL=NO
+OPENMP_USES= compiler:openmp
+OPENMP_CMAKE_BOOL= WITH_OPENMP
POPPLER_DESC= PDF preview rendering
POPPLER_CMAKE_BOOL= ENABLE_POPPLER ENABLE_POPPLER_CAIRO
@@ -77,16 +91,28 @@ WPG_DESC= Support for WordPerfect graphics
WPG_CMAKE_BOOL= WITH_LIBWPG
WPG_LIB_DEPENDS= libwpg-0.3.so:graphics/libwpg03
+IMAGICK_DESC= Raster image format library
+IMAGICK6_DESC= Use ImageMagick6
+IMAGICK6_LIB_DEPENDS= libMagick++-6.so:graphics/ImageMagick6
+IMAGICK6_CMAKE_BOOL= WITH_IMAGE_MAGICK
+GM_DESC= Use GraphicsMagick
+GM_LIB_DEPENDS= libGraphicsMagick.so:graphics/GraphicsMagick
+
# temporary until the build works for the !NLS case
USES+= gettext
#NLS_CMAKE_BOOL= WITH_NLS
#NLS_USES= gettext
post-patch:
- @${REINPLACE_CMD} -e 's|COMMAND python|COMMAND ${PYTHON_VERSION}|g' \
+ @${REINPLACE_CMD} -e 's|COMMAND python3|COMMAND ${PYTHON_VERSION}|g' \
${WRKSRC}/share/*/CMakeLists.txt
# Third entry in the table of interpreters is basename of executable
- @${REINPLACE_CMD} -e 's|python|${PYTHON_VERSION}|3' \
+ @${REINPLACE_CMD} -e 's|"python3"|"${PYTHON_VERSION}"|g' \
${WRKSRC}/src/extension/implementation/script.cpp
+ @${REINPLACE_CMD} -e 's|web-set-att|web_set_att|g' \
+ ${WRKSRC}/po/*.po
+ @${REINPLACE_CMD} -e 's|web-transmit-att|web_transmit_att|g' \
+ ${WRKSRC}/po/*.po
+ @${TOUCH} ${WRKSRC}/share/extensions/gcodetools_check_for_updates.inx.h
.include <bsd.port.mk>