aboutsummaryrefslogtreecommitdiff
path: root/graphics/inkscape
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2015-04-30 23:29:35 +0000
committerDon Lewis <truckman@FreeBSD.org>2015-04-30 23:29:35 +0000
commita6dfd1234db2e2fc96c31cffa8d5d24d6418cbfe (patch)
tree88e59cd5df17a292f48c2e8274a4834cc4c9fc38 /graphics/inkscape
parentb8a681bed2ae450279719e385ce986bfec14eaae (diff)
downloadports-a6dfd1234db2e2fc96c31cffa8d5d24d6418cbfe.tar.gz
ports-a6dfd1234db2e2fc96c31cffa8d5d24d6418cbfe.zip
Unbreak graphics/inkscape build on FreeBSD 9.3 i386.
The base version of clang 3.4.1 in FreeBSD 9.3 is missing some patches that are present in clang 3.4.1 in FreeBSD 10.1. One of these patches appears to fix a code generation bug on i386 that is triggered when building graphics/inkscape. Work around this issue by building inkscape with lang/clang34 from ports on FreeBSD 9.3 i386. Approved by: mat (mentor) MFH: 2015Q2 Differential Revision: https://reviews.freebsd.org/D2417
Notes
Notes: svn path=/head/; revision=385075
Diffstat (limited to 'graphics/inkscape')
-rw-r--r--graphics/inkscape/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index e23a8b275528..e001247a2b38 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -71,6 +71,18 @@ WPG_LIB_DEPENDS= libwpg-0.2.so:${PORTSDIR}/graphics/libwpg
CPPFLAGS+= -Wno-mismatched-tags -Wno-unknown-attributes
.endif
+# Base clang 3.4.1 in FreeBSD 9.3 fails to compile this code on i386
+# but base clang 3.4.1 in FreeBSD 10.1 succeeds. The difference *appears*
+# to be the patch applied in r271597 (head) / r271739 (stable/10). The
+# latter happened shortly before 10.1 was branched.
+.if ${ARCH} == i386 && ${OPSYS} == FreeBSD && ${OSVERSION} < 1001000 && \
+ ( ${COMPILER_TYPE} == clang || ${ALT_COMPILER_TYPE} == clang )
+BUILD_DEPENDS+= clang34:${PORTSDIR}/lang/clang34
+CPP= ${LOCALBASE}/bin/clang-cpp34
+CC= ${LOCALBASE}/bin/clang34
+CXX= ${LOCALBASE}/bin/clang++34
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-ldl||g' \
${WRKSRC}/configure