aboutsummaryrefslogtreecommitdiff
path: root/graphics/inventor
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-10-21 07:29:28 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-10-21 07:29:28 +0000
commit047129ab56fa45c910e20b8f8d7b1256ae1c206c (patch)
tree3871e6e827a1b70cc03a4f6dc716af9ef0863b84 /graphics/inventor
parenta0be8bd71e358630900b8f1b02f93aeb28e685ca (diff)
downloadports-047129ab56fa45c910e20b8f8d7b1256ae1c206c.tar.gz
ports-047129ab56fa45c910e20b8f8d7b1256ae1c206c.zip
- Fix build with modern compilers
PR: 182900 Submitted by: gahr Approved by: maintainer
Notes
Notes: svn path=/head/; revision=331098
Diffstat (limited to 'graphics/inventor')
-rw-r--r--graphics/inventor/Makefile2
-rw-r--r--graphics/inventor/files/patch-apps-demos-qmorf_quadCube.c++11
-rw-r--r--graphics/inventor/files/patch-apps-demos-qmorf_quadSheet.c++11
-rw-r--r--graphics/inventor/files/patch-apps-demos-qmorf_quadSphere.c++11
-rw-r--r--graphics/inventor/files/patch-apps-demos-revo_GNUmakefile14
-rw-r--r--graphics/inventor/files/patch-apps-demos-textomatic_GNUmakefile11
-rw-r--r--graphics/inventor/files/patch-apps-samples-widgets_componentTest.c++11
-rw-r--r--graphics/inventor/files/patch-apps-tools-ivcat_ivcat.c++11
-rw-r--r--graphics/inventor/files/patch-apps-tools-ivfix_ivfix.c++11
-rw-r--r--graphics/inventor/files/patch-apps-tools-ivinfo_ivinfo.c++11
-rw-r--r--graphics/inventor/files/patch-doc-man-ivman_Main.c++11
-rw-r--r--graphics/inventor/files/patch-lib-GNUmakefile28
-rw-r--r--graphics/inventor/files/patch-tools-ppp_ppp.c++11
13 files changed, 139 insertions, 15 deletions
diff --git a/graphics/inventor/Makefile b/graphics/inventor/Makefile
index cbf5831001aa..91da47139835 100644
--- a/graphics/inventor/Makefile
+++ b/graphics/inventor/Makefile
@@ -149,6 +149,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%CC%%|${CC}|g ;\
s|%%CXX%%|${CXX}|g ; \
s|%%CXXFLAGS%%|${CXXFLAGS}|g' ${WRKSRC}/make/ivcommondefs
+ @${REINPLACE_CMD} -e 's|%%ICONV_LIB%%|${ICONV_LIB}|' \
+ ${WRKSRC}/lib/GNUmakefile
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/graphics/inventor/files/patch-apps-demos-qmorf_quadCube.c++ b/graphics/inventor/files/patch-apps-demos-qmorf_quadCube.c++
new file mode 100644
index 000000000000..72462e2b3c16
--- /dev/null
+++ b/graphics/inventor/files/patch-apps-demos-qmorf_quadCube.c++
@@ -0,0 +1,11 @@
+--- apps/demos/qmorf/quadCube.c++.orig 2013-10-10 14:58:48.000000000 +0200
++++ apps/demos/qmorf/quadCube.c++ 2013-10-10 14:58:56.000000000 +0200
+@@ -182,7 +182,7 @@
+ return result;
+ }
+
+-main(int argc, char **argv)
++int main(int argc, char **argv)
+ {
+ if (argc > 1) diagonalFlag = 0;
+
diff --git a/graphics/inventor/files/patch-apps-demos-qmorf_quadSheet.c++ b/graphics/inventor/files/patch-apps-demos-qmorf_quadSheet.c++
new file mode 100644
index 000000000000..12c832de0d15
--- /dev/null
+++ b/graphics/inventor/files/patch-apps-demos-qmorf_quadSheet.c++
@@ -0,0 +1,11 @@
+--- apps/demos/qmorf/quadSheet.c++.orig 2013-10-10 14:59:43.000000000 +0200
++++ apps/demos/qmorf/quadSheet.c++ 2013-10-10 14:59:47.000000000 +0200
+@@ -68,7 +68,7 @@
+ return result;
+ }
+
+-main(int argc, char **argv)
++int main(int argc, char **argv)
+ {
+ SoDB::init();
+
diff --git a/graphics/inventor/files/patch-apps-demos-qmorf_quadSphere.c++ b/graphics/inventor/files/patch-apps-demos-qmorf_quadSphere.c++
new file mode 100644
index 000000000000..74379bbaba37
--- /dev/null
+++ b/graphics/inventor/files/patch-apps-demos-qmorf_quadSphere.c++
@@ -0,0 +1,11 @@
+--- apps/demos/qmorf/quadSphere.c++.orig 2013-10-10 14:58:13.000000000 +0200
++++ apps/demos/qmorf/quadSphere.c++ 2013-10-10 14:58:20.000000000 +0200
+@@ -76,7 +76,7 @@
+ return result;
+ }
+
+-main(int argc, char **argv)
++int main(int argc, char **argv)
+ {
+ SoDB::init();
+
diff --git a/graphics/inventor/files/patch-apps-demos-revo_GNUmakefile b/graphics/inventor/files/patch-apps-demos-revo_GNUmakefile
new file mode 100644
index 000000000000..d972247745e9
--- /dev/null
+++ b/graphics/inventor/files/patch-apps-demos-revo_GNUmakefile
@@ -0,0 +1,14 @@
+--- apps/demos/revo/GNUmakefile.orig 2013-10-10 15:00:56.000000000 +0200
++++ apps/demos/revo/GNUmakefile 2013-10-10 15:01:29.000000000 +0200
+@@ -8,9 +8,9 @@
+
+ CXXFILES = revo.c++ RevClass.c++ profile.c++
+
+-LLDOPTS += -L../../samples/common
++LLDOPTS +=
+
+-LLDLIBS = -lcommon -lInventor -lInventorXt
++LLDLIBS = ../../samples/common/libcommon.a -lInventor -lInventorXt
+
+ all: all_ivbin
+
diff --git a/graphics/inventor/files/patch-apps-demos-textomatic_GNUmakefile b/graphics/inventor/files/patch-apps-demos-textomatic_GNUmakefile
new file mode 100644
index 000000000000..b63bcc4a33a5
--- /dev/null
+++ b/graphics/inventor/files/patch-apps-demos-textomatic_GNUmakefile
@@ -0,0 +1,11 @@
+--- apps/demos/textomatic/GNUmakefile.orig 2013-10-10 15:01:55.000000000 +0200
++++ apps/demos/textomatic/GNUmakefile 2013-10-10 15:02:12.000000000 +0200
+@@ -8,7 +8,7 @@
+
+ LLDOPTS += -L../../samples/common
+
+-LLDLIBS = -lcommon -lInventor -lInventorXt
++LLDLIBS = ../../samples/common/libcommon.a -lInventor -lInventorXt
+
+ all: all_ivbin
+
diff --git a/graphics/inventor/files/patch-apps-samples-widgets_componentTest.c++ b/graphics/inventor/files/patch-apps-samples-widgets_componentTest.c++
new file mode 100644
index 000000000000..e0cfa920cfae
--- /dev/null
+++ b/graphics/inventor/files/patch-apps-samples-widgets_componentTest.c++
@@ -0,0 +1,11 @@
+--- apps/samples/widgets/componentTest.c++.orig 2013-10-10 14:53:45.000000000 +0200
++++ apps/samples/widgets/componentTest.c++ 2013-10-10 14:53:54.000000000 +0200
+@@ -60,7 +60,7 @@
+ }
+
+ int
+-main(unsigned int argc, char *argv[])
++main(int argc, char *argv[])
+ {
+ if (argc != 2)
+ usage(argv[0]);
diff --git a/graphics/inventor/files/patch-apps-tools-ivcat_ivcat.c++ b/graphics/inventor/files/patch-apps-tools-ivcat_ivcat.c++
new file mode 100644
index 000000000000..3d3a4692aa73
--- /dev/null
+++ b/graphics/inventor/files/patch-apps-tools-ivcat_ivcat.c++
@@ -0,0 +1,11 @@
+--- apps/tools/ivcat/ivcat.c++.orig 2013-10-10 14:54:27.000000000 +0200
++++ apps/tools/ivcat/ivcat.c++ 2013-10-10 14:54:37.000000000 +0200
+@@ -215,7 +215,7 @@
+ }
+ }
+
+-main(int argc, char **argv)
++int main(int argc, char **argv)
+ {
+ int expandFileNodes = 0;
+ int expandTextureNodes = 0;
diff --git a/graphics/inventor/files/patch-apps-tools-ivfix_ivfix.c++ b/graphics/inventor/files/patch-apps-tools-ivfix_ivfix.c++
new file mode 100644
index 000000000000..9d16e37a0bc0
--- /dev/null
+++ b/graphics/inventor/files/patch-apps-tools-ivfix_ivfix.c++
@@ -0,0 +1,11 @@
+--- apps/tools/ivfix/ivfix.c++.orig 2013-10-10 14:55:27.000000000 +0200
++++ apps/tools/ivfix/ivfix.c++ 2013-10-10 14:55:33.000000000 +0200
+@@ -80,7 +80,7 @@
+ //
+ /////////////////////////////////////////////////////////////////////////////
+
+-main(int argc, char **argv)
++int main(int argc, char **argv)
+ {
+ OptionInfo options;
+
diff --git a/graphics/inventor/files/patch-apps-tools-ivinfo_ivinfo.c++ b/graphics/inventor/files/patch-apps-tools-ivinfo_ivinfo.c++
new file mode 100644
index 000000000000..5c401bbede28
--- /dev/null
+++ b/graphics/inventor/files/patch-apps-tools-ivinfo_ivinfo.c++
@@ -0,0 +1,11 @@
+--- apps/tools/ivinfo/ivinfo.c++.orig 2013-10-10 14:56:40.000000000 +0200
++++ apps/tools/ivinfo/ivinfo.c++ 2013-10-10 14:56:45.000000000 +0200
+@@ -159,7 +159,7 @@
+ }
+ }
+
+-main(int argc, char *argv[])
++int main(int argc, char *argv[])
+ {
+ SoInput in;
+ SoNode *root;
diff --git a/graphics/inventor/files/patch-doc-man-ivman_Main.c++ b/graphics/inventor/files/patch-doc-man-ivman_Main.c++
new file mode 100644
index 000000000000..ef23d5452277
--- /dev/null
+++ b/graphics/inventor/files/patch-doc-man-ivman_Main.c++
@@ -0,0 +1,11 @@
+--- doc/man/ivman/Main.c++.orig 2013-10-10 14:52:11.000000000 +0200
++++ doc/man/ivman/Main.c++ 2013-10-10 14:52:17.000000000 +0200
+@@ -89,7 +89,7 @@
+ //
+ /////////////////////////////////////////////////////////////////////////////
+
+-main(int argc, char *argv[])
++int main(int argc, char *argv[])
+ {
+ SbBool ok = TRUE;
+ int c, curArg;
diff --git a/graphics/inventor/files/patch-lib-GNUmakefile b/graphics/inventor/files/patch-lib-GNUmakefile
index c0ce198af4a4..2d734737fd9d 100644
--- a/graphics/inventor/files/patch-lib-GNUmakefile
+++ b/graphics/inventor/files/patch-lib-GNUmakefile
@@ -1,15 +1,13 @@
-*** lib/GNUmakefile Sat Dec 14 18:23:15 2002
---- lib/GNUmakefile.new Sat Dec 14 17:30:19 2002
-***************
-*** 10,15 ****
---- 10,19 ----
- -lX11 -lm \
- -lGLU -lGL
-
-+ ifeq ($(usingFreeBSD), 1)
-+ LLDLIBS += -lXext -liconv
-+ endif
-+
- OBJECTS = \
- ./database/src/sb/projectors/SbProjectors.o \
- ./database/src/sb/Sb.o \
+--- lib/GNUmakefile.orig 2001-09-25 02:45:32.000000000 +0200
++++ lib/GNUmakefile 2013-10-10 14:49:54.000000000 +0200
+@@ -10,6 +10,10 @@
+ -lX11 -lm \
+ -lGLU -lGL
+
++ifeq ($(usingFreeBSD), 1)
++LLDLIBS += -lXext %%ICONV_LIB%%
++endif
++
+ OBJECTS = \
+ ./database/src/sb/projectors/SbProjectors.o \
+ ./database/src/sb/Sb.o \
diff --git a/graphics/inventor/files/patch-tools-ppp_ppp.c++ b/graphics/inventor/files/patch-tools-ppp_ppp.c++
new file mode 100644
index 000000000000..e054e42b9d8b
--- /dev/null
+++ b/graphics/inventor/files/patch-tools-ppp_ppp.c++
@@ -0,0 +1,11 @@
+--- tools/ppp/ppp.c++.orig 2013-10-10 14:43:30.000000000 +0200
++++ tools/ppp/ppp.c++ 2013-10-10 14:48:56.000000000 +0200
+@@ -627,7 +627,7 @@
+ //
+ //////////////////////////////////////////////////////////////////////////////
+
+-main(int, char *argv[])
++int main(int, char *argv[])
+ {
+ char buf[1024];
+ Line line;