aboutsummaryrefslogtreecommitdiff
path: root/graphics/jdraw/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-06 17:47:02 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-06 17:47:02 +0000
commit2635344162e282b677450d28e6380b50a7ff6a20 (patch)
tree55cc7cc379762e3a6624ff8ae92be2265c86a67d /graphics/jdraw/Makefile
parent26d33e9388ed49b2d1c682c076896f04aaf45fe0 (diff)
downloadports-2635344162e282b677450d28e6380b50a7ff6a20.tar.gz
ports-2635344162e282b677450d28e6380b50a7ff6a20.zip
JDraw is a pixel oriented graphics editor designed especially for small
to medium-sized pictures used to decorate web pages. It is completely written in Java, simple to use and saves (animated) GIFs, ICOs and PNGs. Author: jdomain@users.sourceforge.net WWW: http://www.j-domain.de/homepage.php?page=20 PR: ports/95895 Submitted by: Nicola Vitale <nivit at email.it>
Notes
Notes: svn path=/head/; revision=167069
Diffstat (limited to 'graphics/jdraw/Makefile')
-rw-r--r--graphics/jdraw/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/graphics/jdraw/Makefile b/graphics/jdraw/Makefile
new file mode 100644
index 000000000000..cffe4dd1b99c
--- /dev/null
+++ b/graphics/jdraw/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: jdraw
+# Date created: 2006-04-15
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jdraw
+PORTVERSION= 1.1.4
+CATEGORIES= graphics java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_v${PORTVERSION}
+EXTRACT_SUFX= .jar
+EXTRACT_ONLY=
+
+MAINTAINER= nivit@email.it
+COMMENT= A pixel oriented graphics editor
+
+NO_BUILD= yes
+USE_JAVA= yes
+
+OPTIONS= PLASTIC3D "Use Plastic3DLook&Feel" on
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+SUB_FILES= ${PORTNAME}
+SUB_LIST= JAVA=${JAVA} JAVAJARDIR=${JAVAJARDIR} JDRAWJAR=${JDRAWJAR} PLASTIC3D=${PLASTIC3D}
+
+JDRAWJAR= ${DATADIR}/${DISTFILES}
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DISTFILES} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PLASTIC3D)
+PLASTIC3D= "-Dlf=\"com.jgoodies.looks.plastic.Plastic3DLookAndFeel\""
+JAVA_VERSION= 1.5+
+RUN_DEPENDS+= ${JAVAJARDIR}/looks.jar:${PORTSDIR}/devel/looks
+.else
+JAVA_VERSION= 1.4+
+.endif
+
+.include <bsd.port.post.mk>