aboutsummaryrefslogtreecommitdiff
path: root/graphics/jpeg
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-02-05 11:46:55 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-02-05 11:46:55 +0000
commitca9c60461cb276ee2afe18260afc8dec97c1b6f8 (patch)
tree723ef4dd1e7ab15998168c724ba862742907ca7a /graphics/jpeg
parentfba82b2a968f007c64e260a48433dc7f9e39a3b8 (diff)
downloadports-ca9c60461cb276ee2afe18260afc8dec97c1b6f8.tar.gz
ports-ca9c60461cb276ee2afe18260afc8dec97c1b6f8.zip
- update to jpeg-8
Notes
Notes: svn path=/head/; revision=249285
Diffstat (limited to 'graphics/jpeg')
-rw-r--r--graphics/jpeg/Makefile2
-rw-r--r--graphics/jpeg/distinfo6
-rw-r--r--graphics/jpeg/files/patch-configure2
-rw-r--r--graphics/jpeg/files/patch-jpegtran.c41
-rw-r--r--graphics/jpeg/files/patch-transupp.c46
-rw-r--r--graphics/jpeg/files/patch-transupp.h16
-rw-r--r--graphics/jpeg/pkg-plist2
7 files changed, 56 insertions, 59 deletions
diff --git a/graphics/jpeg/Makefile b/graphics/jpeg/Makefile
index e0cc3f0420d7..79e0ba753d5d 100644
--- a/graphics/jpeg/Makefile
+++ b/graphics/jpeg/Makefile
@@ -8,7 +8,7 @@
# version number) when updating this port. Thank you.
PORTNAME= jpeg
-PORTVERSION= 7
+PORTVERSION= 8
CATEGORIES= graphics
MASTER_SITES= http://www.ijg.org/files/ \
ftp://ftp.uu.net/graphics/jpeg/ \
diff --git a/graphics/jpeg/distinfo b/graphics/jpeg/distinfo
index 8e05c5838c80..687eb553d92b 100644
--- a/graphics/jpeg/distinfo
+++ b/graphics/jpeg/distinfo
@@ -1,6 +1,6 @@
-MD5 (jpegsrc.v7.tar.gz) = 382ef33b339c299b56baf1296cda9785
-SHA256 (jpegsrc.v7.tar.gz) = 50b7866206c5be044c4a2b0d7895898f5a58d31b50e16e79cf7dea3b90337ebf
-SIZE (jpegsrc.v7.tar.gz) = 960379
+MD5 (jpegsrc.v8.tar.gz) = 9c6b3514e922ad42298706163bb5e2d7
+SHA256 (jpegsrc.v8.tar.gz) = 17baa5b7acb3f0f8d15d73dd2416cb9398a55b3334a5a9359d278d8de6a50bac
+SIZE (jpegsrc.v8.tar.gz) = 961697
MD5 (jpegexiforient.c) = ff4657764cb885b9aec06449507bf29d
SHA256 (jpegexiforient.c) = bca1bc35bb53d3c189775e0ef4ecbd9be7660d636c7e044f964bde8697273b83
SIZE (jpegexiforient.c) = 8192
diff --git a/graphics/jpeg/files/patch-configure b/graphics/jpeg/files/patch-configure
index 9dd2a32bca20..6494b4ed92b6 100644
--- a/graphics/jpeg/files/patch-configure
+++ b/graphics/jpeg/files/patch-configure
@@ -4,7 +4,7 @@
JPEG_LIB_VERSION="`expr $JPEG_LIB_VERSION / 10`:`expr $JPEG_LIB_VERSION % 10`"
{ $as_echo "$as_me:$LINENO: result: $JPEG_LIB_VERSION" >&5
$as_echo "$JPEG_LIB_VERSION" >&6; }
-+JPEG_LIB_VERSION="10"
++JPEG_LIB_VERSION="11"
ac_config_files="$ac_config_files Makefile"
diff --git a/graphics/jpeg/files/patch-jpegtran.c b/graphics/jpeg/files/patch-jpegtran.c
index 7a992e766c8e..44db9a88c20c 100644
--- a/graphics/jpeg/files/patch-jpegtran.c
+++ b/graphics/jpeg/files/patch-jpegtran.c
@@ -1,14 +1,14 @@
---- jpegtran.c.orig 2003-09-22 00:00:52.000000000 +0200
-+++ jpegtran.c 2009-06-30 13:41:20.000000000 +0200
+--- jpegtran.c.orig 2009-09-03 12:49:34.000000000 +0200
++++ jpegtran.c 2010-01-13 08:46:28.000000000 +0100
@@ -37,6 +37,7 @@
static const char * progname; /* program name for error messages */
static char * outfilename; /* for -outfile switch */
+static char * dropfilename; /* for -drop switch */
+ static char * scaleoption; /* -scale switch */
static JCOPY_OPTION copyoption; /* -copy switch */
static jpeg_transform_info transformoption; /* image transformation options */
-
-@@ -56,6 +57,7 @@
+@@ -57,6 +58,7 @@
fprintf(stderr, " -copy none Copy no extra markers from source file\n");
fprintf(stderr, " -copy comments Copy only comment markers (default)\n");
fprintf(stderr, " -copy all Copy all extra markers\n");
@@ -16,7 +16,7 @@
#ifdef ENTROPY_OPT_SUPPORTED
fprintf(stderr, " -optimize Optimize Huffman table (smaller file, but slow compression)\n");
#endif
-@@ -65,13 +67,15 @@
+@@ -66,6 +68,7 @@
#if TRANSFORMS_SUPPORTED
fprintf(stderr, "Switches for modifying the image:\n");
fprintf(stderr, " -crop WxH+X+Y Crop to a rectangular subarea\n");
@@ -24,7 +24,8 @@
fprintf(stderr, " -grayscale Reduce to grayscale (omit color data)\n");
fprintf(stderr, " -flip [horizontal|vertical] Mirror image (left-right or top-bottom)\n");
fprintf(stderr, " -perfect Fail if there is non-transformable edge blocks\n");
- fprintf(stderr, " -rotate [90|180|270] Rotate image (degrees clockwise)\n");
+@@ -73,7 +76,8 @@
+ fprintf(stderr, " -scale M/N Scale output image by fraction M/N, eg, 1/8\n");
fprintf(stderr, " -transpose Transpose image\n");
fprintf(stderr, " -transverse Transverse transpose image\n");
- fprintf(stderr, " -trim Drop non-transformable edge blocks\n");
@@ -33,7 +34,7 @@
#endif /* TRANSFORMS_SUPPORTED */
fprintf(stderr, "Switches for advanced users:\n");
fprintf(stderr, " -restart N Set restart interval in rows, or in blocks with B\n");
-@@ -112,6 +116,52 @@
+@@ -114,6 +118,52 @@
}
@@ -86,15 +87,15 @@
LOCAL(int)
parse_switches (j_compress_ptr cinfo, int argc, char **argv,
int last_file_arg_seen, boolean for_real)
-@@ -132,6 +182,7 @@
+@@ -134,6 +184,7 @@
/* Set up default JPEG parameters. */
simple_progressive = FALSE;
outfilename = NULL;
+ dropfilename = NULL;
+ scaleoption = NULL;
copyoption = JCOPYOPT_DEFAULT;
transformoption.transform = JXFORM_NONE;
- transformoption.trim = FALSE;
-@@ -174,6 +225,8 @@
+@@ -177,6 +228,8 @@
copyoption = JCOPYOPT_COMMENTS;
} else if (keymatch(argv[argn], "all", 1)) {
copyoption = JCOPYOPT_ALL;
@@ -103,7 +104,7 @@
} else
usage();
-@@ -191,6 +244,26 @@
+@@ -194,6 +247,26 @@
select_transform(JXFORM_NONE); /* force an error */
#endif
@@ -130,7 +131,7 @@
} else if (keymatch(arg, "debug", 1) || keymatch(arg, "verbose", 1)) {
/* Enable debug printouts. */
/* On first -d, print version identification */
-@@ -199,6 +272,7 @@
+@@ -202,6 +275,7 @@
if (! printed_version) {
fprintf(stderr, "Independent JPEG Group's JPEGTRAN, version %s\n%s\n",
JVERSION, JCOPYRIGHT);
@@ -138,7 +139,7 @@
printed_version = TRUE;
}
cinfo->err->trace_level++;
-@@ -359,6 +433,11 @@
+@@ -369,6 +443,11 @@
struct jpeg_decompress_struct srcinfo;
struct jpeg_compress_struct dstinfo;
struct jpeg_error_mgr jsrcerr, jdsterr;
@@ -150,7 +151,7 @@
#ifdef PROGRESS_REPORT
struct cdjpeg_progress_mgr progress;
#endif
-@@ -440,6 +519,21 @@
+@@ -450,6 +529,21 @@
fp = read_stdin();
}
@@ -172,9 +173,9 @@
#ifdef PROGRESS_REPORT
start_progress_monitor((j_common_ptr) &dstinfo, &progress);
#endif
-@@ -453,6 +547,17 @@
- /* Read file header */
- (void) jpeg_read_header(&srcinfo, TRUE);
+@@ -469,6 +563,17 @@
+ &srcinfo.scale_num, &srcinfo.scale_denom) < 1)
+ usage();
+#if TRANSFORMS_SUPPORTED
+ if (dropfilename != NULL) {
@@ -190,7 +191,7 @@
/* Any space needed by a transform option must be requested before
* jpeg_read_coefficients so that memory allocation will be done right.
*/
-@@ -472,6 +577,12 @@
+@@ -484,6 +589,12 @@
/* Read source file as DCT coefficients */
src_coef_arrays = jpeg_read_coefficients(&srcinfo);
@@ -203,7 +204,7 @@
/* Initialize destination compression parameters from source values */
jpeg_copy_critical_parameters(&srcinfo, &dstinfo);
-@@ -510,6 +621,9 @@
+@@ -522,6 +633,9 @@
/* Adjust default compression parameters by re-parsing the options */
file_index = parse_switches(&dstinfo, argc, argv, 0, TRUE);
@@ -213,7 +214,7 @@
/* Specify data destination for compression */
jpeg_stdio_dest(&dstinfo, fp);
-@@ -531,16 +645,30 @@
+@@ -543,16 +657,30 @@
jpeg_destroy_compress(&dstinfo);
(void) jpeg_finish_decompress(&srcinfo);
jpeg_destroy_decompress(&srcinfo);
diff --git a/graphics/jpeg/files/patch-transupp.c b/graphics/jpeg/files/patch-transupp.c
index 519d07b08183..feb9f8ac8f97 100644
--- a/graphics/jpeg/files/patch-transupp.c
+++ b/graphics/jpeg/files/patch-transupp.c
@@ -1,5 +1,5 @@
---- transupp.c.orig 2009-06-17 11:14:27.000000000 +0200
-+++ transupp.c 2009-07-01 08:50:53.000000000 +0200
+--- transupp.c.orig 2009-09-03 16:45:06.000000000 +0200
++++ transupp.c 2010-01-13 09:38:15.000000000 +0100
@@ -51,6 +51,13 @@
* guarantee we can touch more than one row at a time. So in that case,
* we have to use a separate destination array.
@@ -356,26 +356,22 @@
}
-@@ -861,9 +1168,9 @@
- jvirt_barray_ptr *coef_arrays = NULL;
- boolean need_workspace, transpose_it;
- jpeg_component_info *compptr;
-- JDIMENSION xoffset, yoffset, width_in_iMCUs, height_in_iMCUs;
-+ JDIMENSION xoffset, yoffset, dtemp, width_in_iMCUs, height_in_iMCUs;
+@@ -876,7 +1183,9 @@
+ JDIMENSION xoffset, yoffset;
+ JDIMENSION width_in_iMCUs, height_in_iMCUs;
JDIMENSION width_in_blocks, height_in_blocks;
-- int ci, h_samp_factor, v_samp_factor;
-+ int itemp, ci, h_samp_factor, v_samp_factor;
++ JDIMENSION dtemp;
+ int ci, h_samp_factor, v_samp_factor;
++ int itemp;
/* Determine number of components in output image */
if (info->force_grayscale &&
-@@ -917,34 +1224,113 @@
- if (info->crop_xoffset_set == JCROP_UNSET)
+@@ -957,33 +1266,112 @@
info->crop_xoffset = 0; /* default to +0 */
if (info->crop_yoffset_set == JCROP_UNSET)
-- info->crop_yoffset = 0; /* default to +0 */
+ info->crop_yoffset = 0; /* default to +0 */
- if (info->crop_xoffset >= info->output_width ||
- info->crop_yoffset >= info->output_height)
-+ info->crop_yoffset = 0; /* default to +0 */
+ if (info->crop_width_set == JCROP_UNSET) {
+ if (info->crop_xoffset >= info->output_width)
ERREXIT(srcinfo, JERR_BAD_CROP_SPEC);
@@ -442,14 +438,14 @@
/* Now adjust so that upper left corner falls at an iMCU boundary */
+ if (info->transform == JXFORM_DROP) {
+ /* Ensure the effective drop region will not exceed the requested */
-+ itemp = info->max_h_samp_factor * DCTSIZE;
++ itemp = info->iMCU_sample_width;
+ dtemp = itemp - 1 - ((xoffset + itemp - 1) % itemp);
+ xoffset += dtemp;
+ if (info->crop_width > dtemp)
+ info->drop_width = (info->crop_width - dtemp) / itemp;
+ else
+ info->drop_width = 0;
-+ itemp = info->max_v_samp_factor * DCTSIZE;
++ itemp = info->iMCU_sample_height;
+ dtemp = itemp - 1 - ((yoffset + itemp - 1) % itemp);
+ yoffset += dtemp;
+ if (info->crop_height > dtemp)
@@ -485,17 +481,17 @@
+ info->output_width = info->crop_width;
+ else
info->output_width =
- info->crop_width + (xoffset % (info->max_h_samp_factor * DCTSIZE));
+ info->crop_width + (xoffset % info->iMCU_sample_width);
+ if (info->crop_height > info->output_height)
+ info->output_height = info->crop_height;
+ else
info->output_height =
- info->crop_height + (yoffset % (info->max_v_samp_factor * DCTSIZE));
+ info->crop_height + (yoffset % info->iMCU_sample_height);
+ }
/* Save x/y offsets measured in iMCUs */
- info->x_crop_offset = xoffset / (info->max_h_samp_factor * DCTSIZE);
- info->y_crop_offset = yoffset / (info->max_v_samp_factor * DCTSIZE);
-@@ -960,7 +1346,9 @@
+ info->x_crop_offset = xoffset / info->iMCU_sample_width;
+ info->y_crop_offset = yoffset / info->iMCU_sample_height;
+@@ -999,7 +1387,9 @@
transpose_it = FALSE;
switch (info->transform) {
case JXFORM_NONE:
@@ -506,7 +502,7 @@
need_workspace = TRUE;
/* No workspace needed if neither cropping nor transforming */
break;
-@@ -1014,6 +1402,11 @@
+@@ -1053,6 +1443,11 @@
need_workspace = TRUE;
transpose_it = TRUE;
break;
@@ -518,7 +514,7 @@
}
/* Allocate workspace if needed.
-@@ -1309,6 +1702,11 @@
+@@ -1359,6 +1754,11 @@
case JXFORM_ROT_270:
transpose_critical_parameters(dstinfo);
break;
@@ -530,7 +526,7 @@
default:
break;
}
-@@ -1363,7 +1761,9 @@
+@@ -1413,7 +1813,9 @@
*/
switch (info->transform) {
case JXFORM_NONE:
@@ -541,7 +537,7 @@
do_crop(srcinfo, dstinfo, info->x_crop_offset, info->y_crop_offset,
src_coef_arrays, dst_coef_arrays);
break;
-@@ -1399,6 +1799,12 @@
+@@ -1449,6 +1851,12 @@
do_rot_270(srcinfo, dstinfo, info->x_crop_offset, info->y_crop_offset,
src_coef_arrays, dst_coef_arrays);
break;
diff --git a/graphics/jpeg/files/patch-transupp.h b/graphics/jpeg/files/patch-transupp.h
index 2073ae3c8775..c48d0e057b3a 100644
--- a/graphics/jpeg/files/patch-transupp.h
+++ b/graphics/jpeg/files/patch-transupp.h
@@ -1,6 +1,6 @@
---- transupp.h.orig 2003-09-21 23:01:30.000000000 +0200
-+++ transupp.h 2009-07-01 08:54:49.000000000 +0200
-@@ -96,7 +96,8 @@
+--- transupp.h.orig 2009-09-03 10:54:26.000000000 +0200
++++ transupp.h 2010-01-13 09:34:06.000000000 +0100
+@@ -101,7 +101,8 @@
JXFORM_TRANSVERSE, /* transpose across UR-to-LL axis */
JXFORM_ROT_90, /* 90-degree clockwise rotation */
JXFORM_ROT_180, /* 180-degree rotation */
@@ -10,7 +10,7 @@
} JXFORM_CODE;
/*
-@@ -136,6 +137,10 @@
+@@ -141,6 +142,10 @@
JDIMENSION crop_yoffset; /* Y offset of selected region */
JCROP_CODE crop_yoffset_set; /* (negative measures from bottom edge) */
@@ -21,16 +21,16 @@
/* Internal workspace: caller should not touch these */
int num_components; /* # of components in workspace */
jvirt_barray_ptr * workspace_coef_arrays; /* workspace for transformations */
-@@ -143,6 +148,8 @@
+@@ -148,6 +153,8 @@
JDIMENSION output_height;
JDIMENSION x_crop_offset; /* destination crop offsets measured in iMCUs */
JDIMENSION y_crop_offset;
+ JDIMENSION drop_width; /* drop dimensions measured in iMCUs */
+ JDIMENSION drop_height;
- int max_h_samp_factor; /* destination iMCU size */
- int max_v_samp_factor;
+ int iMCU_sample_width; /* destination iMCU size */
+ int iMCU_sample_height;
} jpeg_transform_info;
-@@ -191,7 +198,8 @@
+@@ -196,7 +203,8 @@
typedef enum {
JCOPYOPT_NONE, /* copy no optional markers */
JCOPYOPT_COMMENTS, /* copy only comment (COM) markers */
diff --git a/graphics/jpeg/pkg-plist b/graphics/jpeg/pkg-plist
index 6c08819ff034..95aa00bf60ed 100644
--- a/graphics/jpeg/pkg-plist
+++ b/graphics/jpeg/pkg-plist
@@ -14,7 +14,7 @@ include/jpeglib.h
lib/libjpeg.a
lib/libjpeg.la
lib/libjpeg.so
-lib/libjpeg.so.10
+lib/libjpeg.so.11
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/coderules.txt
%%PORTDOCS%%%%DOCSDIR%%/filelist.txt