aboutsummaryrefslogtreecommitdiff
path: root/graphics/jpgraph2/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-04-27 19:40:51 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-04-27 19:40:51 +0000
commitf86537335469d3108c7c6befb6bc132e890bc2bd (patch)
treee1a8b763bbd0eb83abbbd4e6940a4fc96c4c68ed /graphics/jpgraph2/Makefile
parente9c8720884d18c303155f5541e9c33589fa97734 (diff)
downloadports-f86537335469d3108c7c6befb6bc132e890bc2bd.tar.gz
ports-f86537335469d3108c7c6befb6bc132e890bc2bd.zip
- Add staging support
- Convert to USES=tar:bzip2, new options framework
Notes
Notes: svn path=/head/; revision=352454
Diffstat (limited to 'graphics/jpgraph2/Makefile')
-rw-r--r--graphics/jpgraph2/Makefile26
1 files changed, 11 insertions, 15 deletions
diff --git a/graphics/jpgraph2/Makefile b/graphics/jpgraph2/Makefile
index 5885a54c8a99..11ab65a97fdc 100644
--- a/graphics/jpgraph2/Makefile
+++ b/graphics/jpgraph2/Makefile
@@ -5,15 +5,15 @@ PORTNAME= jpgraph
PORTVERSION= 3.0.7
CATEGORIES= graphics
MASTER_SITES= http://hem.bredband.net/jpgraph2/
+PKGNAMESUFFIX= 2
MAINTAINER= ports@FreeBSD.org
COMMENT= Draw both "quick and dirty" graphs with a minimum of code
-USE_BZIP2= yes
+USES= tar:bzip2
NO_BUILD= yes
NO_WRKSUBDIR= yes
USE_PHP= gd
-NO_STAGE= yes
NO_CDROM= The free version cannot be used in a commercial context
@@ -21,20 +21,16 @@ PORTDATA= *
PORTDOCS= *
PORTEXAMPLES= *
-LATEST_LINK= jpgraph2
+OPTIONS_DEFINE= DOCS EXAMPLES
do-install:
- @${MKDIR} ${DATADIR}
- ${CP} ${WRKSRC}/src/*.php ${DATADIR}
- ${CP} ${WRKSRC}/src/*.dat ${DATADIR}
- ${CP} -R ${WRKSRC}/src/lang ${DATADIR}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${CP} -R ${WRKSRC}/docportal/* ${DOCSDIR}
-.endif
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- ${CP} ${WRKSRC}/src/Examples/* ${EXAMPLESDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${CP} ${WRKSRC}/src/*.php ${STAGEDIR}${DATADIR}
+ ${CP} ${WRKSRC}/src/*.dat ${STAGEDIR}${DATADIR}
+ ${CP} -R ${WRKSRC}/src/lang ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${CP} -R ${WRKSRC}/docportal/* ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/src/Examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>