aboutsummaryrefslogtreecommitdiff
path: root/graphics/kdegraphics3
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-01-05 02:29:15 +0000
committerWill Andrews <will@FreeBSD.org>2002-01-05 02:29:15 +0000
commit06517618a812d2a1631079a20caf7f3450155bad (patch)
tree78d48542d953726af080bfe301c2607b5d780984 /graphics/kdegraphics3
parent84a76d28958c9ce909d0e88281e6b8f2384ab39e (diff)
downloadports-06517618a812d2a1631079a20caf7f3450155bad.tar.gz
ports-06517618a812d2a1631079a20caf7f3450155bad.zip
Conditionalize use of objprelink based on whether we're running on
MACHINE_ARCH=i386 *and* whether NO_KDE_OBJPRELINK is defined. Requested by: several
Notes
Notes: svn path=/head/; revision=52585
Diffstat (limited to 'graphics/kdegraphics3')
-rw-r--r--graphics/kdegraphics3/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/graphics/kdegraphics3/Makefile b/graphics/kdegraphics3/Makefile
index fb598a3ecbad..c81a49daa395 100644
--- a/graphics/kdegraphics3/Makefile
+++ b/graphics/kdegraphics3/Makefile
@@ -16,8 +16,10 @@ MAINTAINER= kde@FreeBSD.org
BUILD_DEPENDS= dvips:${PORTSDIR}/print/teTeX \
autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14 \
- objprelink:${PORTSDIR}/devel/objprelink
+ automake14:${PORTSDIR}/devel/automake14
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+.endif
RUN_DEPENDS= dvips:${PORTSDIR}/print/teTeX
USE_KDELIBS_VER=2
@@ -25,7 +27,10 @@ USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS+=--without-kamera --enable-objprelink
+CONFIGURE_ARGS+=--without-kamera
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
CONFIGURE_ARGS+=--enable-final
.endif