aboutsummaryrefslogtreecommitdiff
path: root/graphics/kdegraphics4
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-03-09 19:41:12 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-03-09 19:41:12 +0000
commitf64c6af4f4d0803346188ad60d5055ea8b8d63dc (patch)
treea4ccebaea6c27a0834589e8629dbcdc5ee328c8b /graphics/kdegraphics4
parente96188d0c88794161a4508f2a16698da04fbba36 (diff)
downloadports-f64c6af4f4d0803346188ad60d5055ea8b8d63dc.tar.gz
ports-f64c6af4f4d0803346188ad60d5055ea8b8d63dc.zip
Update to KDE 3.2.1 / QT 3.3.1
Important changes: ================== KDE: - Audio/arts does not install artswrapper anymore, instead it is provided by audio/artswrapper. See UPDATING. - misc/kdeaddons3 is now a metaport with editors/kate-plugins editors/vimpart games/atlantikdesigner misc/kaddressbook-plugins misc/kfile-plugins misc/kicker-applets misc/knewsticker-scripts misc/konq-plugins misc/ksig misc/renamedlgplugins multimedia/noatun-plugins net/kontact-plugins as slave ports. - A number of KDE ports now uses OPTIONS do make various WITH_* options more visible. - Plist fixes - devel/kdevelop should be able to detect FreeBSD's autoconf/automake now for newly created projects. - kdebase will no longer remove previous KDM configurations. This won't take effect during the update from 3.2.0 to 3.2.1 (as deinstalling 3.2.0 will still remove the configuration), but subsequent updates will merge old configs. QT: - Previous versions of QT could be compiled with debugging-support enabled by defining DEBUG. This switch has been renamed to the more unambiguous WANT_QT_DEBUG (similar to WANT_KDE_DEBUG in the KDE ports).
Notes
Notes: svn path=/head/; revision=103453
Diffstat (limited to 'graphics/kdegraphics4')
-rw-r--r--graphics/kdegraphics4/Makefile100
-rw-r--r--graphics/kdegraphics4/distinfo3
-rw-r--r--graphics/kdegraphics4/files/plist.base3
-rw-r--r--graphics/kdegraphics4/files/plist.gphoto2.rm1
-rw-r--r--graphics/kdegraphics4/files/plist.imlib2
-rw-r--r--graphics/kdegraphics4/files/plist.sane3
6 files changed, 67 insertions, 45 deletions
diff --git a/graphics/kdegraphics4/Makefile b/graphics/kdegraphics4/Makefile
index 14d8e796a302..6eda9980cb34 100644
--- a/graphics/kdegraphics4/Makefile
+++ b/graphics/kdegraphics4/Makefile
@@ -8,16 +8,19 @@
PORTNAME= kdegraphics
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 2
CATEGORIES= graphics kde
MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Graphics utilities for the KDE3 integrated X11 desktop
-LIB_DEPENDS= fribidi:${PORTSDIR}/converters/fribidi \
+LIB_DEPENDS= art_lgpl_2:${PORTSDIR}/graphics/libart_lgpl2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ freetype:${PORTSDIR}/print/freetype2 \
+ fribidi:${PORTSDIR}/converters/fribidi \
+ lcms:${PORTSDIR}/graphics/lcms \
glut:${PORTSDIR}/graphics/libglut
RUN_DEPENDS= pdfinfo:${PORTSDIR}/graphics/xpdf
@@ -33,69 +36,78 @@ WANT_GNOME= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
+OPTIONS= IMLIB "Build Kuickshow, a fast and versatile image viewer" off \
+ GPHOTO2 "Enable support for digital cameras" off \
+ SANE "Build Kooka, a SANE scanner frontend for KDE" off
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
-IMLIB_CONFIG= ${X11BASE}/bin/imlib-config
+.if exists (${X11BASE}/bin/imlib-config)
+. if !defined(WITH_IMLIB)
+IMLIB_OVERRIDE= yes
+WITH_IMLIB= yes
+. endif
+.endif
+
+.if exists(${LOCALBASE}/bin/gphoto2-config)
+. if !defined(WITH_GPHOTO2)
+GPHOTO2_OVERRIDE= yes
+WITH_GPHOTO2= yes
+. endif
+.endif
-.if exists(${IMLIB_CONFIG})
-WITH_IMLIB?= yes
+.if exists (${LOCALBASE}/bin/sane-config)
+. if !defined(WITH_SANE)
+SANE_OVERRIDE= yes
+WITH_SANE= yes
+. endif
.endif
-.if defined(WITH_IMLIB) || defined(KDE_WITH_IMLIB)
+.if defined(WITH_IMLIB)
USE_GNOME= imlib
PLIST_APPEND+= plist.imlib
CONFIGURE_ARGS+=--with-imlib-config=${X11BASE}/bin
.else
WITHOUT_IMLIB= yes
CONFIGURE_ARGS+=--without-imlib-config
-pre-everything::
- @${ECHO_MSG}
- @${ECHO_MSG} "======================================================="
- @${ECHO_MSG} "If you want to compile with imlib support (enables"
- @${ECHO_MSG} "kuickshow), hit Ctrl-C right now and use"
- @${ECHO_MSG} "\"make WITH_IMLIB=yes\""
- @${ECHO_MSG} "======================================================="
- @${ECHO_MSG}
-.endif # defined(WITH_IMLIB) || defined(KDE_WITH_IMLIB)
-
-GPHOTO2_CONFIG= ${LOCALBASE}/bin/gphoto2-config
-
-.if exists(${GPHOTO2_CONFIG})
-WITH_GPHOTO2?= yes
-.endif # exists(${GPHOTO2_CONFIG})
+.endif
.if defined(WITH_GPHOTO2)
LIB_DEPENDS+= gphoto2.2:${PORTSDIR}/graphics/gphoto2
PLIST_APPEND+= plist.gphoto2
-.else
-pre-everything::
- @${ECHO_MSG}
- @${ECHO_MSG} "======================================================="
- @${ECHO_MSG} "If you want to compile with digital camera support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_GPHOTO2=yes\""
- @${ECHO_MSG} "======================================================="
- @${ECHO_MSG}
-.endif # defined(WITH_GPHOTO2)
-
-SANE_CONFIG= ${LOCALBASE}/bin/sane-config
-
-.if exists(${SANE_CONFIG})
-WITH_SANE?= yes
-.endif # exists(${SANE_CONFIG})
+.endif
.if defined(WITH_SANE)
LIB_DEPENDS+= sane.1:${PORTSDIR}/graphics/sane-backends
PLIST_APPEND+= plist.sane
-RUN_DEPENDS= ${LOCALBASE}/bin/gocr:${PORTSDIR}/graphics/gocr
-.else
+RUN_DEPENDS+= ${LOCALBASE}/bin/gocr:${PORTSDIR}/graphics/gocr
+.endif
+
pre-everything::
+.if defined(IMLIB_OVERRIDE)
@${ECHO_MSG}
- @${ECHO_MSG} "======================================================="
- @${ECHO_MSG} "If you want to compile with scanner (SANE) support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_SANE=yes\""
- @${ECHO_MSG} "======================================================="
+ @${ECHO_MSG} "********************************************************"
+ @${ECHO_MSG} "* imlib is installed but WITH_IMLIB is not set! *"
+ @${ECHO_MSG} "* WITH_IMLIB has been enabled automatically. *"
+ @${ECHO_MSG} "********************************************************"
@${ECHO_MSG}
-.endif # defined(WITH_SANE)
+.endif
+.if defined(GPHOTO2_OVERRIDE)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "********************************************************"
+ @${ECHO_MSG} "* gphoto2 is installed but WITH_GPHOTO2 is not set! *"
+ @${ECHO_MSG} "* WITH_GPHOTO2 has been enabled automatically. *"
+ @${ECHO_MSG} "********************************************************"
+ @${ECHO_MSG}
+.endif
+.if defined(SANE_OVERRIDE)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "********************************************************"
+ @${ECHO_MSG} "* sane-backends is installed but WITH_SANE is not set! *"
+ @${ECHO_MSG} "* WITH_SANE has been enabled automatically. *"
+ @${ECHO_MSG} "********************************************************"
+ @${ECHO_MSG}
+.endif
.include <bsd.port.post.mk>
diff --git a/graphics/kdegraphics4/distinfo b/graphics/kdegraphics4/distinfo
index 3182e43b466e..9596e1b4a012 100644
--- a/graphics/kdegraphics4/distinfo
+++ b/graphics/kdegraphics4/distinfo
@@ -1 +1,2 @@
-MD5 (KDE/kdegraphics-3.2.0.tar.bz2) = 675dd4f557574097b911350cc47f0843
+MD5 (KDE/kdegraphics-3.2.1.tar.bz2) = 5a1676b46efdd64be2f9e9604f04b176
+SIZE (KDE/kdegraphics-3.2.1.tar.bz2) = 5726582
diff --git a/graphics/kdegraphics4/files/plist.base b/graphics/kdegraphics4/files/plist.base
index 42b60c4f7145..6e68b721cd34 100644
--- a/graphics/kdegraphics4/files/plist.base
+++ b/graphics/kdegraphics4/files/plist.base
@@ -257,6 +257,9 @@ lib/libkdeinit_kview.la
lib/libkdeinit_kview.so
lib/libkdeinit_mrmlsearch.la
lib/libkdeinit_mrmlsearch.so
+lib/libkghostviewlib.la
+lib/libkghostviewlib.so
+lib/libkghostviewlib.so.0
lib/libkimageviewer.la
lib/libkimageviewer.so
lib/libkimageviewer.so.0
diff --git a/graphics/kdegraphics4/files/plist.gphoto2.rm b/graphics/kdegraphics4/files/plist.gphoto2.rm
index 416dcdb37c4f..38f836bd65ab 100644
--- a/graphics/kdegraphics4/files/plist.gphoto2.rm
+++ b/graphics/kdegraphics4/files/plist.gphoto2.rm
@@ -3,3 +3,4 @@
@dirrm share/icons/crystalsvg/16x16/devices
@dirrm share/icons/crystalsvg/16x16/actions
@dirrm share/applnk/Settings/Peripherals
+@dirrm share/applnk/Settings
diff --git a/graphics/kdegraphics4/files/plist.imlib b/graphics/kdegraphics4/files/plist.imlib
index 4234e25b9dc7..4a85b7b67e47 100644
--- a/graphics/kdegraphics4/files/plist.imlib
+++ b/graphics/kdegraphics4/files/plist.imlib
@@ -1,6 +1,8 @@
bin/kuickshow
lib/kde3/kuickshow.la
lib/kde3/kuickshow.so
+lib/libkdeinit_kuickshow.la
+lib/libkdeinit_kuickshow.so
share/applications/kde/kuickshow.desktop
share/apps/kuickshow/im_palette.pal
share/apps/kuickshow/pics/about.png
diff --git a/graphics/kdegraphics4/files/plist.sane b/graphics/kdegraphics4/files/plist.sane
index 4657270b56ed..6f4557e60204 100644
--- a/graphics/kdegraphics4/files/plist.sane
+++ b/graphics/kdegraphics4/files/plist.sane
@@ -19,12 +19,15 @@ lib/libkscan.so
lib/libkscan.so.1
share/applications/kde/kooka.desktop
share/apps/kooka/kookaui.rc
+share/apps/kooka/pics/gocr.png
+share/apps/kooka/pics/lockzoom.png
share/apps/kooka/pics/mirror-both.png
share/apps/kooka/pics/mirror-horiz.png
share/apps/kooka/pics/mirror-vert.png
share/apps/kooka/pics/newfromselect.png
share/apps/kooka/pics/ocr-select.png
share/apps/kooka/pics/ocr.png
+share/apps/kooka/pics/ocrad.png
share/apps/kooka/pics/scaleorig.png
share/apps/kooka/pics/scaletoheight.png
share/apps/kooka/pics/scaletowidth.png