aboutsummaryrefslogtreecommitdiff
path: root/graphics/klatexformula/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-04-18 09:40:35 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-04-18 09:40:35 +0000
commitf7670aefe0851f470af889cf21037b1ffba7f1a0 (patch)
tree98bc3b1c484baf6b528e69ebddcf8dd59c5701c6 /graphics/klatexformula/Makefile
parent6ed528f89a05e069033e9c5e45d39dc1674002d4 (diff)
downloadports-f7670aefe0851f470af889cf21037b1ffba7f1a0.tar.gz
ports-f7670aefe0851f470af889cf21037b1ffba7f1a0.zip
graphics/klatexformula:
- Update to 3.2.8 - Add dependence on help2man and install man pages - Fix build with clang-3.4
Notes
Notes: svn path=/head/; revision=351527
Diffstat (limited to 'graphics/klatexformula/Makefile')
-rw-r--r--graphics/klatexformula/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/graphics/klatexformula/Makefile b/graphics/klatexformula/Makefile
index 6c60e3ac21af..a67dcb4fbcd1 100644
--- a/graphics/klatexformula/Makefile
+++ b/graphics/klatexformula/Makefile
@@ -1,23 +1,26 @@
# $FreeBSD$
PORTNAME= klatexformula
-PORTVERSION= 3.2.7
+PORTVERSION= 3.2.8
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= makc@FreeBSD.org
COMMENT= Convert LaTeX formula to image
+BUILD_DEPENDS= help2man:${PORTSDIR}/misc/help2man
+
USES= cmake:outsource shared-mime-info
USE_QT4= gui xml dbus designer_build linguist_build \
qmake_build moc_build rcc_build uic_build
USE_TEX= latex dvipsk
-HAS_CONFIGURE= yes
-USE_GHOSTSCRIPT= yes
+USE_GHOSTSCRIPT_RUN= yes
CMAKE_ARGS= -DQT_QMAKE_EXECUTABLE_FINDQT=${QMAKE} \
-DKLF_BUILD_KTEXTEDITORPLUGIN=off \
- -DKLF_INSTALL_POST_UPDATEMIMEDATABASE=off
+ -DKLF_INSTALL_POST_UPDATEMIMEDATABASE=off \
+ -DKLF_INSTALL_SHARE_MAN1_DIR=man/man1
CXXFLAGS= -I${LOCALBASE}/include
+MAKE_ENV= HOME=/dev/null
PLIST_SUB= VERSION=${PORTVERSION}