aboutsummaryrefslogtreecommitdiff
path: root/graphics/kphotoalbum-kde4
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
commit0f583d87000061087521fb77c44c9055d122d787 (patch)
treeb9dc00f333e96550a5732b38b9c9444035e4339c /graphics/kphotoalbum-kde4
parent558a51279c03199a7a20966174a8f0a1f33dc9b2 (diff)
downloadports-0f583d87000061087521fb77c44c9055d122d787.tar.gz
ports-0f583d87000061087521fb77c44c9055d122d787.zip
Replace Mk/bsd.kde4.mk by Mk/Uses/kde.mk in preparation for KDE Frameworks and
Plasma5 ports At the moment KDE ports use bsd.kde4.mk to handle their dependencies. When working on the ports for KDE Frameworks and Plasma5 it seemed to be more reasonable to create a new kde.mk instead of adding an bsd.kde5.mk. The kde.mk in this review is a stripped down version of the one we are using in the KDE Test repositories plasma5 branch [1] to only contain the parts relevant to the current KDE4 ports in the portstree [2]. Changes to the KDE Ports needed by this: Replace USE_KDE4 by USE_KDE [3] Add USES=kde:4 [4] [1] http://src.mouf.net/area51/view/branches/plasma5/KDE/Mk/Uses/kde.mk [2] The version in the plasma5 branch also handles frameworks/plasma5 and handles MASTER_SITES via a KDE_DIST variable similar to bsd.qt.mk for Qt Ports -- I chose to leave this out for now, as the diff is already large enough. [3] I chose USE_KDE instead of USE_KDE4, USE_KDE5, USE_KDEX as the version we want is already specified as argument to kde:<arg> [4] For KDE Frameworks and Plasma5 ports this would be kde:5 PR: 210667 Approved by: portmgr, mat (mentor), rakuco (mentor) Reviewed by: mat, rakuco Differential Revision: https://reviews.freebsd.org/D6961
Notes
Notes: svn path=/head/; revision=420774
Diffstat (limited to 'graphics/kphotoalbum-kde4')
-rw-r--r--graphics/kphotoalbum-kde4/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/graphics/kphotoalbum-kde4/Makefile b/graphics/kphotoalbum-kde4/Makefile
index 2e5cb81256eb..a51728884722 100644
--- a/graphics/kphotoalbum-kde4/Makefile
+++ b/graphics/kphotoalbum-kde4/Makefile
@@ -13,9 +13,10 @@ COMMENT= Image viewer and organizer for KDE
LIB_DEPENDS= libexiv2.so:graphics/exiv2
-USES= cmake:outsource jpeg pkgconfig shebangfix tar:bzip2
SHEBANG_FILES= script/open-raw.pl script/kpa-backup.sh
-USE_KDE4= kdelibs libkdcraw libkipi automoc4
+
+USES= cmake:outsource jpeg kde:4 pkgconfig shebangfix tar:bzip2
+USE_KDE= kdelibs libkdcraw libkipi automoc4
USE_QT4= phonon sql \
qmake_build moc_build rcc_build uic_build
@@ -24,7 +25,7 @@ OPTIONS_DEFAULT= MARBLE
OPTIONS_SUB= yes # NLS
MARBLE_DESC= Geolocation support
-MARBLE_USE= KDE4=marble
+MARBLE_USE= KDE=marble
MARBLE_CMAKE_OFF= -DWITH_Marble:BOOL=Off
NLS_USES= gettext