aboutsummaryrefslogtreecommitdiff
path: root/graphics/krita
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-12-22 14:33:41 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-12-22 20:01:30 +0000
commit11b08d733b7c027401aa514d11028a9482c57e93 (patch)
treea2a9ba27561306a7c06c0a5d50973eccb298ebaf /graphics/krita
parente213fd667934a8ab3e85aaa39ecb8190d5733f0f (diff)
downloadports-11b08d733b7c027401aa514d11028a9482c57e93.tar.gz
ports-11b08d733b7c027401aa514d11028a9482c57e93.zip
graphics/libjxl: update to 0.9.0
Changes: https://github.com/libjxl/libjxl/releases/tag/v0.9.0 Reported by: GitHub (watch releases)
Diffstat (limited to 'graphics/krita')
-rw-r--r--graphics/krita/Makefile1
-rw-r--r--graphics/krita/files/patch-plugins_impex_jxl_JPEGXLImport.cpp74
2 files changed, 75 insertions, 0 deletions
diff --git a/graphics/krita/Makefile b/graphics/krita/Makefile
index 260834ac6951..2d918764c54f 100644
--- a/graphics/krita/Makefile
+++ b/graphics/krita/Makefile
@@ -1,5 +1,6 @@
PORTNAME= krita
DISTVERSION= 5.2.2
+PORTREVISION= 1
CATEGORIES= graphics kde
MASTER_SITES= KDE/stable/${PORTNAME}/${DISTVERSION}
DIST_SUBDIR= KDE/${PORTNAME}
diff --git a/graphics/krita/files/patch-plugins_impex_jxl_JPEGXLImport.cpp b/graphics/krita/files/patch-plugins_impex_jxl_JPEGXLImport.cpp
new file mode 100644
index 000000000000..f3fdc06afac7
--- /dev/null
+++ b/graphics/krita/files/patch-plugins_impex_jxl_JPEGXLImport.cpp
@@ -0,0 +1,74 @@
+plugins/impex/jxl/JPEGXLImport.cpp:513:20: error: no matching function for call to 'JxlDecoderGetColorAsEncodedProfile'
+ == JxlDecoderGetColorAsEncodedProfile(dec.get(),
+ ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+/usr/local/include/jxl/decode.h:749:29: note: candidate function not viable: requires 3 arguments, but 4 were provided
+JXL_EXPORT JxlDecoderStatus JxlDecoderGetColorAsEncodedProfile(
+ ^
+plugins/impex/jxl/JPEGXLImport.cpp:638:24: error: no matching function for call to 'JxlDecoderGetICCProfileSize'
+ != JxlDecoderGetICCProfileSize(dec.get(), nullptr, JXL_COLOR_PROFILE_TARGET_DATA, &iccSize)) {
+ ^~~~~~~~~~~~~~~~~~~~~~~~~~~
+/usr/local/include/jxl/decode.h:775:29: note: candidate function not viable: requires 3 arguments, but 4 were provided
+JXL_EXPORT JxlDecoderStatus JxlDecoderGetICCProfileSize(
+ ^
+plugins/impex/jxl/JPEGXLImport.cpp:645:24: error: no matching function for call to 'JxlDecoderGetColorAsICCProfile'
+ != JxlDecoderGetColorAsICCProfile(dec.get(),
+ ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+/usr/local/include/jxl/decode.h:793:29: note: candidate function not viable: requires 4 arguments, but 5 were provided
+JXL_EXPORT JxlDecoderStatus JxlDecoderGetColorAsICCProfile(
+ ^
+plugins/impex/jxl/JPEGXLImport.cpp:659:28: error: no matching function for call to 'JxlDecoderGetICCProfileSize'
+ != JxlDecoderGetICCProfileSize(dec.get(),
+ ^~~~~~~~~~~~~~~~~~~~~~~~~~~
+/usr/local/include/jxl/decode.h:775:29: note: candidate function not viable: requires 3 arguments, but 4 were provided
+JXL_EXPORT JxlDecoderStatus JxlDecoderGetICCProfileSize(
+ ^
+plugins/impex/jxl/JPEGXLImport.cpp:669:28: error: no matching function for call to 'JxlDecoderGetColorAsICCProfile'
+ != JxlDecoderGetColorAsICCProfile(dec.get(),
+ ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+/usr/local/include/jxl/decode.h:793:29: note: candidate function not viable: requires 4 arguments, but 5 were provided
+JXL_EXPORT JxlDecoderStatus JxlDecoderGetColorAsICCProfile(
+ ^
+
+--- plugins/impex/jxl/JPEGXLImport.cpp.orig 2023-12-06 11:38:26 UTC
++++ plugins/impex/jxl/JPEGXLImport.cpp
+@@ -511,7 +511,6 @@ JPEGXLImport::convert(KisDocument *document, QIODevice
+ JxlColorEncoding colorEncoding{};
+ if (JXL_DEC_SUCCESS
+ == JxlDecoderGetColorAsEncodedProfile(dec.get(),
+- nullptr,
+ JXL_COLOR_PROFILE_TARGET_DATA,
+ &colorEncoding)) {
+ const TransferCharacteristics transferFunction = [&]() {
+@@ -635,7 +634,7 @@ JPEGXLImport::convert(KisDocument *document, QIODevice
+ size_t iccSize = 0;
+ QByteArray iccProfile;
+ if (JXL_DEC_SUCCESS
+- != JxlDecoderGetICCProfileSize(dec.get(), nullptr, JXL_COLOR_PROFILE_TARGET_DATA, &iccSize)) {
++ != JxlDecoderGetICCProfileSize(dec.get(), JXL_COLOR_PROFILE_TARGET_DATA, &iccSize)) {
+ errFile << "ICC profile size retrieval failed";
+ document->setErrorMessage(i18nc("JPEG-XL errors", "Unable to read the image profile."));
+ return ImportExportCodes::ErrorWhileReading;
+@@ -643,7 +642,6 @@ JPEGXLImport::convert(KisDocument *document, QIODevice
+ iccProfile.resize(static_cast<int>(iccSize));
+ if (JXL_DEC_SUCCESS
+ != JxlDecoderGetColorAsICCProfile(dec.get(),
+- nullptr,
+ JXL_COLOR_PROFILE_TARGET_DATA,
+ reinterpret_cast<uint8_t *>(iccProfile.data()),
+ static_cast<size_t>(iccProfile.size()))) {
+@@ -657,7 +655,6 @@ JPEGXLImport::convert(KisDocument *document, QIODevice
+ if (!d.m_info.uses_original_profile) {
+ if (JXL_DEC_SUCCESS
+ != JxlDecoderGetICCProfileSize(dec.get(),
+- nullptr,
+ JXL_COLOR_PROFILE_TARGET_ORIGINAL,
+ &iccTargetSize)) {
+ errFile << "ICC profile size retrieval failed";
+@@ -667,7 +664,6 @@ JPEGXLImport::convert(KisDocument *document, QIODevice
+ iccTargetProfile.resize(static_cast<int>(iccTargetSize));
+ if (JXL_DEC_SUCCESS
+ != JxlDecoderGetColorAsICCProfile(dec.get(),
+- nullptr,
+ JXL_COLOR_PROFILE_TARGET_ORIGINAL,
+ reinterpret_cast<uint8_t *>(iccTargetProfile.data()),
+ static_cast<size_t>(iccTargetProfile.size()))) {