aboutsummaryrefslogtreecommitdiff
path: root/graphics/lcdtest
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-01-02 19:28:05 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-01-02 19:28:05 +0000
commit1bf071adf0ffd2c1e836134624ba8716fc663435 (patch)
tree135e2d321bb5305b67426f84719058fe6b216cd7 /graphics/lcdtest
parentf81a5397df73458a27caefaf18067354a7e4319b (diff)
downloadports-1bf071adf0ffd2c1e836134624ba8716fc663435.tar.gz
ports-1bf071adf0ffd2c1e836134624ba8716fc663435.zip
- Bump PORTREVISION
- Change master sites, icon - Use PLIST_FILES instead of pkg-plist - Support STAGEDIR - Simplify Option DOCS handling Approved by: pawel / wg (mentors, implicit)
Notes
Notes: svn path=/head/; revision=338467
Diffstat (limited to 'graphics/lcdtest')
-rw-r--r--graphics/lcdtest/Makefile42
-rw-r--r--graphics/lcdtest/distinfo2
-rw-r--r--graphics/lcdtest/pkg-plist5
3 files changed, 22 insertions, 27 deletions
diff --git a/graphics/lcdtest/Makefile b/graphics/lcdtest/Makefile
index c164ee50753e..9b723d15f023 100644
--- a/graphics/lcdtest/Makefile
+++ b/graphics/lcdtest/Makefile
@@ -3,9 +3,13 @@
PORTNAME= lcdtest
PORTVERSION= 1.18
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics
-MASTER_SITES= http://www.brouhaha.com/~eric/software/lcdtest/download/
+MASTER_SITES= http://www.brouhaha.com/~eric/software/lcdtest/download/ \
+ SF/nemysisfreebsdp/${CATEGORIES}/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= nemysis@FreeBSD.org
COMMENT= LCD monitor test pattern generator
@@ -19,21 +23,15 @@ USE_SDL= sdl image ttf
CFLAGS+= -I${LOCALBASE}/include -DRELEASE=1.18
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lSDL -lSDL_image -lSDL_ttf
-PORTDOCS= README
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz \
+ share/applications/${PORTNAME}.desktop \
+ share/pixmaps/${PORTNAME}.png
-MAN1= lcdtest.1
+PORTDOCS= README
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-PLIST_SUB+= PORTDOCS=""
-.else
-PLIST_SUB+= PORTDOCS="@comment "
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|/usr/share/fonts/liberation/|${LOCALBASE}/lib/X11/fonts/Liberation/|' \
${WRKSRC}/src/lcdtest.c
@@ -43,14 +41,14 @@ do-build:
(cd ${WRKSRC}/src && ${CC} ${LDFLAGS} -o lcdtest lcdtest.o)
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/man/${MAN1} ${MAN1PREFIX}/man/man1/
- ${INSTALL_DATA} ${WRKSRC}/desktop/${PORTNAME}.svg ${PREFIX}/share/pixmaps/
- ${INSTALL_DATA} ${WRKSRC}/desktop/${PORTNAME}.desktop ${PREFIX}/share/applications/
-
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${INSTALL_DATA} ${WRKSRC}/desktop/${PORTNAME}.desktop \
+ ${STAGEDIR}${DESKTOPDIR}
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/graphics/lcdtest/distinfo b/graphics/lcdtest/distinfo
index d7b24bf4cf88..cfe2fdd6db55 100644
--- a/graphics/lcdtest/distinfo
+++ b/graphics/lcdtest/distinfo
@@ -1,2 +1,4 @@
SHA256 (lcdtest-1.18.tar.gz) = f0b3fa9c5a4bc86eb2713f85f422d328a673ca8f541a6403bfe156afd631200e
SIZE (lcdtest-1.18.tar.gz) = 26886
+SHA256 (lcdtest.png) = bab95d97f827fd03bb3b31bdb27a5ed9fbe68dea0090ebbb4ad32b10c74345e0
+SIZE (lcdtest.png) = 2361
diff --git a/graphics/lcdtest/pkg-plist b/graphics/lcdtest/pkg-plist
deleted file mode 100644
index 516963fedf04..000000000000
--- a/graphics/lcdtest/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/lcdtest
-share/applications/lcdtest.desktop
-%%PORTDOCS%%%%DOCSDIR%%/README
-share/pixmaps/lcdtest.svg
-%%PORTDOCS%%@dirrm %%DOCSDIR%%