aboutsummaryrefslogtreecommitdiff
path: root/graphics/libboard
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-10-21 14:06:12 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-10-21 14:06:12 +0000
commit75235ed507dcbc22b22d62a044c620ecefb35073 (patch)
tree7ffce62d4fc30b9c006687a1f9013f6a42351b17 /graphics/libboard
parent2cf10562bf804dc69986918c5f73b04614f89b94 (diff)
downloadports-75235ed507dcbc22b22d62a044c620ecefb35073.tar.gz
ports-75235ed507dcbc22b22d62a044c620ecefb35073.zip
- Mark BROKEN on 9.x:
src/Tools.cpp:204: error: 'snprintf' is not a member of 'std' - Switch to options helpers - Switch to new test framework Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=424418
Diffstat (limited to 'graphics/libboard')
-rw-r--r--graphics/libboard/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/graphics/libboard/Makefile b/graphics/libboard/Makefile
index 5f7cef89763a..c98032d40f60 100644
--- a/graphics/libboard/Makefile
+++ b/graphics/libboard/Makefile
@@ -13,6 +13,8 @@ LICENSE= LGPL3
BUILD_DEPENDS= doxygen:devel/doxygen
LIB_DEPENDS= libMagick++-6.so:graphics/ImageMagick
+BROKEN_FreeBSD_9= does not build
+
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
CONFIGURE_ENV= CXX=${CXX}
@@ -40,19 +42,19 @@ pre-configure:
post-install:
${MV} ${STAGEDIR}${PREFIX}/lib/libboard.so ${STAGEDIR}${PREFIX}/lib/libboard.so.0
${LN} -sf libboard.so.0 ${STAGEDIR}${PREFIX}/lib/libboard.so
-.if ${PORT_OPTIONS:MDOCS}
+
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/doc/html/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/
${RM} -r ${STAGEDIR}${DOCSDIR}/.svn
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
+
+post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}/
cd ${WRKSRC}/bin/ && ${COPYTREE_BIN} . ${STAGEDIR}${EXAMPLESDIR}/
${RM} -r ${STAGEDIR}${EXAMPLESDIR}/.svn
-.endif
-regression-test:
+do-test:
(cd ${WRKDIR} && ${WRKSRC}/bin/arithmetic bec)
.for ex in 1 2 3
(cd ${WRKDIR} && ${WRKSRC}/bin/example${ex})