aboutsummaryrefslogtreecommitdiff
path: root/graphics/libchamplain/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2017-05-30 11:18:24 +0000
committerKoop Mast <kwm@FreeBSD.org>2017-05-30 11:18:24 +0000
commit2b97aa310d3fa36f5c59353391befc81613f59be (patch)
tree319f0fdbdece06511146f6b80ba26f1aee7159af /graphics/libchamplain/Makefile
parent90ad0414caaadcaabc2a265db6182e962e7d59ce (diff)
downloadports-2b97aa310d3fa36f5c59353391befc81613f59be.tar.gz
ports-2b97aa310d3fa36f5c59353391befc81613f59be.zip
Update libchamplain to 0.12.15.
* Add license * Review/add missing dependencies * Switch to USES=localbase Obtained from: gnome devel repo
Notes
Notes: svn path=/head/; revision=442058
Diffstat (limited to 'graphics/libchamplain/Makefile')
-rw-r--r--graphics/libchamplain/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/graphics/libchamplain/Makefile b/graphics/libchamplain/Makefile
index 5c3d095c1ebb..466925d59b34 100644
--- a/graphics/libchamplain/Makefile
+++ b/graphics/libchamplain/Makefile
@@ -2,24 +2,29 @@
# $FreeBSD$
PORTNAME= libchamplain
-PORTVERSION= 0.12.13
-PORTREVISION= 1
+PORTVERSION= 0.12.15
CATEGORIES= graphics
MASTER_SITES= GNOME
MAINTAINER= gnome@FreeBSD.org
COMMENT= C library aimed to provide a Gtk+ widget to display rasterized maps and markers
-LIB_DEPENDS= libclutter-gtk-1.0.so:graphics/clutter-gtk3 \
- libsoup-gnome-2.4.so:devel/libsoup-gnome
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake gnome libtool pathfix pkgconfig sqlite tar:xz
-USE_GNOME= gtk30 introspection:build
-USE_GL= gl
+LIB_DEPENDS= libcogl.so:graphics/cogl \
+ libclutter-1.0.so:graphics/clutter \
+ libclutter-gtk-1.0.so:graphics/clutter-gtk3 \
+ libjson-glib-1.0.so:devel/json-glib \
+ libsoup-2.4.so:devel/libsoup
+
+USES= gettext-runtime gmake gnome libtool localbase pathfix \
+ pkgconfig sqlite tar:xz
+USE_GNOME= cairo gdkpixbuf2 gtk30 introspection:build
+USE_GL= egl
+USE_XORG= x11 xcomposite xdamage xext xfixes xi xrandr
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --enable-gtk-doc-html=no
INSTALL_TARGET= install-strip