aboutsummaryrefslogtreecommitdiff
path: root/graphics/libdmtx/Makefile
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2009-04-23 17:06:44 +0000
committerJohan van Selst <johans@FreeBSD.org>2009-04-23 17:06:44 +0000
commitd1d269d44145ecc026b3c81459e0652fcd6844fe (patch)
tree307678e1eb236b7de14d1eaedcbb0b6aa8e0a69d /graphics/libdmtx/Makefile
parent271ee243cdd9b79bd45a24daca5bbc0778dbd9f3 (diff)
downloadports-d1d269d44145ecc026b3c81459e0652fcd6844fe.tar.gz
ports-d1d269d44145ecc026b3c81459e0652fcd6844fe.zip
libdmtx is open source software for reading and writing Data Matrix
barcodes on Linux, Unix, OS X, Windows, and certain mobile devices. At its core libdmtx is a shared library, allowing C/C++ programs to use its capabilities without restrictions or overhead. The included utility programs, dmtxread and dmtxwrite, serve as the official interface to libdmtx from the command line, and also provide a good reference for programmers who wish to write their own programs that interact with libdmtx. WWW: http://www.libdmtx.org/
Notes
Notes: svn path=/head/; revision=232594
Diffstat (limited to 'graphics/libdmtx/Makefile')
-rw-r--r--graphics/libdmtx/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/graphics/libdmtx/Makefile b/graphics/libdmtx/Makefile
new file mode 100644
index 000000000000..6b6fc7f2d030
--- /dev/null
+++ b/graphics/libdmtx/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: libdmtx
+# Date created: 16 April 2009
+# Whom: johans
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdmtx
+PORTVERSION= 0.7.0
+CATEGORIES= graphics
+MASTER_SITES= SF
+
+MAINTAINER= johans@stack.nl
+COMMENT= Software for reading and writing Data Matrix barcodes
+
+LIB_DEPENDS= MagickWand.2:${PORTSDIR}/graphics/ImageMagick
+
+MAN1= dmtxread.1 dmtxwrite.1 dmtxquery.1
+MAN3= libdmtx.3
+
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>