aboutsummaryrefslogtreecommitdiff
path: root/graphics/libdrm
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-06-30 17:31:49 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-06-30 17:31:49 +0000
commitebdf3d40d7da82993edea6672e6d6eb62824af96 (patch)
treedc0bfaf9b7394d117546f16cd8de2b87d14a55d8 /graphics/libdrm
parent1cb0c79339615b1651f1f134e33195a86f802a1f (diff)
downloadports-ebdf3d40d7da82993edea6672e6d6eb62824af96.tar.gz
ports-ebdf3d40d7da82993edea6672e6d6eb62824af96.zip
graphics/libdrm: Update to 2.4.98
Update graphics/libdrm to 2.4.98 [1] Change to use the meson build system instead of autotools. [2] PR: 235430 [1], 237411 [2] Submitted by: Greg V [1], jbiech [2]
Notes
Notes: svn path=/head/; revision=505441
Diffstat (limited to 'graphics/libdrm')
-rw-r--r--graphics/libdrm/Makefile17
-rw-r--r--graphics/libdrm/distinfo6
-rw-r--r--graphics/libdrm/files/patch-meson.build23
-rw-r--r--graphics/libdrm/files/patch-xf86drm.c34
4 files changed, 39 insertions, 41 deletions
diff --git a/graphics/libdrm/Makefile b/graphics/libdrm/Makefile
index e09714cc4fd1..01d23c013588 100644
--- a/graphics/libdrm/Makefile
+++ b/graphics/libdrm/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libdrm
-PORTVERSION= 2.4.96
+PORTVERSION= 2.4.98
PORTEPOCH= 1
CATEGORIES= graphics x11
MASTER_SITES= http://dri.freedesktop.org/libdrm/
@@ -15,10 +15,8 @@ LICENSE= MIT
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
LIB_DEPENDS= libpciaccess.so:devel/libpciaccess
-USES= libtool pkgconfig tar:bzip2
-GNU_CONFIGURE= yes
+USES= gnome meson pkgconfig tar:bzip2
USE_LDCONFIG= yes
-INSTALL_TARGET= install-strip
OPTIONS_DEFINE= MANPAGES TESTS
OPTIONS_SUB= yes
@@ -29,14 +27,14 @@ TESTS_DESC= Install test programs (which are always built)
OPTIONS_DEFAULT+= MANPAGES
.endif
-MANPAGES_CONFIGURE_ENABLE= manpages
MANPAGES_BUILD_DEPENDS= ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:textproc/docbook-xsl
MANPAGES_USE= GNOME=libxslt:build
+MANPAGES_MESON_TRUE= man-pages
-TESTS_CONFIGURE_ENABLE= install-test-programs
+TESTS_MESON_TRUE= install-test-programs
# avoid circular dependency in case cairo supports OpenGL (cairo->mesa-libs->libdrm->cairo)
-CONFIGURE_ARGS+= --disable-cairo-tests
+CONFIGURE_ARGS+= -Dcairo-tests=false
.include <bsd.port.options.mk>
@@ -68,9 +66,4 @@ PLIST_SUB+= RADEON_DRIVERS="@comment "
EXTRA_PATCHES+= ${FILESDIR}/extra-xf86drm.c
.endif
-pre-patch:
- @${REINPLACE_CMD} 's|{libdir}/pkgconfig|{prefix}/libdata/pkgconfig|g; \
- s,i?86|x86_64),i?86|amd64|x86_64),g' \
- ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/graphics/libdrm/distinfo b/graphics/libdrm/distinfo
index 91038e3426cc..7867fb7cbdcf 100644
--- a/graphics/libdrm/distinfo
+++ b/graphics/libdrm/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1539797646
-SHA256 (libdrm-2.4.96.tar.bz2) = 0d561acf7bb4cc59dc82415100e6c1a44860e8c380e00f9592923e3cd08db393
-SIZE (libdrm-2.4.96.tar.bz2) = 829518
+TIMESTAMP = 1559430556
+SHA256 (libdrm-2.4.98.tar.bz2) = 8be0edccaca3abde8b6bb1431b46354c7fab46e9b91cc6946ba65b51f56f1894
+SIZE (libdrm-2.4.98.tar.bz2) = 833295
diff --git a/graphics/libdrm/files/patch-meson.build b/graphics/libdrm/files/patch-meson.build
new file mode 100644
index 000000000000..bc23fec83296
--- /dev/null
+++ b/graphics/libdrm/files/patch-meson.build
@@ -0,0 +1,23 @@
+- sys/sysctl.h isn't self-sufficient
+- tests don't use Bash features
+
+--- meson.build.orig 2019-04-19 15:52:29 UTC
++++ meson.build
+@@ -181,7 +181,7 @@ endif
+ dep_m = cc.find_library('m', required : false)
+ foreach header : ['sys/sysctl.h', 'sys/select.h', 'alloca.h']
+ config.set('HAVE_' + header.underscorify().to_upper(),
+- cc.compiles('#include <@0@>'.format(header), name : '@0@ works'.format(header)))
++ cc.compiles('#include <sys/types.h>\n#include <@0@>'.format(header), name : '@0@ works'.format(header)))
+ endforeach
+ if cc.has_header_symbol('sys/sysmacros.h', 'major')
+ config.set10('MAJOR_IN_SYSMACROS', true)
+@@ -249,7 +249,7 @@ endif
+ with_man_pages = with_man_pages != 'false' and prog_xslt.found() and prog_sed.found()
+
+ # Used for tets
+-prog_bash = find_program('bash')
++prog_bash = find_program('sh')
+
+ config.set10('HAVE_VISIBILITY',
+ cc.compiles('''int foo_hidden(void) __attribute__((visibility(("hidden"))));''',
diff --git a/graphics/libdrm/files/patch-xf86drm.c b/graphics/libdrm/files/patch-xf86drm.c
index 8e5135bf901b..4d14f5e0be1d 100644
--- a/graphics/libdrm/files/patch-xf86drm.c
+++ b/graphics/libdrm/files/patch-xf86drm.c
@@ -10,9 +10,9 @@
#include <sys/stat.h>
#define stat_t struct stat
#include <sys/ioctl.h>
-@@ -59,6 +62,10 @@
- #endif
- #include <math.h>
+@@ -61,6 +64,10 @@
+
+ #define ARRAY_SIZE(a) (sizeof(a) / sizeof((a)[0]))
+#if defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__DragonFly__)
+#include <sys/pciio.h>
@@ -41,16 +41,7 @@
#endif
#ifdef __NetBSD__
-@@ -177,7 +174,7 @@ drm_public void drmFree(void *pt)
- }
-
- /**
-- * Call ioctl, restarting if it is interupted
-+ * Call ioctl, restarting if it is interrupted
- */
- drm_public int
- drmIoctl(int fd, unsigned long request, void *arg)
-@@ -220,6 +217,89 @@ drm_public drmHashEntry *drmGetEntry(int fd)
+@@ -222,6 +219,89 @@ drm_public drmHashEntry *drmGetEntry(int fd)
return entry;
}
@@ -140,16 +131,7 @@
/**
* Compare two busid strings
*
-@@ -287,7 +367,7 @@ static int drmMatchBusID(const char *id1, const char *
- *
- * \internal
- * Checks for failure. If failure was caused by signal call chown again.
-- * If any other failure happened then it will output error mesage using
-+ * If any other failure happened then it will output error message using
- * drmMsg() call.
- */
- #if !UDEV
-@@ -324,8 +404,8 @@ static int chown_check_return(const char *path, uid_t
+@@ -326,8 +406,8 @@ static int chown_check_return(const char *path, uid_t
static int drmOpenDevice(dev_t dev, int minor, int type)
{
stat_t st;
@@ -415,11 +397,11 @@
base = drmGetMinorBase(type);
if (base < 0)
return NULL;
-@@ -3011,7 +3048,7 @@ static int drmParseSubsystemType(int maj, int min)
- return DRM_BUS_VIRTIO;
+@@ -3032,7 +3069,7 @@ static int drmParseSubsystemType(int maj, int min)
+ }
return -EINVAL;
--#elif defined(__OpenBSD__)
+-#elif defined(__OpenBSD__) || defined(__DragonFly__)
+#elif defined(__OpenBSD__) || defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__DragonFly__)
return DRM_BUS_PCI;
#else