aboutsummaryrefslogtreecommitdiff
path: root/graphics/libepoxy/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-10-24 11:10:31 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-10-24 11:10:31 +0000
commit1bc98bdc34995efc87d70df8608f1c86f7484a9b (patch)
tree4c7c9aa621f07fbf133741bdbb05c40f4e2705f6 /graphics/libepoxy/Makefile
parentbe82c889dc92d94c305c12dbdddf745d5cecec9f (diff)
downloadports-1bc98bdc34995efc87d70df8608f1c86f7484a9b.tar.gz
ports-1bc98bdc34995efc87d70df8608f1c86f7484a9b.zip
Add libepoxy.
Epoxy is a library for handling OpenGL function pointer management for you.
Notes
Notes: svn path=/head/; revision=371433
Diffstat (limited to 'graphics/libepoxy/Makefile')
-rw-r--r--graphics/libepoxy/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/graphics/libepoxy/Makefile b/graphics/libepoxy/Makefile
new file mode 100644
index 000000000000..9527673f32bb
--- /dev/null
+++ b/graphics/libepoxy/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= libepoxy
+PORTVERSION= 1.2
+CATEGORIES= graphics
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= library that handles OpenGL function pointer managerment for you
+
+LICENSE= MIT
+
+USE_GITHUB= YES
+GH_ACCOUNT= anholt
+GH_PROJECT= ${PORTNAME}
+GH_COMMIT= 7422de5
+GH_TAGNAME= v1.2
+
+USES= autoreconf libtool pathfix pkgconfig python:3,build
+USE_XORG= xorg-macros
+USE_GL= egl glesv2
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+PATHFIX_MAKEFILEIN= Makefile.am
+
+# GLX
+USE_XORG+= x11
+
+.include <bsd.port.mk>