aboutsummaryrefslogtreecommitdiff
path: root/graphics/libgeotiff/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-12-09 06:38:28 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-12-09 06:38:28 +0000
commit278852703fd3f5b8e61957f9aa47d041759c3892 (patch)
tree4d275e403c45c0675063e0fecd8dd2abb118190c /graphics/libgeotiff/Makefile
parent687fa2a3b4be8a94a81b4fa98996b1ef9d3aa4d8 (diff)
downloadports-278852703fd3f5b8e61957f9aa47d041759c3892.tar.gz
ports-278852703fd3f5b8e61957f9aa47d041759c3892.zip
Add libgeotiff, a library for reading and writing GeoTIFF tags.
Notes
Notes: svn path=/head/; revision=150704
Diffstat (limited to 'graphics/libgeotiff/Makefile')
-rw-r--r--graphics/libgeotiff/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/graphics/libgeotiff/Makefile b/graphics/libgeotiff/Makefile
new file mode 100644
index 000000000000..16f512883635
--- /dev/null
+++ b/graphics/libgeotiff/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libgeotiff
+# Date created: 9 December 2005
+# Whom: Sam Lawrance
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgeotiff
+PORTVERSION= 1.2.2
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.remotesensing.org/pub/geotiff/libgeotiff/ \
+ http://dl1.maptools.org/dl/geotiff/libgeotiff/
+
+MAINTAINER= lawrance@FreeBSD.org
+COMMENT= Library for reading and writing GeoTIFF information tags
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ proj.5:${PORTSDIR}/graphics/proj \
+ tiff.4:${PORTSDIR}/graphics/tiff
+
+CONFIGURE_ARGS= --with-jpeg=${LOCALBASE} \
+ --with-proj=${LOCALBASE} \
+ --with-libtiff=${LOCALBASE}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>