aboutsummaryrefslogtreecommitdiff
path: root/graphics/libgfx
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /graphics/libgfx
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
- update png to 1.5.10
Notes
Notes: svn path=/head/; revision=297915
Diffstat (limited to 'graphics/libgfx')
-rw-r--r--graphics/libgfx/Makefile5
-rw-r--r--graphics/libgfx/files/patch-png.cxx20
2 files changed, 23 insertions, 2 deletions
diff --git a/graphics/libgfx/Makefile b/graphics/libgfx/Makefile
index 4b6cf1b7c854..8df8ed5d1218 100644
--- a/graphics/libgfx/Makefile
+++ b/graphics/libgfx/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libgfx
DISTVERSION= 1.1.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
MASTER_SITES= http://mgarland.org/files/dist/
@@ -18,7 +18,7 @@ LICENSE= MIT
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
tiff.4:${PORTSDIR}/graphics/tiff \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
gzstream.0:${PORTSDIR}/devel/gzstream \
jpeg.11:${PORTSDIR}/graphics/jpeg
@@ -26,6 +26,7 @@ BUILD_WRKSRC= ${WRKSRC}/src
USE_GL= glu
USE_GMAKE= yes
+USE_XORG= x11 xext xft xinerama
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gzstream --with-libtiff-lzw --with-x
ALL_TARGET= ${PORTNAME}.so
diff --git a/graphics/libgfx/files/patch-png.cxx b/graphics/libgfx/files/patch-png.cxx
new file mode 100644
index 000000000000..80b3f88d92c0
--- /dev/null
+++ b/graphics/libgfx/files/patch-png.cxx
@@ -0,0 +1,20 @@
+--- src/raster-png.cxx.orig 2004-09-27 06:45:31.000000000 +0200
++++ src/raster-png.cxx 2012-05-04 12:59:52.000000000 +0200
+@@ -42,7 +42,7 @@
+ // Because we didn't set up any error handlers, we need to be
+ // prepared to handle longjmps out of the library on error
+ // conditions.
+- if( setjmp(png_ptr->jmpbuf) )
++ if( setjmp(png_jmpbuf(png_ptr)) )
+ {
+ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+ fclose(fp);
+@@ -132,7 +132,7 @@
+ return false;
+ }
+
+- if( setjmp(png_ptr->jmpbuf) )
++ if( setjmp(png_jmpbuf(png_ptr)) )
+ {
+ fclose(fp);
+ png_destroy_write_struct(&png_ptr, (png_infopp)NULL);