aboutsummaryrefslogtreecommitdiff
path: root/graphics/libgltext
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /graphics/libgltext
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'graphics/libgltext')
-rw-r--r--graphics/libgltext/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/graphics/libgltext/Makefile b/graphics/libgltext/Makefile
index 2ebf8d9bb399..a1dd3ad7c148 100644
--- a/graphics/libgltext/Makefile
+++ b/graphics/libgltext/Makefile
@@ -9,8 +9,7 @@ PORTNAME= libgltext
PORTVERSION= 0.3.1
PORTREVISION= 2
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= gltext
+MASTER_SITES= SF/gltext
DISTNAME= gltext-${PORTVERSION}
MAINTAINER= acm@FreeBSD.org
@@ -19,11 +18,11 @@ COMMENT= Portable font rendering library for C++
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
USE_AUTOTOOLS= libtool:15
-USE_GL= yes
+USE_GL= glu
USE_GMAKE= yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
-CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
+USE_LCONFIG= yes
+CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}"
@@ -32,7 +31,7 @@ OPTIONS= EXAMPLES "Compile examples, need libglut" off
.include <bsd.port.pre.mk>
.if defined(WITH_EXAMPLES)
-LIB_DEPENDS+= glut.4:${PORTSDIR}/graphics/libglut
+USE_GL= glut
FLAG_EXAMPLES= true
PLIST_SUB+= EXAMPLES=""
.else