aboutsummaryrefslogtreecommitdiff
path: root/graphics/libgltext
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-07-19 11:04:13 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-07-19 11:04:13 +0000
commitf899c758a653ca8ff2f8a63aafcb2519a0b524ed (patch)
treebe6eebf3e77ddf9fcf383081091d8b8b336dd71c /graphics/libgltext
parent74d26774f830684ae21247061aa4bd7dabbe6527 (diff)
downloadports-f899c758a653ca8ff2f8a63aafcb2519a0b524ed.tar.gz
ports-f899c758a653ca8ff2f8a63aafcb2519a0b524ed.zip
When there is a do-install target, do not use a post-install target, do
everything at once. Sometime, rename post-install into a options helper target. I did not fix ports that were such a mess that I could not figure out what they really wanted to do. I also did not change ports that had some version of an auto-plist code in post-install, for the same reason. With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=418767
Diffstat (limited to 'graphics/libgltext')
-rw-r--r--graphics/libgltext/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/graphics/libgltext/Makefile b/graphics/libgltext/Makefile
index 73856300d059..08fb5bb5154d 100644
--- a/graphics/libgltext/Makefile
+++ b/graphics/libgltext/Makefile
@@ -27,7 +27,6 @@ EXAMPLES_DESC= Compile examples, need libglut
.if ${PORT_OPTIONS:MEXAMPLES}
USE_GL+= glut
USE_XORG= xmu
-FLAG_EXAMPLES= true
PLIST_SUB+= EXAMPLES=""
.else
PLIST_SUB+= EXAMPLES="@comment "
@@ -45,13 +44,13 @@ do-install:
@cd ${STAGEDIR}${PREFIX}/lib && \
${LN} -s ${PORTNAME}.so.0 ${PORTNAME}.so
-post-install:
+post-install-DOCS-on:
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/doc/tutorial.txt ${STAGEDIR}${DOCSDIR}
.endif
-.if defined(FLAG_EXAMPLES)
+post-install-EXAMPLES-on:
.for DIRE in alpha fps simple sizes
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/${DIRE}
@cd ${WRKSRC}/examples && \
@@ -60,6 +59,5 @@ post-install:
@${ECHO_MSG} ""
@${ECHO_MSG} " Examples source and binary on ${STAGEDIR}${EXAMPLESDIR}"
@${ECHO_MSG} ""
-.endif
.include <bsd.port.mk>