aboutsummaryrefslogtreecommitdiff
path: root/graphics/libglvnd/Makefile
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2022-06-03 13:18:05 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2022-06-03 13:41:40 +0000
commit239ba7a240fd6fd611ac6a72986de6b26ab5da64 (patch)
treedb3a7ac033d04b2686a88746d4112ea0380c35c1 /graphics/libglvnd/Makefile
parent9e6e9f1c024eb6d1c10d8c7b134d953cf4f75908 (diff)
downloadports-239ba7a240fd6fd611ac6a72986de6b26ab5da64.tar.gz
ports-239ba7a240fd6fd611ac6a72986de6b26ab5da64.zip
graphics/libglvnd: fix on armv6/armv7
The .thumb_func directive does not switch to thumb mode in clang's integrated assembler. This causes the code to be miscompiled in that it is generated as ARM code but the symbols are tagged as thumb. The resulting library is unusable. Every call into it crashes. Fix this issue by applying an upstream patch set to have the entry stubs be in ARM mode instead of Thumb mode. See also: https://gitlab.freedesktop.org/glvnd/libglvnd/-/merge_requests/267 See also: https://gitlab.freedesktop.org/glvnd/libglvnd/-/issues/232 PR: 263845
Diffstat (limited to 'graphics/libglvnd/Makefile')
-rw-r--r--graphics/libglvnd/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/graphics/libglvnd/Makefile b/graphics/libglvnd/Makefile
index 5315970b50a8..da53c5bd2dbe 100644
--- a/graphics/libglvnd/Makefile
+++ b/graphics/libglvnd/Makefile
@@ -1,8 +1,13 @@
PORTNAME= libglvnd
DISTVERSION= 1.4.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
+PATCH_SITES= https://gitlab.freedesktop.org/glvnd/libglvnd/-/commit/
+PATCHFILES= 28da9963e52ee2d2e1501351eb26b77cec89f886.diff:-p1 \
+ d853cf56f81afff725946eec1144560a121da5af.diff:-p1 \
+ b90f235998e199d810ef61c0a8dc103d297962cb.diff:-p1
+
MAINTAINER= x11@FreeBSD.org
COMMENT= GL Vendor-Neutral Dispatch library