aboutsummaryrefslogtreecommitdiff
path: root/graphics/libimg
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2016-06-14 19:27:30 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2016-06-14 19:27:30 +0000
commitd1ba86f97cde5f57435f919310d90e06dbb4c9e8 (patch)
tree61927c9452640cd95d55a9c34ae3cfe59db0c673 /graphics/libimg
parentb222f710245ef22c73f3aa42d97fcaf0c830fc5a (diff)
downloadports-d1ba86f97cde5f57435f919310d90e06dbb4c9e8.tar.gz
ports-d1ba86f97cde5f57435f919310d90e06dbb4c9e8.zip
Don't remove X11 linkage; this breaks the upcoming LinuxCNC port.
PR: 210212 Approved by: maintainer (earlier version)
Notes
Notes: svn path=/head/; revision=416906
Diffstat (limited to 'graphics/libimg')
-rw-r--r--graphics/libimg/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/graphics/libimg/Makefile b/graphics/libimg/Makefile
index 81e5e3cf7146..a62d2a040628 100644
--- a/graphics/libimg/Makefile
+++ b/graphics/libimg/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libimg
PORTVERSION= 1.4.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= graphics tk
MASTER_SITES= SF/tkimg/tkimg/${PORTVERSION:R}
DISTNAME= tkimg${PORTVERSION}
@@ -12,7 +12,9 @@ MAINTAINER= mi@aldan.algebra.com
COMMENT= Library of image format handlers for Tk4.1 and later
BUILD_DEPENDS= dtplite:devel/tcllib
-LIB_DEPENDS= libpng.so:graphics/png \
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libpng.so:graphics/png \
libtiff.so:graphics/tiff
PLIST_SUB+= SHLIB_NAME="${SHLIB_NAME}" \
@@ -20,6 +22,7 @@ PLIST_SUB+= SHLIB_NAME="${SHLIB_NAME}" \
WRKSRC= ${WRKDIR}/tkimg${PORTVERSION:R}
USES= autoreconf jpeg tk:tea tar:bzip2
+USE_XORG= x11 xext xft xrender xscrnsaver
# We don't need the bundled libraries:
EXTRACT_AFTER_ARGS= --exclude '*/libz/*' --exclude zlib \
@@ -37,9 +40,6 @@ post-patch:
.endfor
post-configure:
- # Do not link with X11 -- none of tkimg code uses X directly
- ${REINPLACE_CMD} -E -e 's,-L[^[:space:]]+[[:space:]]+-lX[^[:space:]]*,,g' \
- ${WRKSRC}/*/Makefile
.for l in jpeg png tiff
# Link with -l$l
${REINPLACE_CMD} -E \