aboutsummaryrefslogtreecommitdiff
path: root/graphics/libjxl
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-04-13 00:51:19 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-04-13 00:51:19 +0000
commitc6132c766da2e4cf17cce9a001331560f6d330ab (patch)
tree4f844d5b4f29083a6e2f1e32f65d54f15460da7c /graphics/libjxl
parente49f4878c2f777c73a720f5bfcf61ba97762dd20 (diff)
downloadports-c6132c766da2e4cf17cce9a001331560f6d330ab.tar.gz
ports-c6132c766da2e4cf17cce9a001331560f6d330ab.zip
graphics/libjxl: fix build on powerpc / powerpc64
/usr/local/include/hwy/ops/ppc_vsx-inl.h:2719:34: error: use of 'long long' with '__vector' requires VSX support (available on POWER7 or later) to be enabled
Diffstat (limited to 'graphics/libjxl')
-rw-r--r--graphics/libjxl/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/graphics/libjxl/Makefile b/graphics/libjxl/Makefile
index f1d4aa1c7b41..cdbe4d4e0cd1 100644
--- a/graphics/libjxl/Makefile
+++ b/graphics/libjxl/Makefile
@@ -22,6 +22,8 @@ GH_TUPLE= jbeich:skcms:b25b07b:skcms/third_party/skcms \
libjxl:testdata:d6168ff:testdata/testdata \
webmproject:sjpeg:868ab55:sjpeg/third_party/sjpeg \
${NULL}
+CFLAGS_powerpc64= -DHWY_DISABLE_PPC8_CRYPTO
+CFLAGS_powerpc= -DHWY_DISABLE_PPC8_CRYPTO
CMAKE_ON= JPEGXL_ENABLE_PLUGINS
CMAKE_OFF= ${BENCHMARK FUZZERS TCMALLOC:L:S/^/JPEGXL_ENABLE_/}
CMAKE_OFF+= ${OpenGL GLUT:L:S/^/CMAKE_DISABLE_FIND_PACKAGE_/} # sjpeg