aboutsummaryrefslogtreecommitdiff
path: root/graphics/libosmesa/Makefile
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-06-30 14:56:12 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-06-30 14:56:12 +0000
commit6db0d126a41154e6f341a90c0d7edfd30c4ec862 (patch)
tree5dbf095631f33d3681e0665b4bece07319143b54 /graphics/libosmesa/Makefile
parentb66098f32b1c8a6bf31deee56334a631a3048f5d (diff)
downloadports-6db0d126a41154e6f341a90c0d7edfd30c4ec862.tar.gz
ports-6db0d126a41154e6f341a90c0d7edfd30c4ec862.zip
Switch mesa and related ports to llvm80
Switch mesa over to use llvm80 instead of llvm60. Make it use the global LLVM_DEFAULT instead of deciding for ourself which llvm version to use. [1] Fix build of lang/beginet [1] Add patch from upstream to fix build of devel/libclc. The patch is taken from the git mirror of devel/libclc rather than the SVN repo, for convenience. Add a patch from mesa upstream preventing certain error messages when using amdgpu [2] Add a notice to bsd.default-versions.mk asking that the graphics team be informed before the llvm version is changed. Enable llvm and gallium on MIPS. As far as I can tell, this used to be the default before this change. Bump portrevisions since dependencies changed. PR: 230789 [1], [2] Submitted by: jbeich [1], tobik [2] Obtained from: FreeBSD Graphics Team development repo https://github.com/FreeBSDDesktop/freebsd-ports/commits/feature/mesa-llvm80 Sponsored by: B3 Init (zeising)
Notes
Notes: svn path=/head/; revision=505425
Diffstat (limited to 'graphics/libosmesa/Makefile')
-rw-r--r--graphics/libosmesa/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/graphics/libosmesa/Makefile b/graphics/libosmesa/Makefile
index 81f262092ea5..71acb8d910e4 100644
--- a/graphics/libosmesa/Makefile
+++ b/graphics/libosmesa/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libosmesa
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
COMMENT= Off-Screen Mesa implementation of the OpenGL API
@@ -18,7 +18,7 @@ CONFIGURE_ARGS+= --disable-dri --disable-egl --disable-gbm \
MESA_BUILD_WRKSRC= src/util src/compiler src/mapi src/mesa
LDFLAGS_i386= -Wl,-znotext
-.if "${MESA_LLVM_VER}" != ""
+.if ${ARCH} == aarch64 || ${ARCH} == amd64 || ${ARCH:Marm*} || ${ARCH} == i386 || ${ARCH:Mmips*} || ${ARCH:Mpowerpc*}
CONFIGURE_ARGS+= --enable-osmesa-gallium
MESA_BUILD_WRKSRC+= src/gallium
MESA_INSTALL_WRKSRC= src/gallium/state_trackers/osmesa src/gallium/targets/osmesa