aboutsummaryrefslogtreecommitdiff
path: root/graphics/libprojectm/Makefile
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2013-12-30 14:30:07 +0000
committerChris Rees <crees@FreeBSD.org>2013-12-30 14:30:07 +0000
commit78a89fb7bef9683f807252e84bebd76af01de7bd (patch)
treeef15acda5b935025287ea394893e0a578ccdf97d /graphics/libprojectm/Makefile
parent0e10847841335c4eeaca6fc53d9b518182c200eb (diff)
downloadports-78a89fb7bef9683f807252e84bebd76af01de7bd.tar.gz
ports-78a89fb7bef9683f807252e84bebd76af01de7bd.zip
Final ports of mine staged
Notes
Notes: svn path=/head/; revision=338117
Diffstat (limited to 'graphics/libprojectm/Makefile')
-rw-r--r--graphics/libprojectm/Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/graphics/libprojectm/Makefile b/graphics/libprojectm/Makefile
index 51a5c4d8945f..5a8281c6327e 100644
--- a/graphics/libprojectm/Makefile
+++ b/graphics/libprojectm/Makefile
@@ -1,4 +1,3 @@
-# Created by: utisoft@gmail.com
# $FreeBSD$
PORTNAME= libprojectM
@@ -13,15 +12,14 @@ COMMENT= An awesome music visualiser
LICENSE= LGPL21
-LIB_DEPENDS= ftgl:${PORTSDIR}/graphics/ftgl \
- GLEW:${PORTSDIR}/graphics/glew \
- freetype:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= libftgl.so:${PORTSDIR}/graphics/ftgl \
+ libGLEW.so:${PORTSDIR}/graphics/glew \
+ libfreetype.so:${PORTSDIR}/print/freetype2
USES= cmake
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
USE_LDCONFIG= yes
-NO_STAGE= yes
post-patch:
# Install config.inp.sample instead of overwriting user's file.
# Needs to be specific enough not to rename config.inp.in too!
@@ -35,10 +33,4 @@ post-patch:
@${REINPLACE_CMD} -e 's#^\(libdir=\).*#\1${PREFIX}/lib#' \
${WRKSRC}/${PORTNAME}.pc.in
-post-install:
- @if [ ! -f ${PREFIX}/share/projectM/config.inp ]; then \
- ${CP} -p ${PREFIX}/share/projectM/config.inp.sample \
- ${PREFIX}/share/projectM/config.inp ; \
- fi
-
.include <bsd.port.mk>