aboutsummaryrefslogtreecommitdiff
path: root/graphics/libqglviewer
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-06-08 06:16:41 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-06-08 06:16:41 +0000
commit5d8de5067bbc3723262214ee75b85fb4fcca453e (patch)
tree1fec5ca833d12ba9834168e4a77dd2fe00a631a5 /graphics/libqglviewer
parent907e8e24ba60bf007c29b82f30c4fe5f04a5e7e2 (diff)
downloadports-5d8de5067bbc3723262214ee75b85fb4fcca453e.tar.gz
ports-5d8de5067bbc3723262214ee75b85fb4fcca453e.zip
add libqglviewer 1.3.7
A C++ library helps development of 3D applications
Notes
Notes: svn path=/head/; revision=111054
Diffstat (limited to 'graphics/libqglviewer')
-rw-r--r--graphics/libqglviewer/Makefile41
-rw-r--r--graphics/libqglviewer/distinfo2
-rw-r--r--graphics/libqglviewer/pkg-descr15
-rw-r--r--graphics/libqglviewer/pkg-plist5
4 files changed, 63 insertions, 0 deletions
diff --git a/graphics/libqglviewer/Makefile b/graphics/libqglviewer/Makefile
new file mode 100644
index 000000000000..be9e2e939b9d
--- /dev/null
+++ b/graphics/libqglviewer/Makefile
@@ -0,0 +1,41 @@
+# ex:ts=8
+# Ports collection makefile for: libQGLViewer
+# Date created: Jun 8, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libqglviewer
+PORTVERSION= 1.3.7
+CATEGORIES= graphics
+MASTER_SITES= http://artis.imag.fr/Members/Gilles.Debunne/QGLViewer/src/
+DISTNAME= libQGLViewer-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A C++ library helps development of 3D applications
+
+USE_BZIP2= yes
+USE_QT_VER= 3
+MAKE_ENV= QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++ \
+ QTDIR=${X11BASE}
+QMAKE= ${LOCALBASE}/bin/qmake
+INSTALLS_SHLIB= yes
+
+DOCSDIR= ${PREFIX}/share/doc/QGLViewer
+PORTDOCS= *
+
+do-build:
+ @(cd ${WRKSRC}/QGLViewer && ${SETENV} ${MAKE_ENV} ${QMAKE} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE})
+
+do-install:
+ @(cd ${WRKSRC}/QGLViewer && ${SETENV} ${MAKE_ENV} ${MAKE} install)
+
+post-install:
+ @${FIND} ${PREFIX}/include/QGLViewer ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/include/QGLViewer -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/graphics/libqglviewer/distinfo b/graphics/libqglviewer/distinfo
new file mode 100644
index 000000000000..33faddcf7b14
--- /dev/null
+++ b/graphics/libqglviewer/distinfo
@@ -0,0 +1,2 @@
+MD5 (libQGLViewer-1.3.7.tar.bz2) = a4f803b820023a0ef80ff9db189d6bda
+SIZE (libQGLViewer-1.3.7.tar.bz2) = 672584
diff --git a/graphics/libqglviewer/pkg-descr b/graphics/libqglviewer/pkg-descr
new file mode 100644
index 000000000000..ee84c0eec5be
--- /dev/null
+++ b/graphics/libqglviewer/pkg-descr
@@ -0,0 +1,15 @@
+libQGLViewer is a GPL-free software C++ library which lets you quickly start
+the development of a new 3D application. It is designed for 3D developers, who
+can display and move around a 3D scene by simply providing the openGL orders
+that define their 3D geometry. The viewer is designed to be as general as
+possible and is not designed for a specific 3D application. It provides some
+useful classical functionalities such as a camera trackball, screenshot saving,
+mouse manipulated frames, stereo display, keyFrames and more. It hence has a
+strong pedagogical interest and is well suited for openGL assignements.
+
+libQGLViewer is not a 3D viewer that can be used directly to view 3D scenes in
+various formats (well, there is a 3dsViewer example, but it is just a proof of
+concept). It is more likely to be the starting point for the coding of such a
+viewer.
+
+WWW: http://artis.imag.fr/Members/Gilles.Debunne/QGLViewer/
diff --git a/graphics/libqglviewer/pkg-plist b/graphics/libqglviewer/pkg-plist
new file mode 100644
index 000000000000..35ac1bd2ecf5
--- /dev/null
+++ b/graphics/libqglviewer/pkg-plist
@@ -0,0 +1,5 @@
+lib/libQGLViewer.prl
+lib/libQGLViewer.so
+lib/libQGLViewer.so.1
+lib/libQGLViewer.so.1.3
+lib/libQGLViewer.so.1.3.7