aboutsummaryrefslogtreecommitdiff
path: root/graphics/libvisual04/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2004-11-30 21:52:52 +0000
committerKoop Mast <kwm@FreeBSD.org>2004-11-30 21:52:52 +0000
commit3e1ab817c9290ece1e93b50bb4aa9fb236c39406 (patch)
treee9b3edd857547cd658c12fa28da24ce33c71371a /graphics/libvisual04/Makefile
parentf8eed8659107bb01660d6f6c98221a50a8a4c333 (diff)
downloadports-3e1ab817c9290ece1e93b50bb4aa9fb236c39406.tar.gz
ports-3e1ab817c9290ece1e93b50bb4aa9fb236c39406.zip
Add libvisual. Libvisual is an abstraction library that comes between
applications and audio visualisation plugins. Approved by: pav (mentor)
Notes
Notes: svn path=/head/; revision=122844
Diffstat (limited to 'graphics/libvisual04/Makefile')
-rw-r--r--graphics/libvisual04/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/graphics/libvisual04/Makefile b/graphics/libvisual04/Makefile
new file mode 100644
index 000000000000..3c2a22b1790d
--- /dev/null
+++ b/graphics/libvisual04/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libvisual
+# Date created: 23 oktober 2004
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+# WARNING: when updating this port check if the ports that use libvisual
+# can work with it. Backwards compatiblity is known to be broken in the past.
+
+PORTNAME= libvisual
+PORTVERSION= 0.1.7
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Abstraction library that sits between apps and visual plugin
+
+USE_XLIBS= yes
+USE_GNOME= gnomehack pkgconfig
+USE_REINPLACE= yes
+USE_LIBTOOL_VER=15
+CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-Wno-unused-variable||g' \
+ -e 's|-O3|${CFLAGS}|g' \
+ ${WRKSRC}/libvisual/Makefile.in
+
+.include <bsd.port.mk>