aboutsummaryrefslogtreecommitdiff
path: root/graphics/linux-c6-sdl_image
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-22 10:40:00 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-22 10:40:00 +0000
commit05317facbedf1ed4566b56f4e09e6e4a49fc3f38 (patch)
treef0614b64c20d137667eadfbdc5663150937dc6c3 /graphics/linux-c6-sdl_image
parentf287925fdbb7ff7ab55ee8aaa28cf756fe49a296 (diff)
downloadports-05317facbedf1ed4566b56f4e09e6e4a49fc3f38.tar.gz
ports-05317facbedf1ed4566b56f4e09e6e4a49fc3f38.zip
Update CentOS base to 6.5, add userland ports
The Fedora 10 infrastructure ports have been in use since June 2009 and, while having served a great deed, have become unsupported upstream and hence affected by unfixed security vulnerabilities. In addition to that, many recent Linux binaries need newer libc / stdlibc++ versions. This commit adds the linux-c6- userland as drop-in replacement for the -f10 infrastructure, as well as upgrading the linux_base-c6 port to CentOS 6.5. If you want to switch to linux-c6 ports, please define at /etc/make.conf: OVERRIDE_LINUX_BASE_PORT=c6 OVERRIDE_LINUX_NONBASE_PORTS=c6 Additionally, please add the following line to /etc/sysctl.conf: compat.linux.osrelease=2.6.18 Upgrading procedures are shown in /usr/ports/UPDATING. This work has been inspired by Artyom Mirgorodskiy's post to emulation@ in November 2013, using and extending mav@'s work. It has been tested extensively and most reported issues were already fixed. Please report any additional bug or "features" to the emulation mailing list. Many thanks to: mav@, rene@, allanjude@, netchild@, antoine@, everyone who's filed Issues and Pull requests on GitHub, PR: 186820 Differential Revision: https://reviews.freebsd.org/D793 Reviewed by: allanjude, antoine, bapt, rene Approved by: portmgr (antoine, bapt) Approved by: koobs (mentor) Sponsored by: Perceivon Hosting Inc.
Notes
Notes: svn path=/head/; revision=368845
Diffstat (limited to 'graphics/linux-c6-sdl_image')
-rw-r--r--graphics/linux-c6-sdl_image/Makefile32
-rw-r--r--graphics/linux-c6-sdl_image/distinfo.i3864
-rw-r--r--graphics/linux-c6-sdl_image/distinfo.i6864
3 files changed, 40 insertions, 0 deletions
diff --git a/graphics/linux-c6-sdl_image/Makefile b/graphics/linux-c6-sdl_image/Makefile
new file mode 100644
index 000000000000..49126a397277
--- /dev/null
+++ b/graphics/linux-c6-sdl_image/Makefile
@@ -0,0 +1,32 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= sdl_image
+PORTVERSION= 1.2.10
+CATEGORIES= graphics linux
+MASTER_SITES= EPEL
+DISTNAME= SDL_image-${PORTVERSION}-${RPMVERSION}
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Simple library to load images as SDL interfaces (Linux CentOS ${LINUX_DIST_VER})
+
+CONFLICTS= linux-sdl_image-[0-9]* linux-f8-sdl_image-[0-9]*
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX= c6
+USE_LINUX_RPM= yes
+USE_LINUX_APPS= jpeg png sdl12 tiff
+LINUX_NAME= SDL_image
+
+RPMVERSION= 1.el6
+BRANDELF_FILES= usr/bin/showimage
+USE_LDCONFIG= yes
+
+DOCSDIR= ${PREFIX}/usr/share/doc/${LINUX_NAME}-${PORTVERSION}
+PORTDOCS= CHANGES COPYING README
+
+PLIST_FILES= usr/bin/showimage usr/lib/libSDL_image-1.2.so.0 \
+ usr/lib/libSDL_image-1.2.so.0.8.2
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
+.include <bsd.port.mk>
diff --git a/graphics/linux-c6-sdl_image/distinfo.i386 b/graphics/linux-c6-sdl_image/distinfo.i386
new file mode 100644
index 000000000000..a1563343a877
--- /dev/null
+++ b/graphics/linux-c6-sdl_image/distinfo.i386
@@ -0,0 +1,4 @@
+SHA256 (rpm/i386/fedora/10/SDL_image-1.2.6-6.fc9.i386.rpm) = 8da4e1aebeefcd68b6d5684fac9cf361e56818691c8e73c39d5e1bcf090971de
+SIZE (rpm/i386/fedora/10/SDL_image-1.2.6-6.fc9.i386.rpm) = 45268
+SHA256 (rpm/i386/fedora/10/SDL_image-1.2.6-6.fc9.src.rpm) = dedfd510d6b8b314db97a8e0406e0481fa564f508dff177c65ae6fa3335a848a
+SIZE (rpm/i386/fedora/10/SDL_image-1.2.6-6.fc9.src.rpm) = 1317840
diff --git a/graphics/linux-c6-sdl_image/distinfo.i686 b/graphics/linux-c6-sdl_image/distinfo.i686
new file mode 100644
index 000000000000..e26eb1b18080
--- /dev/null
+++ b/graphics/linux-c6-sdl_image/distinfo.i686
@@ -0,0 +1,4 @@
+SHA256 (rpm/i686/centos/6.5/SDL_image-1.2.10-1.el6.i686.rpm) = 81233adfe8f95e2aa362a7d7ab568ad2ad32624a37ced1dc37d64bef9ba9109b
+SIZE (rpm/i686/centos/6.5/SDL_image-1.2.10-1.el6.i686.rpm) = 45732
+SHA256 (rpm/i686/centos/6.5/SDL_image-1.2.10-1.el6.src.rpm) = 39c291625747a8ba168465af16ec0c5bc1e5746ffb4e5cfe5efd597e8c2b1c52
+SIZE (rpm/i686/centos/6.5/SDL_image-1.2.10-1.el6.src.rpm) = 1342983