aboutsummaryrefslogtreecommitdiff
path: root/graphics/linux-c6-tiff
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-22 10:40:00 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-22 10:40:00 +0000
commit05317facbedf1ed4566b56f4e09e6e4a49fc3f38 (patch)
treef0614b64c20d137667eadfbdc5663150937dc6c3 /graphics/linux-c6-tiff
parentf287925fdbb7ff7ab55ee8aaa28cf756fe49a296 (diff)
downloadports-05317facbedf1ed4566b56f4e09e6e4a49fc3f38.tar.gz
ports-05317facbedf1ed4566b56f4e09e6e4a49fc3f38.zip
Update CentOS base to 6.5, add userland ports
The Fedora 10 infrastructure ports have been in use since June 2009 and, while having served a great deed, have become unsupported upstream and hence affected by unfixed security vulnerabilities. In addition to that, many recent Linux binaries need newer libc / stdlibc++ versions. This commit adds the linux-c6- userland as drop-in replacement for the -f10 infrastructure, as well as upgrading the linux_base-c6 port to CentOS 6.5. If you want to switch to linux-c6 ports, please define at /etc/make.conf: OVERRIDE_LINUX_BASE_PORT=c6 OVERRIDE_LINUX_NONBASE_PORTS=c6 Additionally, please add the following line to /etc/sysctl.conf: compat.linux.osrelease=2.6.18 Upgrading procedures are shown in /usr/ports/UPDATING. This work has been inspired by Artyom Mirgorodskiy's post to emulation@ in November 2013, using and extending mav@'s work. It has been tested extensively and most reported issues were already fixed. Please report any additional bug or "features" to the emulation mailing list. Many thanks to: mav@, rene@, allanjude@, netchild@, antoine@, everyone who's filed Issues and Pull requests on GitHub, PR: 186820 Differential Revision: https://reviews.freebsd.org/D793 Reviewed by: allanjude, antoine, bapt, rene Approved by: portmgr (antoine, bapt) Approved by: koobs (mentor) Sponsored by: Perceivon Hosting Inc.
Notes
Notes: svn path=/head/; revision=368845
Diffstat (limited to 'graphics/linux-c6-tiff')
-rw-r--r--graphics/linux-c6-tiff/Makefile25
-rw-r--r--graphics/linux-c6-tiff/distinfo.i6864
-rw-r--r--graphics/linux-c6-tiff/pkg-plist57
3 files changed, 86 insertions, 0 deletions
diff --git a/graphics/linux-c6-tiff/Makefile b/graphics/linux-c6-tiff/Makefile
new file mode 100644
index 000000000000..7587b73076b5
--- /dev/null
+++ b/graphics/linux-c6-tiff/Makefile
@@ -0,0 +1,25 @@
+# Created by: Artyom Mirgorodskiy <artyom.mirgorodsky@gmail.com>
+# $FreeBSD$
+
+PORTNAME= tiff
+PORTVERSION= 3.9.4
+CATEGORIES= graphics linux
+DISTNAME= lib${PORTNAME}-${PORTVERSION}-${RPMVERSION}
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= TIFF library (Linux CentOS ${LINUX_DIST_VER})
+
+CONFLICTS= linux-tiff-[0-9]* linux-f10-tiff-[0-9]*
+
+ONLY_FOR_ARCHS= amd64 i386
+USE_LINUX= c6
+USE_LINUX_APPS= jpeg
+USE_LINUX_RPM= yes
+RPMVERSION= 9.el6_3
+LINUX_NAME= lib${PORTNAME}
+BRANDELF_DIRS= usr/bin
+USE_LDCONFIG= yes
+
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
+.include <bsd.port.mk>
diff --git a/graphics/linux-c6-tiff/distinfo.i686 b/graphics/linux-c6-tiff/distinfo.i686
new file mode 100644
index 000000000000..193805308bd9
--- /dev/null
+++ b/graphics/linux-c6-tiff/distinfo.i686
@@ -0,0 +1,4 @@
+SHA256 (rpm/i686/centos/6.5/libtiff-3.9.4-9.el6_3.i686.rpm) = 0b3f107d56ce0573d470ff613f3fe15419493fe940021ff2aa57a61fd755af21
+SIZE (rpm/i686/centos/6.5/libtiff-3.9.4-9.el6_3.i686.rpm) = 346840
+SHA256 (rpm/i686/centos/6.5/libtiff-3.9.4-9.el6_3.src.rpm) = 73bd79bac805f90a43cfe048bf71eb28c9e10758a47d97b0a8ef478e210dbbd5
+SIZE (rpm/i686/centos/6.5/libtiff-3.9.4-9.el6_3.src.rpm) = 1472377
diff --git a/graphics/linux-c6-tiff/pkg-plist b/graphics/linux-c6-tiff/pkg-plist
new file mode 100644
index 000000000000..9f1776548027
--- /dev/null
+++ b/graphics/linux-c6-tiff/pkg-plist
@@ -0,0 +1,57 @@
+@comment file listing
+usr/bin/bmp2tiff
+usr/bin/fax2ps
+usr/bin/fax2tiff
+usr/bin/gif2tiff
+usr/bin/pal2rgb
+usr/bin/ppm2tiff
+usr/bin/ras2tiff
+usr/bin/raw2tiff
+usr/bin/rgb2ycbcr
+usr/bin/thumbnail
+usr/bin/tiff2bw
+usr/bin/tiff2pdf
+usr/bin/tiff2ps
+usr/bin/tiff2rgba
+usr/bin/tiffcmp
+usr/bin/tiffcp
+usr/bin/tiffcrop
+usr/bin/tiffdither
+usr/bin/tiffdump
+usr/bin/tiffinfo
+usr/bin/tiffmedian
+usr/bin/tiffset
+usr/bin/tiffsplit
+usr/lib/libtiff.so.3
+usr/lib/libtiff.so.3.9.4
+usr/lib/libtiffxx.so.3
+usr/lib/libtiffxx.so.3.9.4
+usr/share/doc/libtiff-3.9.4/COPYRIGHT
+usr/share/doc/libtiff-3.9.4/README
+usr/share/doc/libtiff-3.9.4/RELEASE-DATE
+usr/share/doc/libtiff-3.9.4/VERSION
+usr/share/man/man1/bmp2tiff.1.gz
+usr/share/man/man1/fax2ps.1.gz
+usr/share/man/man1/fax2tiff.1.gz
+usr/share/man/man1/gif2tiff.1.gz
+usr/share/man/man1/pal2rgb.1.gz
+usr/share/man/man1/ppm2tiff.1.gz
+usr/share/man/man1/ras2tiff.1.gz
+usr/share/man/man1/raw2tiff.1.gz
+usr/share/man/man1/rgb2ycbcr.1.gz
+usr/share/man/man1/thumbnail.1.gz
+usr/share/man/man1/tiff2bw.1.gz
+usr/share/man/man1/tiffcrop.1.gz
+usr/share/man/man1/tiff2pdf.1.gz
+usr/share/man/man1/tiff2ps.1.gz
+usr/share/man/man1/tiff2rgba.1.gz
+usr/share/man/man1/tiffcmp.1.gz
+usr/share/man/man1/tiffcp.1.gz
+usr/share/man/man1/tiffdither.1.gz
+usr/share/man/man1/tiffdump.1.gz
+usr/share/man/man1/tiffinfo.1.gz
+usr/share/man/man1/tiffmedian.1.gz
+usr/share/man/man1/tiffset.1.gz
+usr/share/man/man1/tiffsplit.1.gz
+@comment non-empty directory listing in revers order
+@dirrm usr/share/doc/libtiff-3.9.4