aboutsummaryrefslogtreecommitdiff
path: root/graphics/linux-sdl_image
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-12-23 06:23:35 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-12-23 06:23:35 +0000
commit2020a142a0cd1617ba334778dd94fbd0e7ee64b5 (patch)
tree0642e03e2c1abe7a64666457d5af5d5e1eec883e /graphics/linux-sdl_image
parent1dd8be6ecf778bb42c190cab460c76079b990e72 (diff)
downloadports-2020a142a0cd1617ba334778dd94fbd0e7ee64b5.tar.gz
ports-2020a142a0cd1617ba334778dd94fbd0e7ee64b5.zip
[NEW PORT] graphics/linux-sdl_image: A simple library to load images
as SDL interfaces (linux version) This is a simple library to load images of various formats as SDL surfaces. This library supports BMP, PPM, PCX, GIF, JPEG, PNG, TGA, and TIFF formats. (Linux version) WWW: http://www.libsdl.org/projects/SDL_image/ PR: ports/71552 Submitted by: Nicola Vitale <nivit@email.it>
Notes
Notes: svn path=/head/; revision=124906
Diffstat (limited to 'graphics/linux-sdl_image')
-rw-r--r--graphics/linux-sdl_image/Makefile45
-rw-r--r--graphics/linux-sdl_image/distinfo2
-rw-r--r--graphics/linux-sdl_image/pkg-descr6
-rw-r--r--graphics/linux-sdl_image/pkg-plist6
4 files changed, 59 insertions, 0 deletions
diff --git a/graphics/linux-sdl_image/Makefile b/graphics/linux-sdl_image/Makefile
new file mode 100644
index 000000000000..c8607b6daf25
--- /dev/null
+++ b/graphics/linux-sdl_image/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: linux-sdl_image
+# Date created: 09 July 2004
+# Whom: Nicola Vitale <nivit@email.it>
+# Based on: devel/linux-sdl12 by martin@tradex.sk
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdl_image
+PORTVERSION= 1.2.3
+CATEGORIES= graphics linux
+MASTER_SITES= http://www.libsdl.org/projects/SDL_image/release/
+PKGNAMEPREFIX= linux-
+DISTNAME= SDL_image-${PORTVERSION}-1.${MACHINE_ARCH}
+EXTRACT_SUFX= .rpm
+EXTRACT_ONLY=
+
+MAINTAINER= nivit@users.sourceforge.net
+COMMENT= A simple library to load images as SDL interfaces (linux version)
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
+BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
+
+USE_LINUX_PREFIX= yes
+USE_LINUX_RPM= yes
+LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
+
+ONLY_FOR_ARCHS= i386
+DIST_SUBDIR= rpm
+NO_BUILD= yes
+NO_FILTER_SHLIBS= yes
+
+DBPATH= /var/lib/rpm
+RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
+ --nodeps --replacepkgs
+.if defined(NOPORTDOCS)
+RPMFLAGS+= --excludedocs
+.endif
+RPMDIR= ${DISTDIR}/${DIST_SUBDIR}
+
+do-install:
+ @${LOCALBASE}/bin/rpm -U ${RPMFLAGS} ${RPMDIR}/${DISTFILES}
+ @${LDCONFIG_LINUX}
+
+.include <bsd.port.mk>
diff --git a/graphics/linux-sdl_image/distinfo b/graphics/linux-sdl_image/distinfo
new file mode 100644
index 000000000000..59456e5976d4
--- /dev/null
+++ b/graphics/linux-sdl_image/distinfo
@@ -0,0 +1,2 @@
+MD5 (rpm/SDL_image-1.2.3-1.i386.rpm) = 28556ddd55a16705b5a30cf45a28e78a
+SIZE (rpm/SDL_image-1.2.3-1.i386.rpm) = 133312
diff --git a/graphics/linux-sdl_image/pkg-descr b/graphics/linux-sdl_image/pkg-descr
new file mode 100644
index 000000000000..77770e39e7d6
--- /dev/null
+++ b/graphics/linux-sdl_image/pkg-descr
@@ -0,0 +1,6 @@
+This is a simple library to load images of various formats as SDL surfaces.
+This library supports BMP, PPM, PCX, GIF, JPEG, PNG, TGA, and TIFF formats.
+
+(Linux version)
+
+WWW: http://www.libsdl.org/projects/SDL_image/
diff --git a/graphics/linux-sdl_image/pkg-plist b/graphics/linux-sdl_image/pkg-plist
new file mode 100644
index 000000000000..8c3c76fd1cc3
--- /dev/null
+++ b/graphics/linux-sdl_image/pkg-plist
@@ -0,0 +1,6 @@
+%%PORTDOCS%%usr/doc/SDL_image-1.2.3/CHANGES
+%%PORTDOCS%%usr/doc/SDL_image-1.2.3/COPYING
+%%PORTDOCS%%usr/doc/SDL_image-1.2.3/README
+usr/lib/libSDL_image-1.2.so.0
+usr/lib/libSDL_image-1.2.so.0.1.2
+@dirrm usr/doc/SDL_image-1.2.3