aboutsummaryrefslogtreecommitdiff
path: root/graphics/lprof-devel/files
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-05 12:39:13 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-05 12:39:13 +0000
commitbb51537e7839b543246d4e600d46eeb832d7c3ef (patch)
tree04d8513bf09e3906423d0a1a7f5c5afc61b9e491 /graphics/lprof-devel/files
parent4b5a571da8484ad16b60d608546169aa502840ee (diff)
downloadports-bb51537e7839b543246d4e600d46eeb832d7c3ef.tar.gz
ports-bb51537e7839b543246d4e600d46eeb832d7c3ef.zip
LPROF is the only open source ICC profiler with a graphical user
interface. It can be used to create ICC version 2 compliant profiles for cameras, scanners and monitors. As such it fills a necessary niche in the emerging open source color management effort. WWW: http://lprof.sourceforge.net PR: ports/124240 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
Notes
Notes: svn path=/head/; revision=214350
Diffstat (limited to 'graphics/lprof-devel/files')
-rw-r--r--graphics/lprof-devel/files/patch-src-CMakeLists.txt11
-rw-r--r--graphics/lprof-devel/files/patch-src-argyll-spectro-unixio.c27
-rw-r--r--graphics/lprof-devel/files/patch-src-libqtlcmswidgets-lprofgauge.h10
3 files changed, 48 insertions, 0 deletions
diff --git a/graphics/lprof-devel/files/patch-src-CMakeLists.txt b/graphics/lprof-devel/files/patch-src-CMakeLists.txt
new file mode 100644
index 000000000000..f564ba957e14
--- /dev/null
+++ b/graphics/lprof-devel/files/patch-src-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/CMakeLists.txt.orig 2008-02-20 00:01:32.000000000 +0300
++++ src/CMakeLists.txt 2008-05-24 05:13:22.000000000 +0400
+@@ -129,7 +129,7 @@
+
+ # Normally these are set for us. Since we're overriding the normal include path we've got to add them ourselves, but it's
+ # probably a good idea to be explicit about what we use anyway.
+-SET(lprof_qt_incs "${QT_INCLUDE_DIR};${QT_QT_INCLUDE_DIR};${QT_QTCORE_INCLUDE_DIR};${QT_QTGUI_INCLUDE_DIR};${QT_QTSVG_INCLUDE_DIR};${QT_QT3SUPPORT_INCLUDE_DIR};${QT_QTASSISTANT_INCLUDE_DIR}")
++SET(lprof_qt_incs "${QT_QT_INCLUDE_DIR};${QT_QTCORE_INCLUDE_DIR};${QT_QTGUI_INCLUDE_DIR};${QT_QT3SUPPORT_INCLUDE_DIR};${QT_QTASSISTANT_INCLUDE_DIR};${QT_INCLUDE_DIR}")
+
+
+ IF(NOT LIBVIGRAIMPEX_FOUND)
diff --git a/graphics/lprof-devel/files/patch-src-argyll-spectro-unixio.c b/graphics/lprof-devel/files/patch-src-argyll-spectro-unixio.c
new file mode 100644
index 000000000000..092e78d7ddc5
--- /dev/null
+++ b/graphics/lprof-devel/files/patch-src-argyll-spectro-unixio.c
@@ -0,0 +1,27 @@
+--- src/argyll/spectro/unixio.c.orig 2008-02-20 00:02:24.000000000 +0300
++++ src/argyll/spectro/unixio.c 2008-05-14 06:16:33.000000000 +0400
+@@ -585,9 +585,8 @@
+ break;
+
+ if (!(
+- ( strncmp(de->d_name, "ttyS", 4) == 0
+- && de->d_name[4] >= '0' && de->d_name[4] <= '9')
+- || ( strncmp(de->d_name, "ttyUSB", 5) == 0)
++ ( strncmp(de->d_name, "ttyd", 4) == 0 || strncmp(de->d_name, "ttyU", 4) == 0)
++ && de->d_name[4] >= '0' && de->d_name[4] <= '9' && de->d_name[5] == '\0'
+ ))
+ continue;
+
+@@ -598,12 +597,6 @@
+ strcpy(dpath, dirn);
+ strcat(dpath, de->d_name);
+
+- if ((fd = open(dpath, O_RDWR | O_NOCTTY )) < 0) {
+- free(dpath);
+- continue;
+- }
+- close(fd);
+-
+ /* Add the path to the list */
+ if (p->paths == NULL) {
+ if ((p->paths = (icompath **)calloc(sizeof(icompath *), 1 + 1)) == NULL) {
diff --git a/graphics/lprof-devel/files/patch-src-libqtlcmswidgets-lprofgauge.h b/graphics/lprof-devel/files/patch-src-libqtlcmswidgets-lprofgauge.h
new file mode 100644
index 000000000000..6a30db004ddd
--- /dev/null
+++ b/graphics/lprof-devel/files/patch-src-libqtlcmswidgets-lprofgauge.h
@@ -0,0 +1,10 @@
+--- src/libqtlcmswidgets/lprofgauge.h.orig 2008-02-20 00:02:39.000000000 +0300
++++ src/libqtlcmswidgets/lprofgauge.h 2008-05-24 05:07:17.000000000 +0400
+@@ -58,7 +58,6 @@
+
+ #include <Qt>
+ #include <QWidget>
+-#include <QtDesigner/QDesignerExportWidget>
+
+
+ class QColor;