aboutsummaryrefslogtreecommitdiff
path: root/graphics/luxrender
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2016-06-06 09:37:11 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2016-06-06 09:37:11 +0000
commitd563f260840229a77f9efd5d40e8b119c89e3bc4 (patch)
tree01ca94bdb9ff46652e62a1d4a16098407b36f3f6 /graphics/luxrender
parent247c71f1c75f3757d357d125ea4937255d8191ae (diff)
downloadports-d563f260840229a77f9efd5d40e8b119c89e3bc4.tar.gz
ports-d563f260840229a77f9efd5d40e8b119c89e3bc4.zip
- Update LuxRender modern (Embree-based) branch to version 1.6
- Move DISTFILES setting back to master port exclusively as upstream had used correct (coherent with v1.4) tags for v1.6 this time - Register mutual port install-time conflict (CONFLICTS_INSTALL) - Create convenience symlink in `post-extract' rather than `pre-patch', because `200:dos2unix' bogusly(?) runs before `300:pre-patch' - Since luxrays' library samples are not built as of r410138, do not try to patch them (GC currently no-op patches) - For the same reason, do not request GLUT, GLEW, and execinfo libraries that were only used when building samples - Convert FreeImage to an option (mandatory for v1.4) and default to off
Notes
Notes: svn path=/head/; revision=416447
Diffstat (limited to 'graphics/luxrender')
-rw-r--r--graphics/luxrender/Makefile25
-rw-r--r--graphics/luxrender/distinfo8
-rw-r--r--graphics/luxrender/files/patch-luxrays-CMakeLists.txt40
-rw-r--r--graphics/luxrender/files/patch-luxrays-samples-benchsimple-CMakeLists.txt14
-rw-r--r--graphics/luxrender/files/patch-luxrays-samples-luxcoredemo-CMakeLists.txt16
-rw-r--r--graphics/luxrender/files/patch-luxrays-samples-luxcoreimplserializationdemo-CMakeLists.txt16
-rw-r--r--graphics/luxrender/files/patch-luxrays-samples-luxcorescenedemo-CMakeLists.txt16
-rw-r--r--graphics/luxrender/files/patch-luxrays-samples-smallluxgpu4-CMakeLists.txt24
8 files changed, 53 insertions, 106 deletions
diff --git a/graphics/luxrender/Makefile b/graphics/luxrender/Makefile
index 8b881ae9f0b1..7ddf4449343d 100644
--- a/graphics/luxrender/Makefile
+++ b/graphics/luxrender/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= luxrender
-DISTVERSION?= 1.5.1
+DISTVERSION?= 1.6
CATEGORIES= graphics
MASTER_SITES= https://bitbucket.org/luxrender/lux/get/ \
https://bitbucket.org/luxrender/luxrays/get/:lr
-DISTFILES?= ${PORTNAME}_v${DISTVERSION}.tar.gz \
+DISTFILES= v${DISTVERSION:C/[.-]//g}${EXTRACT_SUFX} \
${PORTNAME}_v${DISTVERSION:S/-//}${EXTRACT_SUFX}:lr
DIST_SUBDIR= ${PORTNAME}
@@ -17,17 +17,19 @@ LICENSE= GPLv3
LIB_DEPENDS= libboost_python.so:devel/boost-python-libs \
libfftw3.so:math/fftw3 \
- libfreeimage.so:graphics/freeimage \
libOpenImageIO.so:graphics/openimageio
.if ${DISTVERSION} != 1.4
LIB_DEPENDS+= libembree.so:graphics/embree
.endif
+CONFLICTS_INSTALL?= ${PORTNAME}14-1.4*
+
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= uses SSE instructions
-USES= bison cmake execinfo python:build tar:bzip2
-USE_GL= glut glew
+USES+= bison cmake python:build tar:bzip2
+USE_GL= glu
+
WRKSRC= ${WRKDIR}/${PORTNAME}-lux-${LUX_REV}
LUXRAYS_WRKSRC= ${WRKDIR}/${PORTNAME}-luxrays-${LUXRAYS_REV}
@@ -39,22 +41,25 @@ CMAKE_ARGS= -DLUXCORE_INCLUDE_DIRS:PATH="${LUXRAYS_WRKSRC}/include" \
-DSLG_LIBRARY:PATH="${LUXRAYS_WRKSRC}/lib/libsmallluxgpu.a" \
-DLUXRAYS_DISABLE_OPENCL:BOOL=ON
-LUX_REV?= 8dabcd6b7016
-LUXRAYS_REV?= 8577ff287efb
+LUX_REV?= b3f85cf7742f
+LUXRAYS_REV?= 61352e6aae3f
-OPTIONS_DEFINE= X11
+OPTIONS_DEFINE= FREEIMAGE X11
OPTIONS_DEFAULT= X11
+FREEIMAGE_DESC= Build with FreeImage (otherwise use OIIO only)
+FREEIMAGE_CMAKE_ON= -DLUX_USE_FREEIMAGE:BOOL=ON
+FREEIMAGE_LIB_DEPENDS= libfreeimage.so:graphics/freeimage
+
X11_DESC= Build GUI executable (requires Qt 4)
X11_USE= QT4=moc_build,qmake_build,rcc_build,uic_build,corelib,gui
X11_PLIST_FILES= bin/luxrender
-pre-patch:
+post-extract:
@${LN} -sf ${PORTNAME}-luxrays-${LUXRAYS_REV} ${WRKDIR}/luxrays
post-patch:
@${REINPLACE_CMD} -e 's/__APPLE__/__FreeBSD__/' \
- ${LUXRAYS_WRKSRC}/samples/smallluxgpu4/smallluxgpu.h \
${WRKSRC}/core/osfunc.h \
${WRKSRC}/shapes/mikktspace/weldmesh.c
# Avoid infamous "local symbol discarded in section `.text...' errors
diff --git a/graphics/luxrender/distinfo b/graphics/luxrender/distinfo
index f64459f86e6f..a857ce4ab2df 100644
--- a/graphics/luxrender/distinfo
+++ b/graphics/luxrender/distinfo
@@ -1,4 +1,4 @@
-SHA256 (luxrender/luxrender_v1.5.1.tar.gz) = 6f55594759c7580bc9b08d517fc23a4e7c2e2195e8ad367e87ba1a3a2216f3e2
-SIZE (luxrender/luxrender_v1.5.1.tar.gz) = 3267994
-SHA256 (luxrender/luxrender_v1.5.1.tar.bz2) = 551ce7506f04a51f59c262cb47dd03db5db1d4a0d3cd7f43d7b4dbb10ddd94cc
-SIZE (luxrender/luxrender_v1.5.1.tar.bz2) = 29613457
+SHA256 (luxrender/v16.tar.bz2) = 29144f657087644086928a66421df5d25fc4dccd05970200932f5693650ddecf
+SIZE (luxrender/v16.tar.bz2) = 2421141
+SHA256 (luxrender/luxrender_v1.6.tar.bz2) = eb38489e4bcb1336027efc8fa991f506bf78e8cb9edc7b73794e0cdcf998b15a
+SIZE (luxrender/luxrender_v1.6.tar.bz2) = 36615450
diff --git a/graphics/luxrender/files/patch-luxrays-CMakeLists.txt b/graphics/luxrender/files/patch-luxrays-CMakeLists.txt
index 46aa445d860c..ffdd49ebebc0 100644
--- a/graphics/luxrender/files/patch-luxrays-CMakeLists.txt
+++ b/graphics/luxrender/files/patch-luxrays-CMakeLists.txt
@@ -1,19 +1,47 @@
---- ../luxrays/CMakeLists.txt.orig 2015-10-06 08:56:47 UTC
+--- ../luxrays/CMakeLists.txt.orig
+++ ../luxrays/CMakeLists.txt
-@@ -128,16 +128,6 @@ add_subdirectory(src/luxcore)
- #
- ################################################################################
+@@ -91,14 +91,6 @@ if (NOT OPENGL_FOUND AND NOT LUXRAYS_DIS
+ SET(LUXRAYS_DISABLE_OPENCL 1)
+ endif()
+
+-if (NOT GLEW_FOUND)
+- MESSAGE(FATAL_ERROR "--> Could not locate required GLEW files, disabling samples build - Please check ${GLEW_SEARCH_PATH}")
+-endif()
+-
+-if (NOT GLUT_FOUND)
+- MESSAGE(FATAL_ERROR "--> Could not locate required GLUT files, disabling samples build - Please check ${GLUT_SEARCH_PATH}")
+-endif()
+-
+ if (NOT EMBREE_FOUND)
+ MESSAGE(FATAL_ERROR "--> Could not locate required Intel Embree files - Please check ${EMBREE_SEARCH_PATH}")
+ endif()
+@@ -124,29 +116,6 @@ add_subdirectory(src/luxcore)
+ ################################################################################
+ #
+-# Samples
+-#
+-################################################################################
+-
-if(NOT APPLE OR OSX_BUILD_DEMOS)
- add_subdirectory(samples/benchsimple)
- add_subdirectory(samples/luxcoredemo)
- add_subdirectory(samples/luxcorescenedemo)
- add_subdirectory(samples/luxcoreimplserializationdemo)
-endif()
+-
-if(OPENGL_FOUND AND GLUT_FOUND AND GLEW_FOUND)
- add_subdirectory(samples/smallluxgpu4)
-endif(OPENGL_FOUND AND GLUT_FOUND AND GLEW_FOUND)
-
-
- ################################################################################
+-add_subdirectory(samples/luxcoreconsole)
+-if(OPENGL_FOUND)
+- add_subdirectory(samples/luxcoreui)
+-endif(OPENGL_FOUND)
+-
+-
+-################################################################################
+-#
+ # For non win32 we'll have to copy everything to a single dir
#
+ ################################################################################
diff --git a/graphics/luxrender/files/patch-luxrays-samples-benchsimple-CMakeLists.txt b/graphics/luxrender/files/patch-luxrays-samples-benchsimple-CMakeLists.txt
deleted file mode 100644
index 57463f284521..000000000000
--- a/graphics/luxrender/files/patch-luxrays-samples-benchsimple-CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
---- ../luxrays/samples/benchsimple/CMakeLists.txt.orig
-+++ ../luxrays/samples/benchsimple/CMakeLists.txt
-@@ -19,8 +19,10 @@
- # LuxRays website: http://www.luxrender.net #
- ###########################################################################
-
-+find_package(Threads)
-+
- include_directories(${LuxRays_INCLUDE_DIR})
- link_directories (${LuxRays_LIB_DIR})
-
- add_executable(benchsimple benchsimple.cpp)
--target_link_libraries(benchsimple luxrays)
-+target_link_libraries(benchsimple luxrays ${PYTHON_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
diff --git a/graphics/luxrender/files/patch-luxrays-samples-luxcoredemo-CMakeLists.txt b/graphics/luxrender/files/patch-luxrays-samples-luxcoredemo-CMakeLists.txt
deleted file mode 100644
index c49fa9306fa8..000000000000
--- a/graphics/luxrender/files/patch-luxrays-samples-luxcoredemo-CMakeLists.txt
+++ /dev/null
@@ -1,16 +0,0 @@
---- ../luxrays/samples/luxcoredemo/CMakeLists.txt.orig
-+++ ../luxrays/samples/luxcoredemo/CMakeLists.txt
-@@ -22,10 +22,12 @@
- #
- ################################################################################
-
-+find_package(Threads)
-+
- set(LUXCORELIBDEMO_SRCS
- luxcoredemo.cpp
- )
-
- add_executable(luxcoredemo ${LUXCORELIBDEMO_SRCS})
-
--TARGET_LINK_LIBRARIES(luxcoredemo luxcore smallluxgpu luxrays ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
-+TARGET_LINK_LIBRARIES(luxcoredemo luxcore smallluxgpu luxrays ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES} ${PYTHON_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
diff --git a/graphics/luxrender/files/patch-luxrays-samples-luxcoreimplserializationdemo-CMakeLists.txt b/graphics/luxrender/files/patch-luxrays-samples-luxcoreimplserializationdemo-CMakeLists.txt
deleted file mode 100644
index 61b086aac3aa..000000000000
--- a/graphics/luxrender/files/patch-luxrays-samples-luxcoreimplserializationdemo-CMakeLists.txt
+++ /dev/null
@@ -1,16 +0,0 @@
---- ../luxrays/samples/luxcoreimplserializationdemo/CMakeLists.txt.orig 2015-08-29 17:04:08 UTC
-+++ ../luxrays/samples/luxcoreimplserializationdemo/CMakeLists.txt
-@@ -22,10 +22,12 @@
- #
- ################################################################################
-
-+find_package(Threads)
-+
- set(LUXCOREIMPL_SERIALIZATIONDEMO_SRCS
- luxcoreimplserializationdemo.cpp
- )
-
- add_executable(luxcoreimplserializationdemo ${LUXCOREIMPL_SERIALIZATIONDEMO_SRCS})
-
--TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore smallluxgpu luxrays ${EMBREE_LIBRARY} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
-+TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore smallluxgpu luxrays ${EMBREE_LIBRARY} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES} ${PYTHON_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
diff --git a/graphics/luxrender/files/patch-luxrays-samples-luxcorescenedemo-CMakeLists.txt b/graphics/luxrender/files/patch-luxrays-samples-luxcorescenedemo-CMakeLists.txt
deleted file mode 100644
index 582310ee23b0..000000000000
--- a/graphics/luxrender/files/patch-luxrays-samples-luxcorescenedemo-CMakeLists.txt
+++ /dev/null
@@ -1,16 +0,0 @@
---- ../luxrays/samples/luxcorescenedemo/CMakeLists.txt.orig
-+++ ../luxrays/samples/luxcorescenedemo/CMakeLists.txt
-@@ -22,10 +22,12 @@
- #
- ################################################################################
-
-+find_package(Threads)
-+
- set(LUXCORESCENEDEMO_SRCS
- luxcorescenedemo.cpp
- )
-
- add_executable(luxcorescenedemo ${LUXCORESCENEDEMO_SRCS})
-
--TARGET_LINK_LIBRARIES(luxcorescenedemo luxcore smallluxgpu luxrays ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
-+TARGET_LINK_LIBRARIES(luxcorescenedemo luxcore smallluxgpu luxrays ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES} ${PYTHON_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
diff --git a/graphics/luxrender/files/patch-luxrays-samples-smallluxgpu4-CMakeLists.txt b/graphics/luxrender/files/patch-luxrays-samples-smallluxgpu4-CMakeLists.txt
deleted file mode 100644
index 1c4be84820b4..000000000000
--- a/graphics/luxrender/files/patch-luxrays-samples-smallluxgpu4-CMakeLists.txt
+++ /dev/null
@@ -1,24 +0,0 @@
---- ../luxrays/samples/smallluxgpu4/CMakeLists.txt.orig
-+++ ../luxrays/samples/smallluxgpu4/CMakeLists.txt
-@@ -22,6 +22,8 @@
- #
- #############################################################################
-
-+find_package(Threads)
-+
- set(SMALLLUXGPU_SRCS
- smallluxgpu.cpp
- displayfunc.cpp
-@@ -29,11 +31,7 @@
-
- add_executable(slg4 ${SMALLLUXGPU_SRCS})
-
--if(APPLE)
-- TARGET_LINK_LIBRARIES(slg4 luxcore smallluxgpu luxrays ${EMBREE_LIBRARY} ${OPENGL_LIBRARIES} ${GLEW_LIBRARY} ${GLUT_LIBRARY} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
--else(APPLE)
-- TARGET_LINK_LIBRARIES(slg4 luxcore smallluxgpu luxrays ${EMBREE_LIBRARY} ${OPENGL_LIBRARIES} ${GLEW_LIBRARY} ${GLUT_LIBRARY} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
--endif(APPLE)
-+TARGET_LINK_LIBRARIES(slg4 luxcore smallluxgpu luxrays ${EMBREE_LIBRARY} ${OPENGL_LIBRARIES} ${GLEW_LIBRARY} ${GLUT_LIBRARY} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES} ${PYTHON_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} -lexecinfo)
-
- # This instructs FREEGLUT to emit a pragma for the static version
- SET_TARGET_PROPERTIES(slg4 PROPERTIES COMPILE_DEFINITIONS FREEGLUT_STATIC)