aboutsummaryrefslogtreecommitdiff
path: root/graphics/mapserver/Makefile
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2004-12-13 20:25:34 +0000
committerMichael Haro <mharo@FreeBSD.org>2004-12-13 20:25:34 +0000
commit626c205db9296702afa9ec414e4b07a5477d0339 (patch)
tree8b7a32317387a97be13355d80b9143807b0c9fbf /graphics/mapserver/Makefile
parent0083804533ca47e8481e5b40de38c7d76c789b91 (diff)
downloadports-626c205db9296702afa9ec414e4b07a5477d0339.tar.gz
ports-626c205db9296702afa9ec414e4b07a5477d0339.zip
upgrade to 4.4.0
Notes
Notes: svn path=/head/; revision=123953
Diffstat (limited to 'graphics/mapserver/Makefile')
-rw-r--r--graphics/mapserver/Makefile21
1 files changed, 15 insertions, 6 deletions
diff --git a/graphics/mapserver/Makefile b/graphics/mapserver/Makefile
index 1bfb6c8911c4..a68b0a714cf3 100644
--- a/graphics/mapserver/Makefile
+++ b/graphics/mapserver/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= mapserver
-PORTVERSION= 4.2.3
-PORTREVISION= 1
+PORTVERSION= 4.4.0
+PORTREVISION= 0
CATEGORIES= graphics www misc
MASTER_SITES= http://cvs.gis.umn.edu/dist/
@@ -17,8 +17,6 @@ COMMENT= System for developing web-based GIS applications
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd \
proj.5:${PORTSDIR}/graphics/proj
-BROKEN= "Does not install"
-
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-runpath \
@@ -33,7 +31,8 @@ OPTIONS= TIFF "Support for TIFF (but not GeoTIFF) files" off \
PHP "Support for MapScript/PHP" off \
PERL "Support for MapScript/PERL" off \
WMS "Support for web map service server and client" off \
- WFS "Support for web feature service" off \
+ WFS "Support for web feature service (req: GDAL)" off \
+ MAPSERV "Install mapserv cgi interface" on \
DEBUG "Enable debugging output" off
.include <bsd.port.pre.mk>
@@ -111,6 +110,13 @@ LIB_DEPENDS+= curl.3:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+= --with-curl=${LOCALBASE}
.endif
+.if defined(WITH_MAPSERV)
+USE_APACHE= YES
+PLIST_SUB+= WITH_MAPSERV=""
+.else
+PLIST_SUB+= WITH_MAPSERV="@comment "
+.endif
+
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
.endif
@@ -126,8 +132,11 @@ do-install:
.for f in ${PROG_FILES}
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
.endfor
- ${INSTALL_PROGRAM} ${WRKSRC}/mapserv ${LOCALBASE}/www/cgi-bin/mapserv
${INSTALL_SCRIPT} ${WRKSRC}/shp2mysql.pl ${PREFIX}/bin/shp2mysql
+.if defined(WITH_MAPSERV)
+ ${MKDIR} ${LOCALBASE}/www/cgi-bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/mapserv ${LOCALBASE}/www/cgi-bin/mapserv
+.endif
.if defined(WITH_PHP)
@${MKDIR} ${LOCALBASE}/${PHP_EXTENSION_DIR}
${INSTALL_PROGRAM} ${WRKSRC}/mapscript/php3/php_mapscript.so ${LOCALBASE}/${PHP_EXTENSION_DIR}/