aboutsummaryrefslogtreecommitdiff
path: root/graphics/metacam/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-04 15:22:59 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-04 15:22:59 +0000
commitc9bab278e7d9ab5d8be1ea227784a4a7bafe105c (patch)
tree9fa316241d2afc533a2ac26d1f92c4511d3c51c2 /graphics/metacam/Makefile
parent9a4796daf5d43365174e1822cb5570637ddc72df (diff)
downloadports-c9bab278e7d9ab5d8be1ea227784a4a7bafe105c.tar.gz
ports-c9bab278e7d9ab5d8be1ea227784a4a7bafe105c.zip
MetaCam is a utility to read and decode meta-information from digital camera
images with EXIF information. In addition to the standard EXIF fields, MetaCam also supports vendor-specific extensions from Nikon, Olympus, Canon and Casio. PR: ports/85628 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Notes
Notes: svn path=/head/; revision=141926
Diffstat (limited to 'graphics/metacam/Makefile')
-rw-r--r--graphics/metacam/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/graphics/metacam/Makefile b/graphics/metacam/Makefile
new file mode 100644
index 000000000000..c56812d0fcd2
--- /dev/null
+++ b/graphics/metacam/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: metacam
+# Date created: 2 Sep 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= metacam
+PORTVERSION= 1.2
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.cheeseplant.org/pub/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A digital camera EXIF meta-information reader
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_GETOPT_LONG=yes
+USE_GCC= 3.4+
+
+CFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= -I${LOCALBASE}/include
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+
+PLIST_FILES= bin/metacam
+PORTDOCS= README.canon README.casio
+MAN1= metacam.1
+
+ALL_TARGET= ${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+post-patch:
+ @${REINPLACE_CMD} -e 's|<\(getopt\.h\)>|"\1"|' ${WRKSRC}/${PORTNAME}.cc
+ ${CP} ${FILESDIR}/getopt.h ${WRKSRC}
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${FILESDIR}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>