aboutsummaryrefslogtreecommitdiff
path: root/graphics/mirtk/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-06-01 07:40:23 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-06-01 07:40:23 +0000
commitd74706797e0b0dc4671f55fff1bbbcd74b61db27 (patch)
treead58e644014b5a0a0487403f91f325dd0624565f /graphics/mirtk/Makefile
parent1d92e913229b99f54055a35b5a9673652a35e9e8 (diff)
downloadports-d74706797e0b0dc4671f55fff1bbbcd74b61db27.tar.gz
ports-d74706797e0b0dc4671f55fff1bbbcd74b61db27.zip
New port: graphics/mirtk: Medical Image Registration ToolKit (MIRTK)
Notes
Notes: svn path=/head/; revision=503225
Diffstat (limited to 'graphics/mirtk/Makefile')
-rw-r--r--graphics/mirtk/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/graphics/mirtk/Makefile b/graphics/mirtk/Makefile
new file mode 100644
index 000000000000..935ee18d1c2d
--- /dev/null
+++ b/graphics/mirtk/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= mirtk
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.0.0-42
+DISTVERSIONSUFFIX= -g7390df6
+CATEGORIES= graphics
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Medical Image Registration ToolKit (MIRTK)
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= boost-libs>0:devel/boost-libs \
+ nifticlib>0:science/nifticlib
+
+USES= cmake compiler:c++11-lang eigen:3 perl5 python
+USE_GITHUB= yes
+GH_ACCOUNT= BioMedIA
+GH_PROJECT= ${PORTNAME:tu}
+USE_LDCONFIG= yes
+
+post-stage: # https://github.com/BioMedIA/MIRTK/issues/674
+ @${RM} ${STAGEDIR}${PREFIX}/bin/uninstall-mirtk
+ @${REINPLACE_CMD} -i '' 's|${STAGEDIR}||' ${STAGEDIR}${PREFIX}/lib/cmake/mirtk/MIRTKInstallManifest.txt
+
+.include <bsd.port.mk>