aboutsummaryrefslogtreecommitdiff
path: root/graphics/mscgen/Makefile
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2014-05-12 07:31:17 +0000
committerRomain Tartière <romain@FreeBSD.org>2014-05-12 07:31:17 +0000
commit1c4c91465a721c194afd13166cf05a51ba498a3a (patch)
tree09ea2f181fe4992566030a735e4d294884fb41dc /graphics/mscgen/Makefile
parenta44418b03b5a23d912503bf10fd4cd753dd053cd (diff)
downloadports-1c4c91465a721c194afd13166cf05a51ba498a3a.tar.gz
ports-1c4c91465a721c194afd13166cf05a51ba498a3a.zip
- Support staging;
- Make freetype dependency optional; - Pet portlint.
Notes
Notes: svn path=/head/; revision=353778
Diffstat (limited to 'graphics/mscgen/Makefile')
-rw-r--r--graphics/mscgen/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/graphics/mscgen/Makefile b/graphics/mscgen/Makefile
index cbc97048c0d7..76eba748d72f 100644
--- a/graphics/mscgen/Makefile
+++ b/graphics/mscgen/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mscgen
PORTVERSION= 0.20
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://www.mcternan.me.uk/mscgen/software/ \
http://romain.blogreen.org/distfiles/
@@ -12,12 +12,18 @@ DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= romain@FreeBSD.org
COMMENT= A Message Sequence Chart Renderer
-OPTIONS_DEFINE= PNG
-OPTIONS_DEFAULT= PNG
+OPTIONS_DEFINE= FREETYPE PNG
+OPTIONS_DEFAULT=FREETYPE PNG
-NO_STAGE= yes
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MFREETYPE}
+CONFIGURE_ARGS+=--with-freetype
+LIB_DEPENDS+= freetype:${PORTSDIR}/print/freetype2
+.else
+CONFIGURE_ARGS+=--without-freetype
+.endif
+
.if ${PORT_OPTIONS:MPNG}
CONFIGURE_ARGS+=--with-png
LIB_DEPENDS+= gd:${PORTSDIR}/graphics/gd