aboutsummaryrefslogtreecommitdiff
path: root/graphics/mxp
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2005-03-25 01:47:15 +0000
committerMaho Nakata <maho@FreeBSD.org>2005-03-25 01:47:15 +0000
commit943ad93280865582a3aa39b20d05c5392c57e19f (patch)
tree0bebb554655d0ece52e626a774b8b30253fc4455 /graphics/mxp
parente9d88cc1dd1f19c33dcbb09679184d88ba2e93cd (diff)
downloadports-943ad93280865582a3aa39b20d05c5392c57e19f.tar.gz
ports-943ad93280865582a3aa39b20d05c5392c57e19f.zip
Add mxp (Mandelbrot explorer). Mxp is an X application for computing and exploring
Mandelbrot sets. Features of mxp include: - zoom and un-zoom - dynamic resizing of drawing window - setup save/load - asynchronous image generation (buttons always work) - GIF output - animation - nine color schemes - color rotation - color change options - detailed statistics WWW: http://www.ibiblio.org/pub/Linux/apps/math/fractals/ and also fix category Approved by: portmgr(marcus) Submitted by: kris
Notes
Notes: svn path=/head/; revision=131934
Diffstat (limited to 'graphics/mxp')
-rw-r--r--graphics/mxp/Makefile37
-rw-r--r--graphics/mxp/distinfo2
-rw-r--r--graphics/mxp/files/patch-Makefile50
-rw-r--r--graphics/mxp/files/patch-lugfnts.h16
-rw-r--r--graphics/mxp/pkg-descr14
-rw-r--r--graphics/mxp/pkg-plist4
6 files changed, 123 insertions, 0 deletions
diff --git a/graphics/mxp/Makefile b/graphics/mxp/Makefile
new file mode 100644
index 000000000000..5cfd4d6c09b1
--- /dev/null
+++ b/graphics/mxp/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mxp
+# Date Created: 18 March 2004
+# Whom: NAKATA Maho <maho@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mxp
+PORTVERSION= 1.3
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR=apps/math/fractals
+
+MAINTAINER= maho@FreeBSD.org
+COMMENT= Application for computing/exploring Mandelbrot set
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_XPM= yes
+USE_REINPLACE= yes
+ALL_TARGET=
+
+post-extract:
+ @${CP} ${WRKSRC}/Makefile.noimake ${WRKSRC}/Makefile
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
+ s|%%X11BASE%%|${X11BASE}|g ; \
+ s|%%CFLAGS%%|${CFLAGS}|g ; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g ; \
+ s|%%CC%%|${CC}|g' ${WRKSRC}/Makefile
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mxp ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/mxp/distinfo b/graphics/mxp/distinfo
new file mode 100644
index 000000000000..1c0ed18abcbd
--- /dev/null
+++ b/graphics/mxp/distinfo
@@ -0,0 +1,2 @@
+MD5 (mxp-1.3.tar.gz) = c53f8b91fcbb09c4ad885bb7c34d2dd0
+SIZE (mxp-1.3.tar.gz) = 43291
diff --git a/graphics/mxp/files/patch-Makefile b/graphics/mxp/files/patch-Makefile
new file mode 100644
index 000000000000..7aa5edbf6963
--- /dev/null
+++ b/graphics/mxp/files/patch-Makefile
@@ -0,0 +1,50 @@
+--- Makefile.orig Sat Feb 12 16:42:03 2005
++++ Makefile Sat Feb 12 16:42:45 2005
+@@ -1,30 +1,30 @@
+ # Makefile file for mxp - Mandelbrot Explorer
+
+ # Compiler - uncomment for gcc
+-# CC = gcc
++CC = %%CC%%
+
+ # Since this is a compute intensive program, be sure to use
+ # compiler optimization. It makes a big difference.
+ # For gcc on linux "-O2 -m486" works well.
+-# OPT = -O2 -m486
++OPT = %%CFLAGS%%
+
+ # If X is not installed in the standard places you will need to set the
+ # following 2 defines.
+-XLIBS = -L/usr/openwin/lib
+-XINC = -I/usr/openwin/include
++XLIBS = -L%%X11BASE%%/lib
++XINC = -I%%X11BASE%%/include
+
+ # Specify where your Xpm installation directories are
+ # If you have the XPM libraries uncomment and adjust the following lines
+ # to use color icons.
+-#XPM_DEF = -DXPM
+-#XPM_INCLUDE = -I/usr/local/include
+-#XPM_LIB = -L$(LIBDIR)/xpm -lXpm
++XPM_DEF = -DXPM
++XPM_INCLUDE = #-I/usr/local/include
++XPM_LIB = -lXpm #-L$(LIBDIR)/xpm
+
+ # If you are using FVWM 2.0 then the following must be set to 2
+ SIZE_INC = 1
+
+ # Specify install directory
+-BINDIR = /usr/local/bin
++BINDIR = %%PREFIX%%/bin
+
+ INCLUDES = $(XPM_INCLUDE) $(XINC) -Ilug
+
+@@ -34,7 +34,7 @@
+ OBJS = $(M_OBJS) $(L_OBJS)
+
+ mxp: $(OBJS)
+- $(CC) -o $@ $(OBJS) $(XPM_LIB) -L/X/X11/lib -lm -lXaw -lXt -lXmu -lX11 -lXdmcp -lXext
++ $(CC) -o $@ $(OBJS) $(XPM_LIB) $(XLIBS) -lm -lXaw -lXt -lXmu -lX11 -lXdmcp -lXext
+
+ $(OBJS): mxp.h
+
diff --git a/graphics/mxp/files/patch-lugfnts.h b/graphics/mxp/files/patch-lugfnts.h
new file mode 100644
index 000000000000..234b32b5d6f8
--- /dev/null
+++ b/graphics/mxp/files/patch-lugfnts.h
@@ -0,0 +1,16 @@
+--- lug/lugfnts.h.old Sat Aug 18 13:33:46 2001
++++ lug/lugfnts.h Sat Feb 12 16:30:29 2005
+@@ -1057,13 +1057,6 @@
+ );
+
+ extern int
+-isnumber(
+-#ifdef USE_PROTOTYPES
+- char *
+-#endif
+-);
+-
+-extern int
+ Uncompress(
+ #ifdef USE_PROTOTYPES
+ char *,
diff --git a/graphics/mxp/pkg-descr b/graphics/mxp/pkg-descr
new file mode 100644
index 000000000000..d0b7d5ed785d
--- /dev/null
+++ b/graphics/mxp/pkg-descr
@@ -0,0 +1,14 @@
+Mxp (Mandelbrot explorer) is an X application for computing and exploring
+Mandelbrot sets. Features of mxp include:
+ - zoom and un-zoom
+ - dynamic resizing of drawing window
+ - setup save/load
+ - asynchronous image generation (buttons always work)
+ - GIF output
+ - animation
+ - nine color schemes
+ - color rotation
+ - color change options
+ - detailed statistics
+
+WWW: http://www.ibiblio.org/pub/Linux/apps/math/fractals/
diff --git a/graphics/mxp/pkg-plist b/graphics/mxp/pkg-plist
new file mode 100644
index 000000000000..dc99a7065c9a
--- /dev/null
+++ b/graphics/mxp/pkg-plist
@@ -0,0 +1,4 @@
+bin/mxp
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+