aboutsummaryrefslogtreecommitdiff
path: root/graphics/ocaml-images
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-08-07 07:19:19 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-08-07 07:30:08 +0000
commite88dd7a0da54b2f31e635c5da8988862de23ca13 (patch)
treecbf14b37fa42bbc2c7bdf579a53612683f284988 /graphics/ocaml-images
parent4b76ea32c4494bc1867825878f46b61149818aa4 (diff)
downloadports-e88dd7a0da54b2f31e635c5da8988862de23ca13.tar.gz
ports-e88dd7a0da54b2f31e635c5da8988862de23ca13.zip
graphics/ocaml-images: prepare for freetype2 update
- freetype2 will no longer ship freetype-config (which was a pkg-config wrapper) in the near future -- use pkg-config to gather the required flags. PR: 251512
Diffstat (limited to 'graphics/ocaml-images')
-rw-r--r--graphics/ocaml-images/Makefile3
-rw-r--r--graphics/ocaml-images/files/patch-OMakefile23
-rw-r--r--graphics/ocaml-images/files/patch-configure13
3 files changed, 36 insertions, 3 deletions
diff --git a/graphics/ocaml-images/Makefile b/graphics/ocaml-images/Makefile
index 3c6141de4719..d6405e47b9c0 100644
--- a/graphics/ocaml-images/Makefile
+++ b/graphics/ocaml-images/Makefile
@@ -51,6 +51,7 @@ XPM_CONFIGURE_WITH= xpm
GIF_CONFIGURE_WITH= gif
GIF_LIB_DEPENDS= libgif.so:graphics/giflib
+FREETYPE_USES= pkgconfig
FREETYPE_CONFIGURE_WITH=freetype
FREETYPE_LIB_DEPENDS= libttf.so:print/freetype \
libfreetype.so:print/freetype2
@@ -62,6 +63,8 @@ GTK2_CONFIGURE_WITH= liblgtk2
GTK2_BUILD_DEPENDS= lablgtk2:x11-toolkits/ocaml-lablgtk2
GTK2_RUN_DEPENDS= lablgtk2:x11-toolkits/ocaml-lablgtk2
+BINARY_ALIAS= freetype-config=true
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MXPM}
diff --git a/graphics/ocaml-images/files/patch-OMakefile b/graphics/ocaml-images/files/patch-OMakefile
index 469d16c417d5..3fe0f16e9845 100644
--- a/graphics/ocaml-images/files/patch-OMakefile
+++ b/graphics/ocaml-images/files/patch-OMakefile
@@ -1,6 +1,6 @@
---- OMakefile.orig 2012-11-07 22:03:19.000000000 +0100
-+++ OMakefile 2012-11-07 22:04:26.000000000 +0100
-@@ -22,13 +22,13 @@
+--- OMakefile.orig 2011-06-22 18:04:32 UTC
++++ OMakefile
+@@ -22,13 +22,13 @@ if $(defined WithOMyApt)
# Specify non standard include directories
INCLUDES[]=
@@ -18,3 +18,20 @@
# Specify directories where X's rgb.txt can be found
PATH_RGB_TXT[]=
+@@ -175,13 +175,13 @@ print_configured() =
+ OCAMLPACKS+=graphics
+ export
+
+- SUPPORT_FREETYPE = $(Check_prog_in_path freetype-config)
++ SUPPORT_FREETYPE = $(Check_prog_in_path pkg-config)
+ PATH_FREETYPE_CONFIG = $(WHERE)
+ LDFLAGS_freetype=
+ if $(SUPPORT_FREETYPE)
+ println(SUPPORT_FREETYPE=$(SUPPORT_FREETYPE)!)
+- CFLAGS= $(CFLAGS) $(shell freetype-config --cflags)
+- LDFLAGS_freetype= $(shell freetype-config --libs)
++ CFLAGS= $(CFLAGS) $(shell pkg-config freetype2 --cflags)
++ LDFLAGS_freetype= $(shell pkg-config freetype2 --libs)
+ export
+ if $(SUPPORT_FREETYPE)
+ SUPPORTED_NON_FORMATS+=freetype
diff --git a/graphics/ocaml-images/files/patch-configure b/graphics/ocaml-images/files/patch-configure
new file mode 100644
index 000000000000..224ee1fca92e
--- /dev/null
+++ b/graphics/ocaml-images/files/patch-configure
@@ -0,0 +1,13 @@
+--- configure.orig 2021-08-07 07:17:08 UTC
++++ configure
+@@ -8108,8 +8108,8 @@ fi
+
+
+ if test -n "$FREETYPE_CONFIG"; then
+- LIBFREETYPE=`freetype-config --libs`
+- INCFREETYPE=`freetype-config --cflags`
++ LIBFREETYPE=`pkg-config freetype2 --libs`
++ INCFREETYPE=`pkg-config freetype2 --cflags`
+ SUPPORT_FREETYPE="true"
+ fi
+ fi