aboutsummaryrefslogtreecommitdiff
path: root/graphics/ogre3d
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2013-05-22 19:34:18 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2013-05-22 19:34:18 +0000
commit2d209283ec16810f5aa3a055884d1f116c7ddd4c (patch)
treea1257305498b16428f9fe3508509e793457c2f77 /graphics/ogre3d
parente636fb64185d8e9f29a5add5b36164b03065a4e1 (diff)
downloadports-2d209283ec16810f5aa3a055884d1f116c7ddd4c.tar.gz
ports-2d209283ec16810f5aa3a055884d1f116c7ddd4c.zip
add patch file to fix building in case textproc/tinyxml is installed on the system
PR: 175763
Notes
Notes: svn path=/head/; revision=318792
Diffstat (limited to 'graphics/ogre3d')
-rw-r--r--graphics/ogre3d/files/patch-Tools_XMLConverter_CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/graphics/ogre3d/files/patch-Tools_XMLConverter_CMakeLists.txt b/graphics/ogre3d/files/patch-Tools_XMLConverter_CMakeLists.txt
new file mode 100644
index 000000000000..05a2faad21e4
--- /dev/null
+++ b/graphics/ogre3d/files/patch-Tools_XMLConverter_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- Tools/XMLConverter/CMakeLists.txt.orig 2013-05-21 20:52:22.000000000 +0200
++++ Tools/XMLConverter/CMakeLists.txt 2013-05-21 20:52:22.000000000 +0200
+@@ -27,6 +27,7 @@
+ src/tinyxmlparser.cpp
+ )
+
++set (CMAKE_INCLUDE_DIRECTORIES_BEFORE ON)
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR}/include)
+ add_definitions(-DTIXML_USE_STL)
+ ogre_add_executable(OgreXMLConverter ${HEADER_FILES} ${SOURCE_FILES})