aboutsummaryrefslogtreecommitdiff
path: root/graphics/opencv
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /graphics/opencv
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'graphics/opencv')
-rw-r--r--graphics/opencv/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index 9e8c609f72ea..e4c0e94041a0 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -8,10 +8,9 @@
PORTNAME= opencv
PORTVERSION= 1.0.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= opencvlibrary
+MASTER_SITES= SF/opencvlibrary
MAINTAINER= msabramo@yahoo.com
COMMENT= Open Source Computer Vision Library from Intel
@@ -56,7 +55,6 @@ OPTIONS= GTK "Enable GTK+-2.0 support" Off \
.include <bsd.port.pre.mk>
.if defined(WITH_GTK)
-USE_XLIB= yes
USE_GNOME= gtk20
CONFIGURE_ARGS+=--with-gtk
.else
@@ -86,9 +84,9 @@ CONFIGURE_ARGS+=--without-gtk
#.endif
.if defined(WITH_XINE)
-CFLAGS+= -I${X11BASE}/include
-CPPFLAGS+= -I${X11BASE}/include
-LDFLAGS+= -L${X11BASE}/lib
+CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
LIB_DEPENDS+= xine:${PORTSDIR}/multimedia/libxine
CONFIGURE_ARGS+=--with-xine
.else