aboutsummaryrefslogtreecommitdiff
path: root/graphics/openexr
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-01-03 16:57:29 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-01-03 16:57:29 +0000
commitc77c064297efe1486dfdc1841a15df8f6c354230 (patch)
tree02346dde01394e489acc60d118cca50cb13d8243 /graphics/openexr
parent68ef982e1b088f9f3eb01ef0f862ee3fbe16b8f8 (diff)
downloadports-c77c064297efe1486dfdc1841a15df8f6c354230.tar.gz
ports-c77c064297efe1486dfdc1841a15df8f6c354230.zip
graphics/openexr: really commit v2.5.4 update.
Unfortunately, this was missed with the ilmbase update, and causes yet another PORTREVISION bump on all dependent ports. repeating ilmbase's commit log here: "Patch release with various bug/sanitizer/security fixes, primarily related to reading corrupted input files." <https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v2.5.4> Cherry-pick upstream commit for GCC 11 compatibility: <https://github.com/AcademySoftwareFoundation/openexr/commit/a40a6151c4e746eb8f93c7c06992d0ec11289fdc> Since this changes the patchlevel of the solibs, bump PORTREVISION of dependent ports just to be sure. (graphics/py-openshadinglanguage is unaltered and .includes the revision bump from .../openshadinglanguage.) MFH: 2021Q1 (this requires discussion by ports-secteam@!) Reported by: VVD (IRC, #bsdports)
Notes
Notes: svn path=/head/; revision=560022
Diffstat (limited to 'graphics/openexr')
-rw-r--r--graphics/openexr/Makefile4
-rw-r--r--graphics/openexr/distinfo6
-rw-r--r--graphics/openexr/files/patch-IlmImf_ImfDwaCompressor.cpp10
-rw-r--r--graphics/openexr/files/patch-IlmImf_ImfTiledMisc.cpp10
4 files changed, 25 insertions, 5 deletions
diff --git a/graphics/openexr/Makefile b/graphics/openexr/Makefile
index b15d9d21e8bd..e94ebde8da97 100644
--- a/graphics/openexr/Makefile
+++ b/graphics/openexr/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openexr
-PORTVERSION= 2.5.3
+PORTVERSION= 2.5.4
CATEGORIES= graphics devel
MASTER_SITES= LOCAL/mandree/:test
DISTFILES= ${PORTNAME}-2.2.0-comp_dwa-test-images.tar.xz:test
@@ -42,7 +42,7 @@ _DOC_FILES2= *.odt *.pdf
MAJORVER= 2_5
_VER= 25
_MINVER= 0
-_PLVER= 2
+_PLVER= 3
PLIST_SUB+= MAJORVER=${MAJORVER} \
VER=${_VER} \
diff --git a/graphics/openexr/distinfo b/graphics/openexr/distinfo
index e445d0967c74..942e0c2d91f9 100644
--- a/graphics/openexr/distinfo
+++ b/graphics/openexr/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1597314241
+TIMESTAMP = 1609587933
SHA256 (openexr-2.2.0-comp_dwa-test-images.tar.xz) = bbb8ff547e9b68f0dfb1e8804a7ad984978c2b15897988399cc68176e99dd63a
SIZE (openexr-2.2.0-comp_dwa-test-images.tar.xz) = 653768
-SHA256 (AcademySoftwareFoundation-openexr-2.5.3-v2.5.3_GH0.tar.gz) = 6a6525e6e3907715c6a55887716d7e42d09b54d2457323fcee35a0376960bebf
-SIZE (AcademySoftwareFoundation-openexr-2.5.3-v2.5.3_GH0.tar.gz) = 27534825
+SHA256 (AcademySoftwareFoundation-openexr-2.5.4-v2.5.4_GH0.tar.gz) = dba19e9c6720c6f64fbc8b9d1867eaa75da6438109b941eefdc75ed141b6576d
+SIZE (AcademySoftwareFoundation-openexr-2.5.4-v2.5.4_GH0.tar.gz) = 27535491
diff --git a/graphics/openexr/files/patch-IlmImf_ImfDwaCompressor.cpp b/graphics/openexr/files/patch-IlmImf_ImfDwaCompressor.cpp
new file mode 100644
index 000000000000..1f5401729b26
--- /dev/null
+++ b/graphics/openexr/files/patch-IlmImf_ImfDwaCompressor.cpp
@@ -0,0 +1,10 @@
+--- IlmImf/ImfDwaCompressor.cpp.orig 2020-12-30 23:09:11 UTC
++++ IlmImf/ImfDwaCompressor.cpp
+@@ -156,6 +156,7 @@
+ #include <cctype>
+ #include <cassert>
+ #include <algorithm>
++#include <limits>
+
+ #include <cstddef>
+
diff --git a/graphics/openexr/files/patch-IlmImf_ImfTiledMisc.cpp b/graphics/openexr/files/patch-IlmImf_ImfTiledMisc.cpp
new file mode 100644
index 000000000000..6900672ff3ca
--- /dev/null
+++ b/graphics/openexr/files/patch-IlmImf_ImfTiledMisc.cpp
@@ -0,0 +1,10 @@
+--- IlmImf/ImfTiledMisc.cpp.orig 2020-12-30 23:09:11 UTC
++++ IlmImf/ImfTiledMisc.cpp
+@@ -45,6 +45,7 @@
+ #include <ImfChannelList.h>
+ #include <ImfTileDescription.h>
+ #include <algorithm>
++#include <limits>
+
+ #include "ImfNamespace.h"
+