aboutsummaryrefslogtreecommitdiff
path: root/graphics/openjpeg/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-08-22 09:07:49 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-08-22 09:07:49 +0000
commite9d3c6233cde12feee735b103206cb20bdff8639 (patch)
treebafd3ca036388a43bbff2dab94226a04809969b1 /graphics/openjpeg/Makefile
parent6aaea03402c59e55ec3ddc195ae80ca27b540c10 (diff)
downloadports-e9d3c6233cde12feee735b103206cb20bdff8639.tar.gz
ports-e9d3c6233cde12feee735b103206cb20bdff8639.zip
- Sort LIB_DEPENDS
- Use REINPLACE_CMD instead of patch file - Cleanup Makefile - Update WWW and pkg-descr - Take maintainership
Notes
Notes: svn path=/head/; revision=365622
Diffstat (limited to 'graphics/openjpeg/Makefile')
-rw-r--r--graphics/openjpeg/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/graphics/openjpeg/Makefile b/graphics/openjpeg/Makefile
index 0d32394db9e2..54a097f9c924 100644
--- a/graphics/openjpeg/Makefile
+++ b/graphics/openjpeg/Makefile
@@ -4,21 +4,23 @@
PORTNAME= openjpeg
PORTVERSION= 2.1.0
CATEGORIES= graphics
-MASTER_SITES= SF/openjpeg.mirror/${PORTVERSION}/
-#??
+MASTER_SITES= SF/openjpeg.mirror/${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Open-source JPEG 2000 codec
LICENSE= BSD2CLAUSE
-LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
+LIB_DEPENDS= liblcms2.so:${PORTSDIR}/graphics/lcms2 \
libpng15.so:${PORTSDIR}/graphics/png \
- liblcms2.so:${PORTSDIR}/graphics/lcms2
+ libtiff.so:${PORTSDIR}/graphics/tiff
-USES= cmake pkgconfig
USE_LDCONFIG= yes
+USES= cmake pkgconfig
PLIST_SUB= VER=${PORTVERSION:R}
+post-patch:
+ @${REINPLACE_CMD} -e 's|$${OPENJPEG_INSTALL_LIB_DIR}/pkgconfig|libdata/pkgconfig|' ${WRKSRC}/CMakeLists.txt
+
.include <bsd.port.mk>