aboutsummaryrefslogtreecommitdiff
path: root/graphics/optipng
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-03-29 14:02:29 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-03-29 14:02:29 +0000
commit4f668a032799305849c6d9622f17520492860c0e (patch)
tree654139a700069287ebbd2cd81d6d2d1419971ab2 /graphics/optipng
parentcb46ec5b88364a1414dc134da014fbcd5b4fe54f (diff)
downloadports-4f668a032799305849c6d9622f17520492860c0e.tar.gz
ports-4f668a032799305849c6d9622f17520492860c0e.zip
- Support staging
- Use new LIB_DEPENDS syntax PR: 187331 Submitted by: amdmi3 Approved by: maintainer timeout, portmgr (blanket)
Notes
Notes: svn path=/head/; revision=349512
Diffstat (limited to 'graphics/optipng')
-rw-r--r--graphics/optipng/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/graphics/optipng/Makefile b/graphics/optipng/Makefile
index 7f4a15937d08..fe893d8fe807 100644
--- a/graphics/optipng/Makefile
+++ b/graphics/optipng/Makefile
@@ -18,19 +18,17 @@ BUNDLED_LIBPNG_DESC= Use bundled libpng
BUNDLED_ZLIB_DESC= Use bundled zlib
HAS_CONFIGURE= yes
-PLIST_FILES= bin/optipng
-MAN1= optipng.1
+PLIST_FILES= bin/optipng man/man1/optipng.1.gz
PORTDOCS= history.txt optipng.man.html optipng.man.pdf optipng.man.txt \
png_optimization.html todo.txt
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if empty(PORT_OPTIONS:MBUNDLED_LIBPNG)
CONFIGURE_ARGS+= --with-system-libpng
CFLAGS+= "-I${LOCALBASE}/include"
LDFLAGS+= "-L${LOCALBASE}/lib"
-LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png
.endif
.if empty(PORT_OPTIONS:MBUNDLED_ZLIB)
@@ -38,13 +36,11 @@ CONFIGURE_ARGS+= --with-system-zlib
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/optipng/optipng ${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/src/optipng/man/optipng.1 ${MAN1PREFIX}/man/man1/
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/optipng/optipng ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/src/optipng/man/optipng.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${INSTALL} -d ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${DOCSDIR}/
-.endif
+ ${INSTALL} -d ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>